[PATCH 1/1] gnu: Add cyrus-sasl-xoauth2.

  • Open
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • peter
Owner
unassigned
Submitted by
peter
Severity
normal
Merged with
P
P
peter wrote on 4 Nov 2022 18:56
(address . guix-patches@gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
95c44daa0deb5d5104a40c97c15b38299ec34c01.1667583886.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/cyrus-sasl.scm (cyrus-sasl-xoauth2): New variable.
---
gnu/packages/cyrus-sasl.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index 2cd18f3e5e..ddb8c476ac 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,6 +29,7 @@ (define-module (gnu packages cyrus-sasl)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu))
(define-public cyrus-sasl
@@ -78,3 +80,33 @@ (define-public cyrus-sasl
(license (license:non-copyleft "file://COPYING"
"See COPYING in the distribution."))
(home-page "https://cyrusimap.org/sasl/")))
+
+(define-public cyrus-sasl-xoauth2
+ (package
+ (name "cyrus-sasl-xoauth2")
+ (version "0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/moriyoshi/cyrus-sasl-xoauth2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1py9f1mn5k5xihrk0lfrwr6723c22gjb7lmgya83ibvislm2x3wl"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; Not sure what is required here in order to get this installed into the
+ ;; correct location. Maybe it needs to be installed in the plugindir for
+ ;; the cyrus-sasl package above? Not sure how to reference that directory
+ ;; in this package though.
+ '(#:configure-flags (list (string-append "--prefix="
+ (assoc-ref %outputs "out")
+ "/lib/sasl2"))))
+ (native-inputs (list autoconf automake libtool))
+ (inputs (list cyrus-sasl))
+ (home-page "https://github.com/moriyoshi/cyrus-sasl-xoauth2")
+ (synopsis "XOAUTH2 mechanism plugin for cyrus-sasl")
+ (description "XOAUTH2 mechanism plugin for cyrus-sasl.")
+ (license (list license:expat license:expat))))
+
--
2.38.0
L
L
Ludovic Courtès wrote on 15 Nov 2022 11:42
control message for bug #59019
(address . control@debbugs.gnu.org)
87wn7wmrcm.fsf@gnu.org
merge 59019 59018
quit
?