[PATCH ...] gnu: Add the-way.

  • Open
  • quality assurance status badge
Details
One participant
  • jgart
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote on 1 Nov 2022 00:11
(name . Guix Patches)(address . guix-patches@gnu.org)
20221031181123.GB25487@dismail.de

J
J
jgart wrote on 1 Nov 2022 02:46
[PATCH 1/2] gnu: Add crates for the-way.
(address . 58936@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20221101014611.30081-1-jgart@dismail.de
* gnu/packages/crates-io.scm (crates for the-way): New variable.
---
gnu/packages/crates-io.scm | 3430 ++++++++++++++++++++++++++++++++++++
1 file changed, 3430 insertions(+)

Toggle diff (489 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b216ed0baf..a28b6b35e7 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -68483,6 +68483,3436 @@ (define-public rust-pam-sys-0.5
(license (list license:expat license:asl2.0))))
;;;
+
+
+(define-public rust-predicates-2
+ (package
+ (name "rust-predicates")
+ (version "2.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "predicates" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0g0cjv6nn2s18kzsa3nkfhv7myxv9lbb710r0xrv8cj7dszbbam5"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-concolor" ,rust-concolor-0.0.8)
+ ("rust-difflib" ,rust-difflib-0.4)
+ ("rust-float-cmp" ,rust-float-cmp-0.9)
+ ("rust-itertools" ,rust-itertools-0.10)
+ ("rust-normalize-line-endings" ,rust-normalize-line-endings-0.3)
+ ("rust-predicates-core" ,rust-predicates-core-1)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-yansi" ,rust-yansi-0.5))))
+ (home-page "https://github.com/assert-rs/predicates-rs")
+ (synopsis "An implementation of boolean-valued predicate functions.")
+ (description "An implementation of boolean-valued predicate functions.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-ptyprocess-0.3
+ (package
+ (name "rust-ptyprocess")
+ (version "0.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "ptyprocess" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "05qrrrhwg1b4j1sg4cdypv0sh3i3471ryh39kphvyhnqpz78zhk9"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-nix" ,rust-nix-0.21))))
+ (home-page "https://github.com/zhiburt/ptyprocess")
+ (synopsis "A library to work with PTY/TTY on Unix systems")
+ (description
+ "This package provides a library to work with PTY/TTY on Unix systems")
+ (license license:expat)))
+
+(define-public rust-futures-lite-1
+ (package
+ (name "rust-futures-lite")
+ (version "1.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "futures-lite" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0j5zzjcq1ib2kf1mm3apqf9g2ly1jjw1d1d4v9vjqi9rrnd4i53n"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-fastrand" ,rust-fastrand-1)
+ ("rust-futures-core" ,rust-futures-core-0.3)
+ ("rust-futures-io" ,rust-futures-io-0.3)
+ ("rust-memchr" ,rust-memchr-2)
+ ("rust-parking" ,rust-parking-2)
+ ("rust-pin-project-lite" ,rust-pin-project-lite-0.2)
+ ("rust-waker-fn" ,rust-waker-fn-1))))
+ (home-page "https://github.com/smol-rs/futures-lite")
+ (synopsis "Futures, streams, and async I/O combinators")
+ (description "Futures, streams, and async I/O combinators")
+ (license (list license:asl2.0 license:expat))))
+
+(define-public rust-windows-x86-64-msvc-0.29
+ (package
+ (name "rust-windows-x86-64-msvc")
+ (version "0.29.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_x86_64_msvc" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0q9m9brirmxh6jpnzjk54xxnpi5504raakc8h3174dpdv4hm9n8i"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Code gen support for the windows crate")
+ (description "Code gen support for the windows crate")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-windows-x86-64-gnu-0.29
+ (package
+ (name "rust-windows-x86-64-gnu")
+ (version "0.29.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_x86_64_gnu" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0m63i7l2qb3ayd9n8vl19yy9rwbgv3q3lcmksbbhngjl37s1bmpk"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Code gen support for the windows crate")
+ (description "Code gen support for the windows crate")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-windows-macros-0.29
+ (package
+ (name "rust-windows-macros")
+ (version "0.29.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_macros" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "18rrxxypm1gcj8mca461iv5xr07ng3p83z679hgyj33n3zvl6r3g"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-syn" ,rust-syn-1)
+ ("rust-windows-gen" ,rust-windows-gen-0.29)
+ ("rust-windows-quote" ,rust-windows-quote-0.29)
+ ("rust-windows-reader" ,rust-windows-reader-0.29))))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Rust for Windows")
+ (description "Rust for Windows")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-windows-i686-msvc-0.29
+ (package
+ (name "rust-windows-i686-msvc")
+ (version "0.29.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_i686_msvc" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1r3ag5b8gaq1hkv5mizl2yj3pplmz7si5icn56z28w5n332gc0l6"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Code gen support for the windows crate")
+ (description "Code gen support for the windows crate")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-windows-i686-gnu-0.29
+ (package
+ (name "rust-windows-i686-gnu")
+ (version "0.29.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_i686_gnu" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0n5skfwab74n7f15zs4a36bk1fc7gmlv4lm6l7nh32wfgfgzb4w7"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Code gen support for the windows crate")
+ (description "Code gen support for the windows crate")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-windows-reader-0.29
+ (package
+ (name "rust-windows-reader")
+ (version "0.29.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_reader" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "11sp959c5qjc9yivvqrlns5j4269cb91xzkg8g2x7fjp8k038yyq"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Rust for Windows")
+ (description "Rust for Windows")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-windows-quote-0.29
+ (package
+ (name "rust-windows-quote")
+ (version "0.29.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_quote" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0g42bwxhcn78f4apkqkb6nf0l7dpa448lzjs24xxr4f3swh3zn0x"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Code gen support for the windows crate")
+ (description "Code gen support for the windows crate")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-windows-gen-0.29
+ (package
+ (name "rust-windows-gen")
+ (version "0.29.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_gen" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "02yz65cld8w4xl8bq4bmb345h7zcf07qajk0pc8rj0hsyjgbd7p5"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-windows-quote" ,rust-windows-quote-0.29)
+ ("rust-windows-reader" ,rust-windows-reader-0.29))))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Rust for Windows")
+ (description "Rust for Windows")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-windows-aarch64-msvc-0.29
+ (package
+ (name "rust-windows-aarch64-msvc")
+ (version "0.29.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_aarch64_msvc" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "16sxpz2b2ljjrax6qy1m18ri4fz0xfv6lzdrpq61xc00blbjgl63"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Code gen support for the windows crate")
+ (description "Code gen support for the windows crate")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-windows-0.29
+ (package
+ (name "rust-windows")
+ (version "0.29.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1wwwz94m6ia1b8znpzyx83j49aq3jb60d51k545csnab5zqzxixa"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-windows-aarch64-msvc" ,rust-windows-aarch64-msvc-0.29)
+ ("rust-windows-gen" ,rust-windows-gen-0.29)
+ ("rust-windows-i686-gnu" ,rust-windows-i686-gnu-0.29)
+ ("rust-windows-i686-msvc" ,rust-windows-i686-msvc-0.29)
+ ("rust-windows-macros" ,rust-windows-macros-0.29)
+ ("rust-windows-reader" ,rust-windows-reader-0.29)
+ ("rust-windows-x86-64-gnu" ,rust-windows-x86-64-gnu-0.29)
+ ("rust-windows-x86-64-msvc" ,rust-windows-x86-64-msvc-0.29))))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Rust for Windows")
+ (description "Rust for Windows")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-conpty-0.3
+ (package
+ (name "rust-conpty")
+ (version "0.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "conpty" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0m27fflp74g0vi1gg6c7r7dbjypd9bmsi839pgwxfwv20bjalywp"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-windows" ,rust-windows-0.29))))
+ (home-page "https://github.com/zhiburt/conpty")
+ (synopsis "A library which provides an interface for ConPTY")
+ (description
+ "This package provides a library which provides an interface for ConPTY")
+ (license license:expat)))
+
+(define-public rust-blocking-1
+ (package
+ (name "rust-blocking")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "blocking" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1k6ci9rflwr14izydrmvnfm0zab9xmyl714qns3a0y498rfvdk66"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-async-channel" ,rust-async-channel-1)
+ ("rust-async-task" ,rust-async-task-4)
+ ("rust-atomic-waker" ,rust-atomic-waker-1)
+ ("rust-fastrand" ,rust-fastrand-1)
+ ("rust-futures-lite" ,rust-futures-lite-1)
+ ("rust-once-cell" ,rust-once-cell-1))))
+ (home-page "https://github.com/smol-rs/blocking")
+ (synopsis "A thread pool for isolating blocking I/O in async programs")
+ (description
+ "This package provides a thread pool for isolating blocking I/O in async programs")
+ (license (list license:asl2.0 license:expat))))
+
+(define-public rust-async-lock-2
+ (package
+ (name "rust-async-lock")
+ (version "2.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "async-lock" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "11dn0wblps0rhjp8izykjan1irspaca0454i09zc39lmhvz1w468"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-event-listener" ,rust-event-listener-2)
+ ("rust-futures-lite" ,rust-futures-lite-1))))
+ (home-page "https://github.com/smol-rs/async-lock")
+ (synopsis "Async synchronization primitives")
+ (description "Async synchronization primitives")
+ (license (list license:asl2.0 license:expat))))
+
+(define-public rust-async-io-1
+ (package
+ (name "rust-async-io")
+ (version "1.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "async-io" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1xqc97ygpws4yq37kfs8w1i3nfr48wbnn6d49bryfnzhm6b144p8"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-async-lock" ,rust-async-lock-2)
+ ("rust-autocfg" ,rust-autocfg-1)
+ ("rust-concurrent-queue" ,rust-concurrent-queue-1)
+ ("rust-futures-lite" ,rust-futures-lite-1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-parking" ,rust-parking-2)
+ ("rust-polling" ,rust-polling-2)
+ ("rust-slab" ,rust-slab-0.4)
+ ("rust-socket2" ,rust-socket2-0.4)
+ ("rust-waker-fn" ,rust-waker-fn-1)
+ ("rust-winapi" ,rust-winapi-0.3))))
+ (home-page "https://github.com/smol-rs/async-io")
+ (synopsis "Async I/O and timers")
+ (description "Async I/O and timers")
+ (license (list license:asl2.0 license:expat))))
+
+(define-public rust-expectrl-0.5
+ (package
+ (name "rust-expectrl")
+ (version "0.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "expectrl" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1y021c2zdzj7n7r2wmjnv6k5ynjik745mwjlsj24j4p39qgy3597"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-async-io" ,rust-async-io-1)
+ ("rust-blocking" ,rust-blocking-1)
+ ("rust-conpty" ,rust-conpty-0.3)
+ ("rust-futures-lite" ,rust-futures-lite-1)
+ ("rust-futures-timer" ,rust-futures-timer-3)
+ ("rust-nix" ,rust-nix-0.23)
+ ("rust-ptyprocess" ,rust-ptyprocess-0.3)
+ ("rust-regex" ,rust-regex-1))))
+ (home-page "https://github.com/zhiburt/expectrl")
+ (synopsis
+ "A tool for automating terminal applications in Unix like Don libes expect")
+ (description
+ "This package provides a tool for automating terminal applications in Unix like
+Don libes expect")
+ (license license:expat)))
+
+(define-public rust-xcb-0.8
+ (package
+ (name "rust-xcb")
+ (version "0.8.2")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "xcb" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ph27r9nxyfy3hh1c7x85g6dciwxcinf6514pvw9ybhl4hzpm4ay"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-libc" ,rust-libc-0.2)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-x11" ,rust-x11-2))))
+ (home-page "https://github.com/rust-x-bindings/rust-xcb")
+ (synopsis "Rust safe bindings for XCB")
+ (description "Rust safe bindings for XCB")
+ (license license:expat)))
+
+(define-public rust-x11-clipboard-0.3
+ (package
+ (name "rust-x11-clipboard")
+ (version "0.3.3")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "x11-clipboard" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1smwyr23jns0dncm6bwv00xfxxy99bv6qlx6df7dkdcydk04kgc9"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-xcb" ,rust-xcb-0.8))))
+ (home-page "https://github.com/quininer/x11-clipboard")
+ (synopsis "x11 clipboard support for Rust.")
+ (description "x11 clipboard support for Rust.")
+ (license license:expat)))
+
+(define-public rust-clipboard-win-2
+ (package
+ (name "rust-clipboard-win")
+ (version "2.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "clipboard-win" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0svqk0lrw66abaxd6h7l4k4g2s5vd1dcipy34kzfan6mzvb97873"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-winapi" ,rust-winapi-0.3))))
+ (home-page "https://github.com/DoumanAsh/clipboard-win")
+ (synopsis "Provides simple way to interact with Windows clipboard.")
+ (description
+ "This package provides simple way to interact with Windows clipboard.")
+ (license license:expat)))
+
+(define-public rust-clipboard-0.5
+ (package
+ (name "rust-clipboard")
+ (version "0.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "clipboard" version))
+ (file-name (string-append name "
This message was truncated. Download the full message here.
J
J
jgart wrote on 1 Nov 2022 02:46
[PATCH 2/2] gnu: Add the-way.
(address . 58936@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20221101014611.30081-2-jgart@dismail.de
* gnu/packages/rust-apps.scm (the-way): New variable.
---
gnu/packages/rust-apps.scm | 50 ++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 693489264d..0935c037c6 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -2062,3 +2062,53 @@ (define-public zoxide
track of the directories you use most frequently, and uses a ranking algorithm
to navigate to the best match.")
(license license:expat)))
+
+(define-public the-way
+ (package
+ (name "the-way")
+ (version "0.18.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "the-way" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "19pipvr35i4lfpk01f8gfjpp9rwr8p2qbmgyqgclr1lir2aa8slq"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-bincode" ,rust-bincode-1)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-chrono-english" ,rust-chrono-english-0.1)
+ ("rust-clap" ,rust-clap-3)
+ ("rust-clap-complete" ,rust-clap-complete-3)
+ ("rust-color-eyre" ,rust-color-eyre-0.6)
+ ("rust-confy" ,rust-confy-0.4)
+ ("rust-dialoguer" ,rust-dialoguer-0.10)
+ ("rust-directories-next" ,rust-directories-next-1)
+ ("rust-eyre" ,rust-eyre-0.6)
+ ("rust-grep-cli" ,rust-grep-cli-0.1)
+ ("rust-hex" ,rust-hex-0.4)
+ ("rust-indicatif" ,rust-indicatif-0.17)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-serde-yaml" ,rust-serde-yaml-0.9)
+ ("rust-skim" ,rust-skim-0.9)
+ ("rust-sled" ,rust-sled-0.34)
+ ("rust-strum" ,rust-strum-0.24)
+ ("rust-strum-macros" ,rust-strum-macros-0.24)
+ ("rust-syntect" ,rust-syntect-5)
+ ("rust-termcolor" ,rust-termcolor-1)
+ ("rust-thiserror" ,rust-thiserror-1)
+ ("rust-ureq" ,rust-ureq-2))
+ #:cargo-development-inputs (("rust-assert-cmd" ,rust-assert-cmd-2)
+ ("rust-clipboard" ,rust-clipboard-0.5)
+ ("rust-expectrl" ,rust-expectrl-0.5)
+ ("rust-predicates" ,rust-predicates-2)
+ ("rust-tempfile" ,rust-tempfile-3))))
+ (home-page "https://github.com/out-of-cheese-error/the-way")
+ (synopsis "Code snippets manager for your terminal")
+ (description
+ "This package provides a code snippets manager for your terminal.")
+ (license license:expat)))
--
2.38.1
J
J
jgart wrote on 1 Nov 2022 02:48
Re: bug#58936: Acknowledgement ([PATCH ...] gnu: Add the-way.)
(address . 58936@debbugs.gnu.org)
20221031204852.GB30192@dismail.de
On Mon, 31 Oct 2022 23:12:02 +0000 help-debbugs@gnu.org (GNU bug Tracking System) wrote:

Hi,

I'll send an update once I learn how to use etc/commmiter.scm to automate adding all these crates.
?