[PATCH] gnu: python-filelock: Update to 3.8.0.

  • Done
  • quality assurance status badge
Details
One participant
  • Tanguy Le Carrour
Owner
unassigned
Submitted by
Tanguy Le Carrour
Severity
normal
T
T
Tanguy Le Carrour wrote on 26 Oct 2022 09:13
(address . guix-patches@gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20221026071312.4635-1-tanguy@bioneland.org
Hi Guix,

This patch is trivial, but it triggers 5,000+ package rebuilds.
I need it in order to upgrade `python-virtualenv` (I'm still working on it)
… which I need to upgrade `poetry`.

Regards,


* gnu/packages/python-xyz.scm (python-filelock): Update to 3.8.0.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 08a33061a9..eacb54d406 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1978,14 +1978,14 @@ (define-public python-fb-re2
(define-public python-filelock
(package
(name "python-filelock")
- (version "3.0.12")
+ (version "3.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "filelock" version))
(sha256
(base32
- "0ngzlvb5j8gqs2nxlp2b0jhzii792h66wsn694qm8kqixr225n0q"))))
+ "1p2f1il288abcrjx002w25dzl9jd1392cfminv2rh8bgcsm7qi2m"))))
(build-system python-build-system)
(home-page
"https://github.com/benediktschmitt/py-filelock")
--
2.38.0
T
T
Tanguy LE CARROUR wrote on 26 Oct 2022 10:03
Re: bug#58792: Acknowledgement ([PATCH] gnu: python-filelock: Update to 3.8.0.)
(address . 58792@debbugs.gnu.org)
166677139827.9762.17717851787532695386@localhost
Hi Guix,

Contrary to what I said, this patch might not be trivial!

The resulting package exposes version 0.0.0, which seems to break every
package that depends on it!
The issue has been reported upstream [1][]. The solution would be to use
a different build system.


I'm working on it…

--
Tanguy
T
T
Tanguy Le Carrour wrote on 26 Oct 2022 15:44
[PATCH v2 1/2] gnu: python-filelock: Update to 3.8.0.
(address . 58792@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20221026134435.16235-1-tanguy@bioneland.org
Hi Guix,

This was less trivial than what I expected, indeed.
I'm adding python-virtualenv to the patch set as it now builds.

Unfortunately, I couldn't make it up to Poetry, because, for
unknown reasons (to me), building poetry with updated python-filelock
and python-virtualenv triggers a **LOT** of rebuilds! I `Ctrl+c` the
process when it started building things related to wayland and to
modem-manager!? If someone was kind enough to tell me why, it would be
very much appreciated!

Thanks

* gnu/packages/python-xyz.scm (python-filelock): Update to 3.8.0.
[arguments]<#:phases>: Build the package PyPA's style.
[native-inputs]: Add python-pypa-build, python-setuptools,
python-setuptools-scm.
---
gnu/packages/python-xyz.scm | 36 ++++++++++++++++++++++++++++++++++--
1 file changed, 34 insertions(+), 2 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 08a33061a9..655d4501b0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1978,15 +1978,47 @@ (define-public python-fb-re2
(define-public python-filelock
(package
(name "python-filelock")
- (version "3.0.12")
+ (version "3.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "filelock" version))
(sha256
(base32
- "0ngzlvb5j8gqs2nxlp2b0jhzii792h66wsn694qm8kqixr225n0q"))))
+ "1p2f1il288abcrjx002w25dzl9jd1392cfminv2rh8bgcsm7qi2m"))))
(build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'compatibility-fixes
+ (lambda _
+ ;; We have an outdated version of setuptools-scm
+ (substitute* "pyproject.toml" (("7.0.5") "6.3.2"))))
+ (replace 'build
+ (lambda _
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)
+ ;; ZIP does not support timestamps before 1980.
+ (setenv "SOURCE_DATE_EPOCH" "315532800")
+ (invoke "python"
+ "-m"
+ "build"
+ "--wheel"
+ "--no-isolation"
+ ".")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((whl (car (find-files "dist" "\\.whl$"))))
+ (invoke "pip"
+ "--no-cache-dir"
+ "--no-input"
+ "install"
+ "--no-deps"
+ "--prefix"
+ #$output
+ whl))))
+ (delete 'check)))) ; pytest causes a circular dependency (?)
+ (native-inputs (list python-pypa-build python-setuptools python-setuptools-scm))
(home-page
"https://github.com/benediktschmitt/py-filelock")
(synopsis "Platform independent file lock")
--
2.38.0
T
T
Tanguy Le Carrour wrote on 26 Oct 2022 15:44
[PATCH v2 2/2] gnu: python-virtualenv: Update to 20.16.5.
(address . 58792@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20221026134435.16235-2-tanguy@bioneland.org
Regarding this patch, I tried and failed updating python-distlib.
I ran into a GPG key issue that I didn't know how to solve.

* gnu/packages/python-xyz.scm (python-virtualenv): Update to 20.16.5.
[arguments]<#:phases>: Add phase compatibility-fixes.
[propagated-inputs]: Add python-platformdirs.
---
gnu/packages/python-xyz.scm | 13 ++++++++++---
1 file changed, 10 insertions(+), 3 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 655d4501b0..0fc6a2c885 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4056,19 +4056,26 @@ (define-public python-vine
(define-public python-virtualenv
(package
(name "python-virtualenv")
- (version "20.3.1")
+ (version "20.16.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "virtualenv" version))
(sha256
(base32
- "1nbhnpzswcf3lmzn5xabmfdd7ki8r2w2i37y6wml54di6qi1l48c"))))
+ "1nl09v092ap469krvgl5x9r78v99xy1k7fkp36imxp2gk6ws2zi2"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'compatibility-fixes
+ (lambda _
+ ;; We have an outdated version of distlib
+ (substitute* "setup.cfg" (("0.3.5") "0.3.1")))))))
(native-inputs
(list python-mock python-pytest python-setuptools-scm))
(propagated-inputs
- (list python-appdirs python-distlib python-filelock python-six))
+ (list python-appdirs python-distlib python-filelock python-platformdirs python-six))
(home-page "https://virtualenv.pypa.io/")
(synopsis "Virtual Python environment builder")
(description
--
2.38.0
T
T
Tanguy Le Carrour wrote on 5 Nov 2022 12:24
[PATCH v3 1/2] gnu: python-filelock: Update to 3.8.0.
(address . 58792@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20221105112435.20540-1-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-filelock): Update to 3.8.0.
[build-system]: Use pyproject-build-system.
[arguments]: Add a phase to fix compatibility issues with
python-setuptools-scm. [native-inputs]: Add python-setuptools-scm.
---
gnu/packages/python-xyz.scm | 16 +++++++++++++---
1 file changed, 13 insertions(+), 3 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 75e1dcc0cb..83e86b21fd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2114,15 +2114,25 @@ (define-public python-fb-re2
(define-public python-filelock
(package
(name "python-filelock")
- (version "3.0.12")
+ (version "3.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "filelock" version))
(sha256
(base32
- "0ngzlvb5j8gqs2nxlp2b0jhzii792h66wsn694qm8kqixr225n0q"))))
- (build-system python-build-system)
+ "1p2f1il288abcrjx002w25dzl9jd1392cfminv2rh8bgcsm7qi2m"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'compatibility-fixes
+ (lambda _
+ ;; We have an outdated version of setuptools-scm
+ (substitute* "pyproject.toml" (("7.0.5") "6.3.2")))))))
+ ;; Required for the version to be properly defined in METADATA
+ (native-inputs (list python-setuptools-scm))
(home-page
"https://github.com/benediktschmitt/py-filelock")
(synopsis "Platform independent file lock")
--
2.38.0
T
T
Tanguy Le Carrour wrote on 5 Nov 2022 12:24
[PATCH v3 2/2] gnu: python-virtualenv: Update to 20.16.5.
(address . 58792@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20221105112435.20540-2-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-virtualenv): Update to 20.16.5.
[arguments]<#:phases>: Add phase compatibility-fixes.
[propagated-inputs]: Add python-platformdirs.
---
gnu/packages/python-xyz.scm | 13 ++++++++++---
1 file changed, 10 insertions(+), 3 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 83e86b21fd..d6efd92bcf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4149,19 +4149,26 @@ (define-public python-vine
(define-public python-virtualenv
(package
(name "python-virtualenv")
- (version "20.3.1")
+ (version "20.16.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "virtualenv" version))
(sha256
(base32
- "1nbhnpzswcf3lmzn5xabmfdd7ki8r2w2i37y6wml54di6qi1l48c"))))
+ "1nl09v092ap469krvgl5x9r78v99xy1k7fkp36imxp2gk6ws2zi2"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'compatibility-fixes
+ (lambda _
+ ;; We have an outdated version of distlib
+ (substitute* "setup.cfg" (("0.3.5") "0.3.1")))))))
(native-inputs
(list python-mock python-pytest python-setuptools-scm))
(propagated-inputs
- (list python-appdirs python-distlib python-filelock python-six))
+ (list python-appdirs python-distlib python-filelock python-platformdirs python-six))
(home-page "https://virtualenv.pypa.io/")
(synopsis "Virtual Python environment builder")
(description
--
2.38.0
T
T
Tanguy LE CARROUR wrote on 29 Feb 09:20 +0100
Re: [PATCH] gnu: python-filelock: Update to 3.8.0.
(address . 58792-done@debbugs.gnu.org)
170919480926.3699.15689045686448599483@bioneland.org
Hi Guix,

I’m closing this old bug, because:

- the patch set probably does not apply anymore;
- even if the affected packages still need to be updated,
I don’t need them anymore as —long story short—,
I’m not trying to make Poetry available in Guix.

Regards,

--
Tanguy
Closed
T
T
Tanguy LE CARROUR wrote on 29 Feb 09:32 +0100
(address . 58792@debbugs.gnu.org)
170919556910.6681.12889508968659293411@bioneland.org
Hi Guix,

I’m closing this old bug, because:

- the patch set probably does not apply anymore;
- even if the affected packages still need to be updated,
I don’t need them anymore as —long story short—,
I’m not trying to make Poetry available in Guix.

Regards,

--
Tanguy
?