[PATCH] gnu: Add emacs-macrostep-geiser.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 25 Sep 2022 03:16
(address . guix-patches@gnu.org)
y76tu4w45j4.wl-hako@ultrarare.space
* gnu/packages/emacs-xyz.scm (emacs-macrostep-geiser): New variable.
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d324b39af3..9df7dcd1c6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20612,6 +20612,29 @@ (define-public emacs-macrostep
expansions for debugging with Edebug as normal.")
(license license:gpl3+))))
+(define-public emacs-macrostep-geiser
+ (let ((commit "f6a2d5bb96ade4f23df557649af87ebd0cc45125")
+ (revision "1"))
+ (package
+ (name "emacs-macrostep-geiser")
+ (version (git-version "0.2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nbfalcon/macrostep-geiser")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dykvwcvg8n24z3fkx6rv3l1mhzmca4cxj0gsvvqsg9wp0az1fc7"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-macrostep emacs-geiser))
+ (home-page "https://github.com/nbfalcon/macrostep-geiser")
+ (synopsis "macrostep for geiser and cider")
+ (description
+ "This plug-in implements a macrostep back-end powered by geiser.")
+ (license license:gpl3+))))
+
(define-public emacs-parent-mode
(package
(name "emacs-parent-mode")
--
2.37.3
N
N
Nicolas Goaziou wrote on 25 Sep 2022 15:22
(name . Hilton Chain via Guix-patches via)(address . guix-patches@gnu.org)
87mtantwqo.fsf@nicolasgoaziou.fr
Hello,

Hilton Chain via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-macrostep-geiser): New variable.

Thank you. I applied the patch with the following changes:

Toggle quote (7 lines)
> +(define-public emacs-macrostep-geiser
> + (let ((commit "f6a2d5bb96ade4f23df557649af87ebd0cc45125")
> + (revision "1"))
> + (package
> + (name "emacs-macrostep-geiser")
> + (version (git-version "0.2.0" revision commit))

I downgraded the commit used to the one matching the version bump. As
a consequence, version is exactly "0.2.0", which is always nicer when
subsequent changes do not bring much to the table.

Toggle quote (2 lines)
> + (propagated-inputs (list emacs-macrostep emacs-geiser))

I ordered inputs alphabetically.

Toggle quote (4 lines)
> + (synopsis "macrostep for geiser and cider")
> + (description
> + "This plug-in implements a macrostep back-end powered by geiser.")

I used capitalization for Macrostep and Geiser.

Regards,
--
Nicolas Goaziou
?