[PATCH 0/2] gnu: Add qtwayland, version 6.3.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 25 Sep 2022 02:32
(address . guix-patches@gnu.org)
y76r100fg3z.wl-hako@ultrarare.space
Hilton Chain (2):
gnu: qtwayland: Rename to qtwayland-5.
gnu: Add qtwayland, version 6.3.1.

gnu/packages/kde-frameworks.scm | 2 +-
gnu/packages/kde-plasma.scm | 2 +-
gnu/packages/qt.scm | 53 +++++++++++++++++++++++++++++++--
gnu/packages/telegram.scm | 2 +-
gnu/packages/video.scm | 2 +-
5 files changed, 55 insertions(+), 6 deletions(-)


base-commit: b79bdbe2ec12de3058720866290201f3cbf72092
--
2.37.3
H
H
Hilton Chain wrote on 25 Sep 2022 02:34
[PATCH 1/2] gnu: qtwayland: Rename to qtwayland-5.
(address . guix-patches@gnu.org)
y76pmfkfg0l.wl-hako@ultrarare.space
Automated via:

git grep -l qtwayland | xargs sed 's/\qtwayland\b/\0-5/g' -i
git checkout NEWS
---
gnu/packages/kde-frameworks.scm | 2 +-
gnu/packages/kde-plasma.scm | 2 +-
gnu/packages/qt.scm | 4 ++--
gnu/packages/telegram.scm | 2 +-
gnu/packages/video.scm | 2 +-
5 files changed, 6 insertions(+), 6 deletions(-)

Toggle diff (76 lines)
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 738013fdba..62de3e38ad 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1077,7 +1077,7 @@ (define-public kwayland
(native-inputs
(list extra-cmake-modules pkg-config))
(inputs
- (list qtbase-5 qtwayland wayland wayland-protocols))
+ (list qtbase-5 qtwayland-5 wayland wayland-protocols))
(arguments
`(#:tests? #f ; FIXME tests require weston to run
; weston requires wayland flags in mesa
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 39716187fd..064f5f7278 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -177,7 +177,7 @@ (define-public layer-shell-qt
(list libxkbcommon
qtbase-5
qtdeclarative-5
- qtwayland
+ qtwayland-5
wayland
wayland-protocols))
(home-page "https://invent.kde.org/plasma/layer-shell-qt")
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index cb7f72e698..bf978eec50 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -220,7 +220,7 @@ (define-public materialdecoration
(list cmake-shared extra-cmake-modules pkg-config))
(inputs
`(("qtbase" ,qtbase-5)
- ("qtwayland" ,qtwayland)
+ ("qtwayland" ,qtwayland-5)
("wayland" ,wayland)
("xkbcommon" ,libxkbcommon)))
(synopsis "Material Decoration for Qt")
@@ -1450,7 +1450,7 @@ (define-public qtmultimedia
set of plugins for interacting with pulseaudio and GStreamer.")
(license (package-license qtbase))))
-(define-public qtwayland
+(define-public qtwayland-5
(package (inherit qtsvg-5)
(name "qtwayland")
(version "5.15.2")
diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index 6c9869f93e..10061059f6 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -588,7 +588,7 @@ (define-public telegram-desktop
qtsvg-5
qt5ct
qtimageformats
- qtwayland
+ qtwayland-5
range-v3
rlottie-for-telegram-desktop
rnnoise
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f07fe192ed..98e2f38148 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3385,7 +3385,7 @@ (define-public obs
qtbase-5
qtsvg-5
qtx11extras
- qtwayland
+ qtwayland-5
speexdsp
v4l-utils
wayland
--
2.37.3
H
H
Hilton Chain wrote on 25 Sep 2022 02:35
[PATCH 2/2] gnu: Add qtwayland, version 6.3.1.
(address . guix-patches@gnu.org)
y76o7v4ffzu.wl-hako@ultrarare.space
* gnu/packages/qt.scm (qtwayland): New variable.
---
gnu/packages/qt.scm | 49 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 49 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index bf978eec50..25b246d7d4 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1500,6 +1500,55 @@ (define-public qtwayland-5
(description "The Qt Wayland module provides the QtWayland client and
compositor libraries.")))
+(define-public qtwayland
+ (package (inherit qtsvg)
+ (name "qtwayland")
+ (version "6.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (qt-urls name version))
+ (sha256
+ (base32
+ "1w60p1did7awdlzq5k8vnq2ncpskb07cpvz31cbv99bjs6igw53g"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments qtsvg)
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ ;; FIXME: tst_seatv4::animatedCursor() fails for no good
+ ;; reason and breaks these two tests.
+ (substitute* "tests/auto/client/seatv4/tst_seatv4.cpp"
+ (((string-append "QVERIFY\\(!cursorSurface\\(\\)->"
+ "m_waitingFrameCallbacks\\.empty\\(\\)\\);"))
+ "")
+ (("QTRY_COMPARE\\(bufferSpy\\.count\\(\\), 1\\);")
+ ""))))
+ (add-before 'check 'set-test-environment
+ (lambda _
+ ;; Do not fail just because /etc/machine-id is missing.
+ (setenv "DBUS_FATAL_WARNINGS" "0")))
+ ;; No such directory anymore.
+ (delete 'delete-installed-tests)))))
+ (native-inputs
+ (list glib perl pkg-config qtdeclarative))
+ (inputs
+ (list fontconfig
+ freetype
+ libx11
+ libxcomposite
+ libxext
+ libxkbcommon
+ libxrender
+ mesa
+ mtdev
+ qtbase
+ vulkan-headers
+ wayland))
+ (synopsis "Qt Wayland module")
+ (description "The Qt Wayland module provides the QtWayland client and
+compositor libraries.")))
+
(define-public qtserialport
(package (inherit qtsvg-5)
(name "qtserialport")
--
2.37.3
M
M
Maxim Cournoyer wrote on 28 Sep 2022 20:58
Re: bug#58054: [PATCH 0/2] gnu: Add qtwayland, version 6.3.1.
(name . Hilton Chain)(address . hako@ultrarare.space)(address . 58054@debbugs.gnu.org)
87zgejtjf5.fsf_-_@gmail.com
Hello Hilton!

Hilton Chain <hako@ultrarare.space> writes:

Toggle quote (5 lines)
> * gnu/packages/qt.scm (qtwayland): New variable.
> ---
> gnu/packages/qt.scm | 49 +++++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 49 insertions(+)

Great work!

Toggle quote (11 lines)
> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> index bf978eec50..25b246d7d4 100644
> --- a/gnu/packages/qt.scm
> +++ b/gnu/packages/qt.scm
> @@ -1500,6 +1500,55 @@ (define-public qtwayland-5
> (description "The Qt Wayland module provides the QtWayland client and
> compositor libraries.")))
>
> +(define-public qtwayland
> + (package (inherit qtsvg)

For the qt 6 packages, I tried to not inherit from qtsvg, as while that
can shorten some repetition sometimes, it doesn't really make sense
(qtwayland is not related to qtsvg) and could cause problems down the
line.

Toggle quote (17 lines)
> + (name "qtwayland")
> + (version "6.3.1")
> + (source (origin
> + (method url-fetch)
> + (uri (qt-urls name version))
> + (sha256
> + (base32
> + "1w60p1did7awdlzq5k8vnq2ncpskb07cpvz31cbv99bjs6igw53g"))))
> + (arguments
> + (substitute-keyword-arguments (package-arguments qtsvg)
> + ((#:phases phases)
> + #~(modify-phases #$phases
> + (add-after 'unpack 'disable-failing-tests
> + (lambda _
> + ;; FIXME: tst_seatv4::animatedCursor() fails for no good
> + ;; reason and breaks these two tests.

Please link to the upstream issue, already reported at

Toggle quote (13 lines)
> + (substitute* "tests/auto/client/seatv4/tst_seatv4.cpp"
> + (((string-append "QVERIFY\\(!cursorSurface\\(\\)->"
> + "m_waitingFrameCallbacks\\.empty\\(\\)\\);"))
> + "")
> + (("QTRY_COMPARE\\(bufferSpy\\.count\\(\\), 1\\);")
> + ""))))
> + (add-before 'check 'set-test-environment
> + (lambda _
> + ;; Do not fail just because /etc/machine-id is missing.
> + (setenv "DBUS_FATAL_WARNINGS" "0")))
> + ;; No such directory anymore.
> + (delete 'delete-installed-tests)))))

That's unwanted inherited stuff from qtsvg which should be no longer
necessary after removing the inheritance.

Toggle quote (20 lines)
> + (native-inputs
> + (list glib perl pkg-config qtdeclarative))
> + (inputs
> + (list fontconfig
> + freetype
> + libx11
> + libxcomposite
> + libxext
> + libxkbcommon
> + libxrender
> + mesa
> + mtdev
> + qtbase
> + vulkan-headers
> + wayland))
> + (synopsis "Qt Wayland module")
> + (description "The Qt Wayland module provides the QtWayland client and
> +compositor libraries.")))
> +

Please send a v2 version with the above addressed and it should be good
to merge it!

Thank you,

Maxim
H
H
Hilton Chain wrote on 29 Sep 2022 15:52
[PATCH v2 0/2] gnu: Add qtwayland, version 6.3.1.
(address . 58054@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
y761qru70fn.wl-hako@ultrarare.space
v1 -> v2: Not inheriting qtsvg.

Hilton Chain (2):
gnu: qtwayland: Rename to qtwayland-5.
gnu: Add qtwayland, version 6.3.1.

gnu/packages/kde-frameworks.scm | 2 +-
gnu/packages/kde-plasma.scm | 2 +-
gnu/packages/qt.scm | 54 +++++++++++++++++++++++++++++++--
gnu/packages/telegram.scm | 2 +-
gnu/packages/video.scm | 2 +-
5 files changed, 56 insertions(+), 6 deletions(-)


base-commit: e6777cfa5eb5e9c36eaf7810b42cac0fbcaa367c
--
2.37.3
H
H
Hilton Chain wrote on 29 Sep 2022 15:53
[PATCH v2 1/2] gnu: qtwayland: Rename to qtwayland-5.
(address . 58054@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
y76zgei5lsw.wl-hako@ultrarare.space
Automated via:

git grep -l qtwayland | xargs sed 's/\qtwayland\b/\0-5/g' -i
git checkout NEWS
---
gnu/packages/kde-frameworks.scm | 2 +-
gnu/packages/kde-plasma.scm | 2 +-
gnu/packages/qt.scm | 4 ++--
gnu/packages/telegram.scm | 2 +-
gnu/packages/video.scm | 2 +-
5 files changed, 6 insertions(+), 6 deletions(-)

Toggle diff (76 lines)
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 61cbf19bc4..059667ee5d 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1068,7 +1068,7 @@ (define-public kwayland
(native-inputs
(list extra-cmake-modules pkg-config))
(inputs
- (list qtbase-5 qtwayland wayland wayland-protocols))
+ (list qtbase-5 qtwayland-5 wayland wayland-protocols))
(arguments
`(#:tests? #f ; FIXME tests require weston to run
; weston requires wayland flags in mesa
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 39716187fd..064f5f7278 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -177,7 +177,7 @@ (define-public layer-shell-qt
(list libxkbcommon
qtbase-5
qtdeclarative-5
- qtwayland
+ qtwayland-5
wayland
wayland-protocols))
(home-page "https://invent.kde.org/plasma/layer-shell-qt")
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 8c94d613d6..f6e5a37472 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -220,7 +220,7 @@ (define-public materialdecoration
(list cmake-shared extra-cmake-modules pkg-config))
(inputs
`(("qtbase" ,qtbase-5)
- ("qtwayland" ,qtwayland)
+ ("qtwayland" ,qtwayland-5)
("wayland" ,wayland)
("xkbcommon" ,libxkbcommon)))
(synopsis "Material Decoration for Qt")
@@ -1450,7 +1450,7 @@ (define-public qtmultimedia
set of plugins for interacting with pulseaudio and GStreamer.")
(license (package-license qtbase))))
-(define-public qtwayland
+(define-public qtwayland-5
(package (inherit qtsvg-5)
(name "qtwayland")
(version "5.15.2")
diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index 2df68ccca7..82c9227ba8 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -502,7 +502,7 @@ (define-public telegram-desktop
qtbase-5
qtimageformats
qtsvg-5
- qtwayland
+ qtwayland-5
range-v3
rlottie-for-telegram-desktop
rnnoise
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 01c9ae186a..ca6148b078 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3385,7 +3385,7 @@ (define-public obs
qtbase-5
qtsvg-5
qtx11extras
- qtwayland
+ qtwayland-5
speexdsp
v4l-utils
wayland
--
2.37.3
H
H
Hilton Chain wrote on 29 Sep 2022 15:53
[PATCH v2 2/2] gnu: Add qtwayland, version 6.3.1.
(address . 58054@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
y76y1u25lsc.wl-hako@ultrarare.space
* gnu/packages/qt.scm (qtwayland): New variable.
---
gnu/packages/qt.scm | 50 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index f6e5a37472..6e30980505 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1500,6 +1500,56 @@ (define-public qtwayland-5
(description "The Qt Wayland module provides the QtWayland client and
compositor libraries.")))
+(define-public qtwayland
+ (package
+ (name "qtwayland")
+ (version "6.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (qt-urls name version))
+ (sha256
+ (base32 "1w60p1did7awdlzq5k8vnq2ncpskb07cpvz31cbv99bjs6igw53g"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-DQT_BUILD_TESTS=ON")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ ;; FIXME: tst_seatv4::animatedCursor() fails here.
+ ;; See also: <https://bugreports.qt.io/browse/QTBUG-78317>
+ (substitute* "tests/auto/client/seatv4/tst_seatv4.cpp"
+ (((string-append
+ "QVERIFY\\(!cursorSurface\\(\\)->"
+ "m_waitingFrameCallbacks\\.empty\\(\\)\\);")) "")
+ (("QTRY_COMPARE\\(bufferSpy\\.count\\(\\), 1\\);") ""))))
+ (add-before 'check 'set-test-environment
+ (lambda _
+ ;; Do not fail just because /etc/machine-id is missing.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ ;; Make Qt render "offscreen", required for tests.
+ (setenv "QT_QPA_PLATFORM" "offscreen"))))))
+ (native-inputs (list glib perl pkg-config qtdeclarative))
+ (inputs
+ (list fontconfig
+ freetype
+ libx11
+ libxcomposite
+ libxext
+ libxkbcommon
+ libxrender
+ mesa
+ mtdev
+ qtbase
+ vulkan-headers
+ wayland))
+ (synopsis "Qt Wayland module")
+ (description "The Qt Wayland module provides the QtWayland client and
+compositor libraries.")
+ (home-page (package-home-page qtbase))
+ (license (package-license qtbase))))
+
(define-public qtserialport
(package (inherit qtsvg-5)
(name "qtserialport")
--
2.37.3
M
M
Maxim Cournoyer wrote on 30 Sep 2022 05:31
(name . Hilton Chain)(address . hako@ultrarare.space)(address . 58054-done@debbugs.gnu.org)
875yh5mtb5.fsf@gmail.com
Hi,

Hilton Chain <hako@ultrarare.space> writes:

Toggle quote (5 lines)
> * gnu/packages/qt.scm (qtwayland): New variable.
> ---
> gnu/packages/qt.scm | 50 +++++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 50 insertions(+)

Applied both patches, thank you for the rework!

--
Maxim
Closed
?