[PATCH] gnu: Add libpatch.

  • Done
  • quality assurance status badge
Details
2 participants
  • Olivier Dion
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Olivier Dion
Severity
normal
O
O
Olivier Dion wrote on 24 Sep 2022 18:38
(address . guix-patches@gnu.org)
3400e6a50d528e085834f77e7159607f22d9b8b9.1664037413.git.olivier.dion@polymtl.ca
* gnu/packages/instrumentation.scm (libpatch): New variable.
---
gnu/packages/instrumentation.scm | 64 ++++++++++++++++++++++++++++++++
1 file changed, 64 insertions(+)

Toggle diff (91 lines)
diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index c508801c6b..b611f2b141 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -22,6 +22,7 @@ (define-module (gnu packages instrumentation)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
#:use-module (gnu packages commencement)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages documentation)
#:use-module (gnu packages elf)
@@ -30,6 +31,7 @@ (define-module (gnu packages instrumentation)
#:use-module (gnu packages flex)
#:use-module (gnu packages gawk)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages guile)
#:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages libunwind)
#:use-module (gnu packages linux)
@@ -207,6 +209,68 @@ (define-public flamegraph
with the script @command{flamegraph.pl} and many stackcollapse scripts.")
(license license:cddl1.0))))
+(define-public libpatch
+ (package
+ (name "libpatch")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~old/libpatch")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1sx1sichnnqfi84z37gd04h41vpr8i2vg6yg0jkqxlrv3dys489a"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ (string-append
+ "--target="
+ ,(platform-linux-architecture
+ (lookup-platform-by-target-or-system
+ (or
+ (%current-target-system)
+ (%current-system))))))))
+ (inputs
+ (list capstone
+ elfutils
+ ;; Uncomment the following if you want tracepoints within libpatch
+ ;; for debugging.
+ ;;
+ ;; lttng-ust
+ libunwind
+ liburcu))
+ (native-inputs
+ (list coreutils
+ ;; test-ftrace.scm
+ (list coreutils "debug")
+ ;; For eu-nm in test-ftrace.scm.
+ (list elfutils "bin")
+ ;; Put Guile in your profile if you want to use the bindings.
+ guile-3.0
+ ;; test-ftrace.scm
+ (list guile-3.0 "debug")
+ gnu-make
+ ;; test-ftrace.scm
+ (list gnu-make "debug")
+ pkg-config
+ ;; zlib is required by libdw. This can be removed if zlib is put
+ ;; as a propagated-input of elfutils.
+ zlib))
+ (synopsis "Dynamic binary patcher")
+ (description
+ "libpatch is a lightweight C library that can be used by tracers,
+debuggers and other tools for insertion of probes in a program at runtime. It
+has many strategies to minimize probe overhead and maximize possible
+coverage.")
+ (home-page "https://git.sr.ht/~old/libpatch")
+ (license (list license:lgpl2.1 license:expat license:gpl3+))
+ ;; Libpatch only supports instrumentation for x86_64 right now. Augment
+ ;; that list in further version.
+ (supported-systems (list "x86_64-linux"))))
+
(define-public lttng-modules
(package
(name "lttng-modules")
--
2.37.3
M
M
Mathieu Othacehe wrote on 26 Sep 2022 15:33
(name . Olivier Dion)(address . olivier.dion@polymtl.ca)(address . 58045-done@debbugs.gnu.org)
87zgemqmyt.fsf@gnu.org
Toggle quote (2 lines)
> * gnu/packages/instrumentation.scm (libpatch): New variable.

Applied with the following diff:

Toggle snippet (41 lines)
diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index b611f2b141..3d6b6fab38 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -233,28 +233,25 @@ (define-public libpatch
(or
(%current-target-system)
(%current-system))))))))
+ ;;; Add lttng-ust to the inputs if you want tracepoints within libpatch
+ ;;; for debugging.
(inputs
(list capstone
elfutils
- ;; Uncomment the following if you want tracepoints within libpatch
- ;; for debugging.
- ;;
- ;; lttng-ust
libunwind
liburcu))
(native-inputs
(list coreutils
;; test-ftrace.scm
(list coreutils "debug")
+ (list guile-3.0 "debug")
+ (list gnu-make "debug")
+
;; For eu-nm in test-ftrace.scm.
(list elfutils "bin")
- ;; Put Guile in your profile if you want to use the bindings.
+
guile-3.0
- ;; test-ftrace.scm
- (list guile-3.0 "debug")
gnu-make
- ;; test-ftrace.scm
- (list gnu-make "debug")
pkg-config
;; zlib is required by libdw. This can be removed if zlib is put
;; as a propagated-input of elfutils.

Thanks,

Mathieu
Closed
?