kernel module not found "pata_acpi" in linux-libre-5.19.10

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 24 Sep 2022 07:16
(name . bug-guix)(address . bug-guix@gnu.org)
87r10173or.fsf@gmail.com
Hello,

While attempting to reconfigure the overdrive1 aarch64 machine, I got:

Toggle snippet (33 lines)
substitute: ^Msubstitute: ESC[Kupdating substitutes from 'https://ci.guix.gnu.org'... 0.0%^Msubstitute: ESC[Kupdating substitutes from 'https://ci.guix.gnu.org'... 100.0%
@ build-started /gnu/store/x9qdj37d6l2yacc73bx284ggj6vkhcdv-linux-modules.drv - aarch64-linux /var/log/guix/drvs/x9//qdj37d6l2yacc73bx284ggj6vkhcdv-linux-modules.drv.gz 31574
Backtrace:
In ice-9/eval.scm:
619:8 19 (_ #f)
626:19 18 (_ #<directory (guile-user) 5ebc80>)
293:34 17 (_ #(#<directory (guile-user) 5ebc80> #<procedure loo?>))
In srfi/srfi-1.scm:
586:29 16 (map1 _)
586:29 15 (map1 _)
586:29 14 (map1 _)
586:29 13 (map1 _)
586:29 12 (map1 _)
586:29 11 (map1 _)
586:29 10 (map1 _)
586:29 9 (map1 _)
586:29 8 (map1 _)
586:29 7 (map1 _)
586:29 6 (map1 _)
586:29 5 (map1 _)
586:29 4 (map1 _)
586:29 3 (map1 _)
586:29 2 (map1 _)
586:17 1 (map1 ("pata_acpi" "pata_atiixp" "isci" "virtio_pci" # ?))
In gnu/build/linux-modules.scm:
257:5 0 (_)

gnu/build/linux-modules.scm:257:5: kernel module not found "pata_acpi" "/gnu/store/nmdy7c4i34y12w8af7zl6sl9fmrp8wa0-linux-libre-5.19.10/lib/modules"
builder for `/gnu/store/x9qdj37d6l2yacc73bx284ggj6vkhcdv-linux-modules.drv' failed with exit code 1
@ build-failed /gnu/store/x9qdj37d6l2yacc73bx284ggj6vkhcdv-linux-modules.drv - 1 builder for `/gnu/store/x9qdj37d6l2yacc73bx284ggj6vkhcdv-linux-modules.drv' failed with exit code 1
/var/log/guix/drvs/x9/qdj37d6l2yacc73bx284ggj6vkhcdv-linux-modules.drv (END

this is with commit 35e8615d387b6630006ccd8c3420154dab93b95a.

Thanks,

Maxim
L
L
Ludovic Courtès wrote on 26 Sep 2022 12:12
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 58036@debbugs.gnu.org)
87leq6mok9.fsf@gnu.org
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

Toggle quote (32 lines)
> While attempting to reconfigure the overdrive1 aarch64 machine, I got:
>
> substitute: ^Msubstitute: ESC[Kupdating substitutes from 'https://ci.guix.gnu.org'... 0.0%^Msubstitute: ESC[Kupdating substitutes from 'https://ci.guix.gnu.org'... 100.0%
> @ build-started /gnu/store/x9qdj37d6l2yacc73bx284ggj6vkhcdv-linux-modules.drv - aarch64-linux /var/log/guix/drvs/x9//qdj37d6l2yacc73bx284ggj6vkhcdv-linux-modules.drv.gz 31574
> Backtrace:
> In ice-9/eval.scm:
> 619:8 19 (_ #f)
> 626:19 18 (_ #<directory (guile-user) 5ebc80>)
> 293:34 17 (_ #(#<directory (guile-user) 5ebc80> #<procedure loo?>))
> In srfi/srfi-1.scm:
> 586:29 16 (map1 _)
> 586:29 15 (map1 _)
> 586:29 14 (map1 _)
> 586:29 13 (map1 _)
> 586:29 12 (map1 _)
> 586:29 11 (map1 _)
> 586:29 10 (map1 _)
> 586:29 9 (map1 _)
> 586:29 8 (map1 _)
> 586:29 7 (map1 _)
> 586:29 6 (map1 _)
> 586:29 5 (map1 _)
> 586:29 4 (map1 _)
> 586:29 3 (map1 _)
> 586:29 2 (map1 _)
> 586:17 1 (map1 ("pata_acpi" "pata_atiixp" "isci" "virtio_pci" # ?))
> In gnu/build/linux-modules.scm:
> 257:5 0 (_)
>
> gnu/build/linux-modules.scm:257:5: kernel module not found "pata_acpi" "/gnu/store/nmdy7c4i34y12w8af7zl6sl9fmrp8wa0-linux-libre-5.19.10/lib/modules"
> builder for `/gnu/store/x9qdj37d6l2yacc73bx284ggj6vkhcdv-linux-modules.drv' failed with exit code 1

This is the derivation made by ‘flat-linux-module-directory’ in (gnu
system linux-initrd).

How did you work around it?

Normally “pata_acpi” is excluded from ‘%base-initrd-modules’ on
aarch64. However, since this relies on (%current-system), there could
be situations where the trick doesn’t work as expected when deploying
say from x86_64:

Toggle snippet (18 lines)
(define* (default-initrd-modules
#:optional
(system (or (%current-target-system)
(%current-system))))
;; [...]

,@(if (string-match "^(x86_64|i[3-6]86)-" system)
'("pata_acpi" "pata_atiixp" ;for ATA controllers
"isci") ;for SAS controllers like Intel C602
'())

,@virtio-modules))

(define-syntax %base-initrd-modules
;; This more closely matches our naming convention.
(identifier-syntax (default-initrd-modules)))

I tried just now and did not reproduce it:

Toggle snippet (19 lines)
$ guix describe
Generation 229 Sep 25 2022 23:42:53 (current)
guix ab69314
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: ab6931483be544b7debb9496f694b593af7e0c0f
$ guix deploy -L modules deploy-overdrive1.scm
The following 1 machine will be deployed:
overdrive1

guix deploy: deploying to overdrive1...

[…]

guix deploy: sending 0 store items (0 MiB) to 'overdrive1.guix.gnu.org'...
guix deploy: error: failed to deploy overdrive1: failed to switch systems while deploying 'overdrive1.guix.gnu.org':
system-error "symlink" "~A" ("File exists") (17)

(But as you can see, I did reproduce that other bug you reported. :-))

Ludo’.
M
M
Maxim Cournoyer wrote on 26 Sep 2022 14:28
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 58036@debbugs.gnu.org)
877d1q1frv.fsf@gmail.com
Hi!

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (41 lines)
> Hi,
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:
>
>> While attempting to reconfigure the overdrive1 aarch64 machine, I got:
>>
>> substitute: ^Msubstitute: ESC[Kupdating substitutes from 'https://ci.guix.gnu.org'... 0.0%^Msubstitute: ESC[Kupdating substitutes from 'https://ci.guix.gnu.org'... 100.0%
>> @ build-started /gnu/store/x9qdj37d6l2yacc73bx284ggj6vkhcdv-linux-modules.drv - aarch64-linux /var/log/guix/drvs/x9//qdj37d6l2yacc73bx284ggj6vkhcdv-linux-modules.drv.gz 31574
>> Backtrace:
>> In ice-9/eval.scm:
>> 619:8 19 (_ #f)
>> 626:19 18 (_ #<directory (guile-user) 5ebc80>)
>> 293:34 17 (_ #(#<directory (guile-user) 5ebc80> #<procedure loo?>))
>> In srfi/srfi-1.scm:
>> 586:29 16 (map1 _)
>> 586:29 15 (map1 _)
>> 586:29 14 (map1 _)
>> 586:29 13 (map1 _)
>> 586:29 12 (map1 _)
>> 586:29 11 (map1 _)
>> 586:29 10 (map1 _)
>> 586:29 9 (map1 _)
>> 586:29 8 (map1 _)
>> 586:29 7 (map1 _)
>> 586:29 6 (map1 _)
>> 586:29 5 (map1 _)
>> 586:29 4 (map1 _)
>> 586:29 3 (map1 _)
>> 586:29 2 (map1 _)
>> 586:17 1 (map1 ("pata_acpi" "pata_atiixp" "isci" "virtio_pci" # ?))
>> In gnu/build/linux-modules.scm:
>> 257:5 0 (_)
>>
>> gnu/build/linux-modules.scm:257:5: kernel module not found "pata_acpi" "/gnu/store/nmdy7c4i34y12w8af7zl6sl9fmrp8wa0-linux-libre-5.19.10/lib/modules"
>> builder for `/gnu/store/x9qdj37d6l2yacc73bx284ggj6vkhcdv-linux-modules.drv' failed with exit code 1
>
> This is the derivation made by ‘flat-linux-module-directory’ in (gnu
> system linux-initrd).
>
> How did you work around it?

I had to use the previous version of the latest linux-libre kernel, by
using this commit:

Toggle snippet (4 lines)
$ guix time-machine --commit=08d515233241ee0921b8b5ab706f98170c62437c -- \
deploy -L modules deploy-overdrive1.scm

And on the first attempt I had to run reconfigure with
--allow-downgrades locally due to a previously failing 'deploy' having
left the failed deploy generation as 'active' which was generated on a
later Guix commit.

There's currently no '--allow-downgrades' for 'guix deploy'.

It's strange that you cannot reproduce it. I was running that from my
home x86_64 Guix System machine which is authorized on overdrive1 and
has SSH access to it.

Thanks,

Maxim
L
L
Ludovic Courtès wrote on 26 Sep 2022 15:21
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 58036@debbugs.gnu.org)
87tu4ul19n.fsf@gnu.org
Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

Toggle quote (14 lines)
>>> gnu/build/linux-modules.scm:257:5: kernel module not found "pata_acpi" "/gnu/store/nmdy7c4i34y12w8af7zl6sl9fmrp8wa0-linux-libre-5.19.10/lib/modules"
>>> builder for `/gnu/store/x9qdj37d6l2yacc73bx284ggj6vkhcdv-linux-modules.drv' failed with exit code 1
>>
>> This is the derivation made by ‘flat-linux-module-directory’ in (gnu
>> system linux-initrd).
>>
>> How did you work around it?
>
> I had to use the previous version of the latest linux-libre kernel, by
> using this commit:
>
> $ guix time-machine --commit=08d515233241ee0921b8b5ab706f98170c62437c -- \
> deploy -L modules deploy-overdrive1.scm

OK. I wonder if it’s just luck, because on another run with the same
revision I’m now hitting it. It might relate to

Toggle quote (2 lines)
> There's currently no '--allow-downgrades' for 'guix deploy'.

There’s the ‘allow-downgrades?’ field of ‘machine-ssh-configuration’,
but sssssh! (info "(guix) Invoking guix deploy")

Ludo’.
L
L
Ludovic Courtès wrote on 26 Sep 2022 23:34
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 58036-done@debbugs.gnu.org)
87zgelhlaf.fsf@gnu.org
Hi,

Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (2 lines)
> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

[...]

Toggle quote (13 lines)
>> gnu/build/linux-modules.scm:257:5: kernel module not found "pata_acpi" "/gnu/store/nmdy7c4i34y12w8af7zl6sl9fmrp8wa0-linux-libre-5.19.10/lib/modules"
>> builder for `/gnu/store/x9qdj37d6l2yacc73bx284ggj6vkhcdv-linux-modules.drv' failed with exit code 1
>
> This is the derivation made by ‘flat-linux-module-directory’ in (gnu
> system linux-initrd).
>
> How did you work around it?
>
> Normally “pata_acpi” is excluded from ‘%base-initrd-modules’ on
> aarch64. However, since this relies on (%current-system), there could
> be situations where the trick doesn’t work as expected when deploying
> say from x86_64:

Fixed in 1033645e9d3899edd6b052b19e24c0a718b95e88.

We need system tests for ‘guix deploy’!

Ludo’.
Closed
M
M
Maxim Cournoyer wrote on 27 Sep 2022 01:47
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 58036-done@debbugs.gnu.org)
87zgely9y4.fsf@gmail.com
Hi!

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (25 lines)
> Hi,
>
> Ludovic Courtès <ludo@gnu.org> skribis:
>
>> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:
>
> [...]
>
>>> gnu/build/linux-modules.scm:257:5: kernel module not found
>>> "pata_acpi"
>>> "/gnu/store/nmdy7c4i34y12w8af7zl6sl9fmrp8wa0-linux-libre-5.19.10/lib/modules"
>>> builder for `/gnu/store/x9qdj37d6l2yacc73bx284ggj6vkhcdv-linux-modules.drv' failed with exit code 1
>>
>> This is the derivation made by ‘flat-linux-module-directory’ in (gnu
>> system linux-initrd).
>>
>> How did you work around it?
>>
>> Normally “pata_acpi” is excluded from ‘%base-initrd-modules’ on
>> aarch64. However, since this relies on (%current-system), there could
>> be situations where the trick doesn’t work as expected when deploying
>> say from x86_64:
>
> Fixed in 1033645e9d3899edd6b052b19e24c0a718b95e88.

Well done, thank you!

Toggle quote (2 lines)
> We need system tests for ‘guix deploy’!

That would help :-).

Maxim
Closed
?