[PATCH] gnu: linux-libre: Support zram on all kernels.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Ludovic Courtès
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 23 Sep 2022 08:08
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
bff367cb853cd5603c8288d2bf6488ee8737a2df.1663913200.git.efraim@flashner.co.il
* gnu/packages/linux.scm (%default-extra-linux-options): Add config
options to add zram support.
---

Currently we only have zram support in our kernel .conf files, this adds
it to all the linux-libre-<arch>-generic kernels, and any other ones I
may have forgotten about.

---
gnu/packages/linux.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 306c18e398..18f8efe2f2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -695,6 +695,10 @@ (define %default-extra-linux-options
("CONFIG_PROC_PID_CPUSET" . #t)
;; Allow disk encryption by default
("CONFIG_DM_CRYPT" . m)
+ ;; Support zram on all kernel configs
+ ("CONFIG_ZSWAP" . #t)
+ ("CONFIG_ZSMALLOC" . #t)
+ ("CONFIG_ZRAM" . m)
;; Modules required for initrd:
("CONFIG_NET_9P" . m)
("CONFIG_NET_9P_VIRTIO" . m)

base-commit: 2e8b4f9bfa00489fd3acff305837a79af236e183
--
2.37.3
L
L
Ludovic Courtès wrote on 4 Oct 2022 09:47
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 58016@debbugs.gnu.org)
87bkqsvxm1.fsf@gnu.org
Hi,

Efraim Flashner <efraim@flashner.co.il> skribis:

Toggle quote (8 lines)
> * gnu/packages/linux.scm (%default-extra-linux-options): Add config
> options to add zram support.
> ---
>
> Currently we only have zram support in our kernel .conf files, this adds
> it to all the linux-libre-<arch>-generic kernels, and any other ones I
> may have forgotten about.

Sounds reasonable to me, thanks!

Ludo’.
E
E
Efraim Flashner wrote on 6 Oct 2022 08:50
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 58016-done@debbugs.gnu.org)
Yz56uxY9W//HPTsC@3900XT
On Tue, Oct 04, 2022 at 09:47:34AM +0200, Ludovic Courtès wrote:
Toggle quote (16 lines)
> Hi,
>
> Efraim Flashner <efraim@flashner.co.il> skribis:
>
> > * gnu/packages/linux.scm (%default-extra-linux-options): Add config
> > options to add zram support.
> > ---
> >
> > Currently we only have zram support in our kernel .conf files, this adds
> > it to all the linux-libre-<arch>-generic kernels, and any other ones I
> > may have forgotten about.
>
> Sounds reasonable to me, thanks!
>
> Ludo’.

Thanks! Patch pushed.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmM+eroACgkQQarn3Mo9
g1Eu/g/9GfKkL7K59TpSmww/w16lrZE28GXYP0LjEcqxR8USVnm1qYpeo5MBvwEZ
4YQEeZXr3qKdPJlwjEio/q8Gf2F1b1V5szgbyCRZzfCpNGwgXlm92C6iA8g7nxZQ
n6uqv6pSSuYAm7xyMNZLaCCBzpJ43pFRbh7fgPjpCs3V3zS2TsDydOGOA77nGYcq
yoxw/f5ZsZnHHGtpVOEsctGD3hm7jTvTr+AwRY1W6hTLPgDedqeDY27crQv7zWCG
/xn1OCa3EryMAX08GoAXm+ZLl0UaiO0gC4jlZZn1KvIr9v9pyphXY4kvuNUB0Eyc
ipCW+WGvBzykp0/qihcVxP0Tt9AaI+u054VTMmgo+jY1KQYPO1siAfX+Nqx7cKLB
iWBVw8eK9KPCGDA/nehWRI68VSXcyLIZQmhuIZNV6NQU6zNAuVYZ6NOs8reQRDmV
1CLDp9sWheb1Z5KTMpAL9OFiwwHcohjuYCagrFI1k+CH9R9/rYmduCwzflbYh9du
mX64JurpdsBX61Y3h94EH7rgcKOI+4v/uHZiCzS/eZH3Hqa51SyougOzvcmnm5v4
4iPbEkvE2VYWZaTPWSkCTHDE0fzhccxXYtEk/4ayidUFdWHJjSEi75j4373+y17Z
A8ziJyagyWJ3/Slwnckzxi3deCWZSyWNPADepUiNuL52vhrdy00=
=jXRR
-----END PGP SIGNATURE-----


Closed
?