[PATCH 0/2] [DRAFT] Add tdlib-1.8.0 and use it for emacs telega

DoneSubmitted by g.
Details
3 participants
  • Zhu Zihao
  • g
  • Ludovic Courtès
Owner
unassigned
Severity
normal
G
(address . guix-patches@gnu.org)(name . Giovanni Biscuolo)(address . g@xelera.eu)
20220922122654.28933-1-g@xelera.eu
From: Giovanni Biscuolo <g@xelera.eu>

Latest telega.el release is 0.8.03 and is incompatible with TDLib major release greater than 1.8.0, see bug#57543 (emacs-telega is broken) for details

I'm trying to reintroduce tdlib v. 1.8.0 as tdlib-1.8.0 and use it to build emacs-telega

WARNING: when I try to build emacs telega with [PATCH 2/2] I get a build error in the patch-sources phase:

Toggle snippet (34 lines)
starting phase `patch-sources'
error: in phase 'patch-sources': uncaught exception:
%exception #<&search-error path: ("/gnu/store/mjcqzs5xrzn48jkbzk7bbslnf0m8kc5n-emacs-minimal-28.1" "/gnu/store/6qfa3yxa9g9gp6fd073px0gbjx5mb8lf-emacs-telega-0.8.03-checkout" "/gnu/store/cc942a03x3vgvf4rj6l6g5i6ax1m0mng-emacs-telega-server-0.8.03" "/gnu/store/dzdpjc8bq0gxq6nw01z465prmn0q7w4x-ffmpeg-4.4.2" "/gnu/store/yv0kyfwpsg10lz0c0kg4a2kc8z0b23gp-emacs-visual-fill-column-2.5" "/gnu/store/phwyciwkqdvwmhlg9nddkyklkd6c1kpg-emacs-company-0.9.13" "/gnu/store/3f84bs6h4fd4d4l7fknmsd92bqqgnx6s-emacs-rainbow-identifiers-0.2.2" "/gnu/store/g2ajyl8xk9aarxrgjbng2hkj3qm2v0z2-tar-1.34" "/gnu/store/iixwcv3k49ks1rf34pjgfzmzyhhgwng3-gzip-1.10" "/gnu/store/s3hl12jxz9ybs7nsy7kq7ybzz7qnzmsg-bzip2-1.0.8" "/gnu/store/c8isj4jq6knv0icfgr43di6q3nvdzkx7-xz-5.2.5" "/gnu/store/4ic6244i3ca4b4rxc2wnrgllsidyishv-file-5.39" "/gnu/store/ahmmvw21p11ik80lg1f953y7fd8bqkjm-diffutils-3.8" "/gnu/store/z39hnrwds1dgcbpfgj8dnv2cngjb2xbl-patch-2.7.6" "/gnu/store/39rsx3nl4c31952jybbjb8d6idr5hx7r-findutils-4.8.0" "/gnu/store/690qz3fg334dpwn3pn6k59n4wc943p2b-gawk-5.1.0" "/gnu/store/wxgv6i8g0p24q5gcyzd0yr07s8kn9680-sed-4.8" "/gnu/store/xjwp2hsd9256icjjybfrmznppjicywf6-grep-3.6" "/gnu/store/d251rfgc9nm2clzffzhgiipdvfvzkvwi-coreutils-8.32" "/gnu/store/55cbpsi18mahg131nmiya6km5b4mscfa-make-4.3" "/gnu/store/4y5m9lb8k3qkb1y9m02sw9w9a6hacd16-bash-minimal-5.1.8" "/gnu/store/s2pg5k98fl2g2szg9dykxyd9zl3xihv9-ld-wrapper-0" "/gnu/store/rc781v4k0drhaqn90xfwwpspki5x0bvf-binutils-2.37" "/gnu/store/069aq2v993kpc41yabp5b6vm4wb9jkhg-gcc-10.3.0" "/gnu/store/5h2w4qi9hk1qzzgi1w83220ydslinr4s-glibc-2.33" "/gnu/store/4jdghmc65q7i7ib89zmvq66l0ghf7jc4-glibc-2.33-static" "/gnu/store/fnr1z6xsan0437r0yg48d0y8k32kqxby-glibc-utf8-locales-2.33" "/gnu/store/6mjww4iz4xdan74d5bbjfh7il8rngfkk-linux-libre-headers-5.10.35") file: "bin/ffplay">
phase `patch-sources' failed after 0.0 seconds
Backtrace:
8 (primitive-load "/gnu/store/l6hsxfvfy6275nmbxlzzh4p8m62?")
In guix/build/gnu-build-system.scm:
906:2 7 (gnu-build #:source _ #:outputs _ #:inputs _ #:phases . #)
In ice-9/boot-9.scm:
1752:10 6 (with-exception-handler _ _ #:unwind? _ # _)
In srfi/srfi-1.scm:
634:9 5 (for-each #<procedure 7ffff2bdb9e0 at guix/build/gnu-b?> ?)
In ice-9/boot-9.scm:
1752:10 4 (with-exception-handler _ _ #:unwind? _ # _)
In guix/build/gnu-build-system.scm:
927:23 3 (_)
In ice-9/eval.scm:
293:34 2 (_ #(#(#<directory (guile-user) 7ffff3fd7c80>) (# # ?)))
In ice-9/boot-9.scm:
1685:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
ERROR:
1. &search-error:
path: ("/gnu/store/mjcqzs5xrzn48jkbzk7bbslnf0m8kc5n-emacs-minimal-28.1" "/gnu/store/6qfa3yxa9g9gp6fd073px0gbjx5mb8lf-emacs-telega-0.8.03-checkout" "/gnu/store/cc942a03x3vgvf4rj6l6g5i6ax1m0mng-emacs-telega-server-0.8.03" "/gnu/store/dzdpjc8bq0gxq6nw01z465prmn0q7w4x-ffmpeg-4.4.2" "/gnu/store/yv0kyfwpsg10lz0c0kg4a2kc8z0b23gp-emacs-visual-fill-column-2.5" "/gnu/store/phwyciwkqdvwmhlg9nddkyklkd6c1kpg-emacs-company-0.9.13" "/gnu/store/3f84bs6h4fd4d4l7fknmsd92bqqgnx6s-emacs-rainbow-identifiers-0.2.2" "/gnu/store/g2ajyl8xk9aarxrgjbng2hkj3qm2v0z2-tar-1.34" "/gnu/store/iixwcv3k49ks1rf34pjgfzmzyhhgwng3-gzip-1.10" "/gnu/store/s3hl12jxz9ybs7nsy7kq7ybzz7qnzmsg-bzip2-1.0.8" "/gnu/store/c8isj4jq6knv0icfgr43di6q3nvdzkx7-xz-5.2.5" "/gnu/store/4ic6244i3ca4b4rxc2wnrgllsidyishv-file-5.39" "/gnu/store/ahmmvw21p11ik80lg1f953y7fd8bqkjm-diffutils-3.8" "/gnu/store/z39hnrwds1dgcbpfgj8dnv2cngjb2xbl-patch-2.7.6" "/gnu/store/39rsx3nl4c31952jybbjb8d6idr5hx7r-findutils-4.8.0" "/gnu/store/690qz3fg334dpwn3pn6k59n4wc943p2b-gawk-5.1.0" "/gnu/store/wxgv6i8g0p24q5gcyzd0yr07s8kn9680-sed-4.8" "/gnu/store/xjwp2hsd9256icjjybfrmznppjicywf6-grep-3.6" "/gnu/store/d251rfgc9nm2clzffzhgiipdvfvzkvwi-coreutils-8.32" "/gnu/store/55cbpsi18mahg131nmiya6km5b4mscfa-make-4.3" "/gnu/store/4y5m9lb8k3qkb1y9m02sw9w9a6hacd16-bash-minimal-5.1.8" "/gnu/store/s2pg5k98fl2g2szg9dykxyd9zl3xihv9-ld-wrapper-0" "/gnu/store/rc781v4k0drhaqn90xfwwpspki5x0bvf-binutils-2.37" "/gnu/store/069aq2v993kpc41yabp5b6vm4wb9jkhg-gcc-10.3.0" "/gnu/store/5h2w4qi9hk1qzzgi1w83220ydslinr4s-glibc-2.33" "/gnu/store/4jdghmc65q7i7ib89zmvq66l0ghf7jc4-glibc-2.33-static" "/gnu/store/fnr1z6xsan0437r0yg48d0y8k32kqxby-glibc-utf8-locales-2.33" "/gnu/store/6mjww4iz4xdan74d5bbjfh7il8rngfkk-linux-libre-headers-5.10.35")
file: "bin/ffplay"
builder for `/gnu/store/m8npriyc96yix8y9hypradnpf39cdgc0-emacs-telega-0.8.03.drv' failed with exit code 1
build of /gnu/store/m8npriyc96yix8y9hypradnpf39cdgc0-emacs-telega-0.8.03.drv failed



Giovanni Biscuolo (2):
gnu: Add tdlib-1.8.0.
gnu: emacs-telega: Use tdlib-1.8.0

gnu/packages/emacs-xyz.scm | 2 +-
gnu/packages/messaging.scm | 15 +++++++++++++++
2 files changed, 16 insertions(+), 1 deletion(-)


base-commit: 4e88a7bfcb70f25219d9f2887121ae196431a115
--
2.37.2
G
[PATCH 1/2] gnu: Add tdlib-1.8.0.
(address . 58003@debbugs.gnu.org)(name . Giovanni Biscuolo)(address . g@xelera.eu)
20220922123913.29670-1-g@xelera.eu
From: Giovanni Biscuolo <g@xelera.eu>

This is needed for emacs-telega 0.8.3

* gnu/packages/messaging.scm (tdlib-1.8.0): New variable.
---
gnu/packages/messaging.scm | 15 +++++++++++++++
1 file changed, 15 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index b5600d4baf..60689c1ae6 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -36,6 +36,7 @@
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;; Copyright © 2022 Jack Hill <jackhill@jackhill.us>
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Giovanni Biscuolo <g@xelera.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2685,6 +2686,20 @@ (define-public tdlib
     (home-page "https://core.telegram.org/tdlib")
     (license license:boost1.0)))
 
+(define-public tdlib-1.8.0
+  (package
+    (inherit tdlib)
+    (name "tdlib-1.8.0")
+    (version "1.8.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tdlib/td")
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32
+                "19psqpyh9a2kzfdhgqkirpif4x8pzy89phvi59dq155y30a3661q"))))))
+
 (define-public purple-mm-sms
   (package
     (name "purple-mm-sms")
-- 
2.37.2
G
[PATCH 2/2] gnu: emacs-telega: Use tdlib-1.8.0
(address . 58003@debbugs.gnu.org)(name . Giovanni Biscuolo)(address . g@xelera.eu)
20220922123939.29693-1-g@xelera.eu
From: Giovanni Biscuolo <g@xelera.eu>

emacs-telega is compatible with the latest TDLib major release 1.8.0

* gnu/packages/emacs-xyz.scm: (emacs-telega) Use tdlib-1.8.0 instead of latest tdlib
---
gnu/packages/emacs-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2cca4eab69..a0154aa7aa 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29166,7 +29166,7 @@ (define-public emacs-telega-server
             (lambda _ (chdir ".."))))
       #:test-target "test"))
     (inputs
-     (list tdlib libappindicator))
+     (list tdlib-1.8.0 libappindicator))
     (native-inputs
      (list python pkg-config))
     (home-page "https://zevlg.github.io/telega.el/")
-- 
2.37.2
Z
Z
Zhu Zihao wrote on 27 Sep 10:24 +0200
Re: [PATCH 0/2] [DRAFT] Add tdlib-1.8.0 and use it for emacs telega
(address . 58003@debbugs.gnu.org)
86k05pusuv.fsf@163.com
FYI, The missing ffplay problem it's been reported here: https://issues.guix.gnu.org/58090
--
Retrieve my PGP public key:

gpg --recv-keys B3EBC086AB0EBC0F45E0B4D433DB374BCEE4D9DC

Zihao
-----BEGIN PGP SIGNATURE-----

iIsEARYIADMWIQT4UAIrVkIEZilSHr2K2nJqP6LM8gUCYzKzaBUcYWxsX2J1dF9s
YXN0QDE2My5jb20ACgkQitpyaj+izPKKPQD/UD3Kteq1A8dbx9U1WaxG9JT7pJrM
7eNxD+uo3lNNwlkA/RS9X99yscMYRQ3/mqpeltRB3UQ4jshSjydrHdVFQzUN
=fk/a
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote 4 days ago
Re: bug#58003: [PATCH 0/2] [DRAFT] Add tdlib-1.8.0 and use it for emacs telega
(address . g@xelera.eu)(address . 58003-done@debbugs.gnu.org)
87fsg69cck.fsf@gnu.org
Ciao Giovanni,

g@xelera.eu skribis:

Toggle quote (3 lines)
> gnu: Add tdlib-1.8.0.
> gnu: emacs-telega: Use tdlib-1.8.0

Finally applied both.

I’ll see whether I can elucidate the ffmpeg 4.x issue.

Thanks!

Ludo’.
Closed
?