[PATCH] gnu: Add emacs-piem.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 21 Sep 2022 16:09
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20220921140912.2065383-1-zimon.toutoune@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-piem): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 32e4c33f16..03ad569300 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7011,6 +7011,34 @@ (define-public emacs-debbugs
Tracker as well as bug identifiers prepared for @code{bug-reference-mode}.")
(license license:gpl3+)))
+(define-public emacs-piem
+ (package
+ (name "emacs-piem")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.kyleam.com/piem.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32 "0wr6n6wvznngjdp4c0pmdr4xz05dark0kxi5svzhzxsg3rdaql3z"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list b4
+ emacs-elfeed
+ emacs-notmuch
+ emacs-transient))
+ (home-page "https://docs.kyleam.com/piem")
+ (synopsis "Glue for working with public-inbox archives")
+ (description "This packages provides a collection of Emacs libraries for
+working with public-inbox archives. As much of the hard work here is already
+done by other Emacs libraries—things like mail clients, news readers, Git
+interfaces, and even web browsers—piem is mostly about bridging some of these
+parts for convenience.")
+ (license license:gpl3)))
+
(define-public emacs-ert-expectations
(package
(name "emacs-ert-expectations")

base-commit: 6885f22375b093c08d69bbed6aa42d2e8c11a168
--
2.36.0
N
N
Nicolas Goaziou wrote on 24 Sep 2022 20:57
(name . zimoun)(address . zimon.toutoune@gmail.com)
87mtaovbvv.fsf@nicolasgoaziou.fr
Hello,

zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-piem): New variable.

Thank you. Applied with the following changes:

Toggle quote (6 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://git.kyleam.com/piem.git")

I removed ".git" suffix.

Toggle quote (8 lines)
> + (commit (string-append "v" version))))
> + (file-name (string-append name "-" version "-checkout"))
> + (sha256
> + (base32 "0wr6n6wvznngjdp4c0pmdr4xz05dark0kxi5svzhzxsg3rdaql3z"))))
> + (build-system emacs-build-system)
> + (propagated-inputs
> + (list b4

This need to be moved to inputs, along with an appropriate phase. I'll
do this in a later commit.

Toggle quote (6 lines)
> + (description "This packages provides a collection of Emacs libraries for
> +working with public-inbox archives. As much of the hard work here is already
> +done by other Emacs libraries—things like mail clients, news readers, Git
> +interfaces, and even web browsers—piem is mostly about bridging some of these
> +parts for convenience.")

I added two spaces between sentences.

Toggle quote (2 lines)
> + (license license:gpl3)))

License is actually GPL3+ (I forgot to change it, I'll do this in
a later commit too)

Regards,
--
Nicolas Goaziou
Closed
Z
Z
zimoun wrote on 25 Sep 2022 13:19
Re: bug#57980: [PATCH] gnu: Add emacs-piem.
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
865yhbn1kv.fsf@gmail.com
Hi,

On Sat, 24 Sep 2022 at 20:57, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

Toggle quote (2 lines)
> Thank you. Applied with the following changes:

Oh my bad. Thank you for the fixes.


Cheers,
simon
Closed
?