[PATCH] gnu: Add cl-bubble-operator-upwards.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • jgart
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220918213733.12243-1-jgart@dismail.de
* gnu/packages/lisp-xyz.scm (cl-bubble-operator-upwards,
ecl-sbcl-bubble-operator-upwards, sbcl-bubble-operator-upwards):
New variables.
---
gnu/packages/lisp-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index f0d1b925be..cf6f0c8828 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -214,6 +214,38 @@ (define-public cl-alea
(define-public ecl-alea
(sbcl-package->ecl-package sbcl-alea))
+(define-public sbcl-bubble-operator-upwards
+ (let ((commit "846275a318b960de81b62caecb1e31930f70aef6")
+ (revision "0"))
+ (package
+ (name "sbcl-bubble-operator-upwards")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Hexstream/bubble-operator-upwards")
+ (commit commit)))
+ (file-name (git-file-name "cl-bubble-operator-upwards" version))
+ (sha256
+ (base32 "0ybsy29ms3yrxgr7f2146lr6z4vm070dvdyzvwwxjh4dgm9na7bi"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-parachute))
+ (home-page "https://www.hexstreamsoft.com/libraries/bubble-operator-upwards/")
+ (synopsis "Function that bubbles an operator upwards in a form")
+ (description
+"@code{bubble-operator-upwards} is a function that bubbles an operator
+upwards in a form, demultiplexing all alternative branches by way of
+cartesian product.")
+ (license license:unlicense))))
+
+(define-public cl-bubble-operator-upwards
+ (sbcl-package->cl-source-package sbcl-bubble-operator-upwards))
+
+(define-public ecl-cl-bubble-operator-upwards
+ (sbcl-package->ecl-package sbcl-bubble-operator-upwards))
+
(define-public sbcl-map-bind
(let ((commit "532d55d93540c632e22b2cd264b5daa5f9d3d900")
(revision "0"))
--
2.37.3
G
G
Guillaume Le Vaillant wrote on 19 Sep 2022 11:13
(name . jgart)(address . jgart@dismail.de)(address . 57917-done@debbugs.gnu.org)
87y1ufzpyi.fsf@kitej
Patch pushed as 4ca4b96e2a674ac53c90315d98ff8ec614f0e606.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYygy1Q8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/V6AD+MFtY2FDQQWZx5BXJFViLNrRc1B40b9vyj2tm
x9BigogBAI325v0RyA+GGg7uZeyR/pg+RUfRfsLQJGPbmrPFhJoj
=Dsnw
-----END PGP SIGNATURE-----

Closed
J
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 57917-done@debbugs.gnu.org)
20220919165002.GB30037@dismail.de
On Mon, 19 Sep 2022 09:13:31 +0000 Guillaume Le Vaillant <glv@posteo.net> wrote:
Toggle quote (3 lines)
> Patch pushed as 4ca4b96e2a674ac53c90315d98ff8ec614f0e606.
> Thanks.

Thank you!
Closed
?