[PATCH]: scripts: build: Format strings before calling display-hint.

  • Done
  • quality assurance status badge
Details
2 participants
  • Zhu Zihao
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Zhu Zihao
Severity
normal
Z
Z
Zhu Zihao wrote on 18 Sep 2022 06:31
(name . guix-patches)(address . guix-patches@gnu.org)
86y1uhuwqp.fsf@163.com
Hi guix.

when running following command, the error message is not expected.

```
citreu@asus-laptop:~$ guix build hello --target=foobar
guix build: error: 'foobar' is not a supported cross-compilation target
hint: Try `--list-targets' to view available targets.~%

citreu@asus-laptop:~$ guix build hello --system=foobar
guix build: error: 'foobar' is not a supported system
hint: Try `--list-systems' to view available system types.~%
```

Unexpected ~% at the end of message.

In guix/scripts/build.scm, the code use display-hint to show this hint
but it doesn't format the "~%" to newline.

This patch adds these missing formats
-----BEGIN PGP SIGNATURE-----

iIsEARYIADMWIQT4UAIrVkIEZilSHr2K2nJqP6LM8gUCYyafvhUcYWxsX2J1dF9s
YXN0QDE2My5jb20ACgkQitpyaj+izPJccQD/aNxkbzhMf96AGf9ogjtaSx9zgWXo
eYRt4N2h69KR04cBAKkuCoeuiv/DK5YvH73948BbOO2W+d1uYY8Sid5/KoUE
=0fDs
-----END PGP SIGNATURE-----

From 13b4f55dc1f21a8ca15329d493f441d09df0ab4e Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sun, 18 Sep 2022 12:28:09 +0800
Subject: [PATCH] scripts: build: Format strings before calling display-hint.

* guix/scripts/build.scm(%standard-cross-build-options): format hint string.
%standard-cross-build-options: Ditto.
---
guix/scripts/build.scm | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)

Toggle diff (30 lines)
diff --git a/guix/scripts/build.scm b/guix/scripts/build.scm
index 06d9ad1f0c..0787dfcc9a 100644
--- a/guix/scripts/build.scm
+++ b/guix/scripts/build.scm
@@ -383,8 +383,9 @@ (define %standard-cross-build-options
(format #f (G_ "Did you mean @code{~a}?
Try @option{--list-targets} to view available targets.~%")
closest))
- (display-hint (G_ "\
-Try @option{--list-targets} to view available targets.~%")))
+ (display-hint
+ (format #f (G_ "\
+Try @option{--list-targets} to view available targets.~%"))))
(exit 1))))))))
(define %standard-native-build-options
@@ -409,8 +410,9 @@ (define %standard-native-build-options
(format #f (G_ "Did you mean @code{~a}?
Try @option{--list-systems} to view available system types.~%")
closest))
- (display-hint (G_ "\
-Try @option{--list-systems} to view available system types.~%")))
+ (display-hint
+ (format #f (G_ "\
+Try @option{--list-systems} to view available system types.~%"))))
(exit 1))))))))
--
2.37.3
--
Retrieve my PGP public key:

gpg --recv-keys B3EBC086AB0EBC0F45E0B4D433DB374BCEE4D9DC

Zihao
M
M
Mathieu Othacehe wrote on 30 Sep 2022 15:53
(name . Zhu Zihao)(address . all_but_last@163.com)(address . 57900-done@debbugs.gnu.org)
878rm16k9g.fsf@gnu.org
Toggle quote (3 lines)
> * guix/scripts/build.scm(%standard-cross-build-options): format hint string.
> %standard-cross-build-options: Ditto.

Applied, thanks!

Mathieu
Closed
?