[PATCH] gnu-maintenance: Support // URLs in latest-html-release

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Maxime Devos
Owner
unassigned
Submitted by
Maxime Devos
Severity
normal
M
M
Maxime Devos wrote on 11 Sep 2022 16:23
(address . guix-patches@gnu.org)(name . Maxime Devos)(address . maximedevos@telenet.be)
20220911142337.1208-1-maximedevos@telenet.be
This makes "./pre-inst-env guix refresh -u" download the release tarball from
the right place -- previously, it downloaded from


whereas it should download from


instead.

* guix/gnu-maintenance.scm (latest-html-release)[url-release]: Adjust
computation in the case of an absolute URI-reference without a scheme.
* tests/gnu-maintenance.scm ("latest-html-release, scheme-less URIs"):
Test it.
---
guix/gnu-maintenance.scm | 7 +++++++
tests/gnu-maintenance.scm | 29 +++++++++++++++++++++++++++++
2 files changed, 36 insertions(+)

Toggle diff (89 lines)
diff --git a/guix/gnu-maintenance.scm b/guix/gnu-maintenance.scm
index e7edbf6656..1ffa408666 100644
--- a/guix/gnu-maintenance.scm
+++ b/guix/gnu-maintenance.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2010, 2011, 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2012, 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -499,6 +500,12 @@ (define (url->release url)
(base-url (string-append base-url directory))
(url (cond ((and=> (string->uri url) uri-scheme) ;full URL?
url)
+ ;; full URL, except for URI scheme. Reuse the URI
+ ;; scheme of the document that contains the link.
+ ((string-prefix? "//" url)
+ (string-append
+ (symbol->string (uri-scheme (string->uri base-url)))
+ ":" url))
((string-prefix? "/" url) ;absolute path?
(let ((uri (string->uri base-url)))
(uri->string
diff --git a/tests/gnu-maintenance.scm b/tests/gnu-maintenance.scm
index c04d8ba733..89b0684c25 100644
--- a/tests/gnu-maintenance.scm
+++ b/tests/gnu-maintenance.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18,6 +19,10 @@
(define-module (test-gnu-maintenance)
#:use-module (guix gnu-maintenance)
+ #:use-module (guix tests)
+ #:use-module (guix tests http)
+ #:use-module (guix upstream)
+ #:use-module (guix utils)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-64)
#:use-module (ice-9 match))
@@ -55,4 +60,28 @@ (define-module (test-gnu-maintenance)
("mpg321_0.3.2.orig.tar.gz" "0.3.2")
("bvi-1.4.1.src.tar.gz" "1.4.1")))))
+(test-assert "latest-html-release, scheme-less URIs"
+ (with-http-server
+ `((200 "<html xmlns=\"http://www.w3.org/1999/xhtml\">
+<head>
+<title>Releases (on another domain)!</title>
+</head>
+<body
+<a href=\"//another-site/foo-2.tar.gz\">version 1</a>
+</body>
+</html>"))
+ (let ()
+ (define package
+ (dummy-package "foo"
+ (source
+ (dummy-origin
+ (uri (string-append (%local-url) "/foo-1.tar.gz"))))
+ (properties
+ `((release-monitoring-url . ,(%local-url))))))
+ (define update ((upstream-updater-latest %generic-html-updater) package))
+ (define expected-new-url "http://another-site/foo-2.tar.gz")
+ (and (pk 'u update)
+ (equal? (upstream-source-version update) "2")
+ (equal? (list expected-new-url) (upstream-source-urls update))))))
+
(test-end)

base-commit: a44e08337d15b3f254a35d0311663c2bbd501852
prerequisite-patch-id: 0caac311875ee39cb48573657ebb960e90da6dfb
prerequisite-patch-id: 418285493d89ebf102175902d9b09a0174e88190
prerequisite-patch-id: 3c39eb839d9d3ff3fca6cd98621a5d5c411b7af4
prerequisite-patch-id: 8d5662e874c469f5ee496ef5181cf2d0a30ad1d8
prerequisite-patch-id: 26513c3b3b86963df718ee41d14a25d1cc6a8f3f
prerequisite-patch-id: 2b2497e2edec0afc48ebadd6f09f0c661c466127
prerequisite-patch-id: 2712efb97bf33985fd0658e4dd8e936dc08be5fe
prerequisite-patch-id: 9d2409b480a8bff0fef029b4b095922d4957e06f
prerequisite-patch-id: 51a32abca3efec1ba67ead59b8694c5ea3129ad3
--
2.37.2
C
C
Christopher Baines wrote on 17 Sep 2022 19:21
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 57732-done@debbugs.gnu.org)
87tu55rk5l.fsf@cbaines.net
Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (20 lines)
> This makes "./pre-inst-env guix refresh -u" download the release tarball from
> the right place -- previously, it downloaded from
>
> https://www.libreoffice.org//download.documentfoundation.org/libreoffice/src/7.4.0/libreoffice-7.4.0.3.tar.xz?idx=1
>
> whereas it should download from
>
> https://download.documentfoundation.org/libreoffice/src/7.4.0/libreoffice-7.4.0.3.tar.xz?idx=1
>
> instead.
>
> * guix/gnu-maintenance.scm (latest-html-release)[url-release]: Adjust
> computation in the case of an absolute URI-reference without a scheme.
> * tests/gnu-maintenance.scm ("latest-html-release, scheme-less URIs"):
> Test it.
> ---
> guix/gnu-maintenance.scm | 7 +++++++
> tests/gnu-maintenance.scm | 29 +++++++++++++++++++++++++++++
> 2 files changed, 36 insertions(+)

Looks good to me :) Pushed to master as
c967d1153cae419e4acbe0dbed8f558d95ced0e3.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmMmAjZfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xcoag//RI8k/o4fUPZFTtM45ry84Y+wIcn1UMYq
ja6IlElr7FfZr0rkY2gwcmTMiJuflvg3BDfLn3K3qfwJn2Tflv8I5uaiZZ8bV67u
lDo4e6PY/7wFzr5XkZ22ifxhXIlJIvCaEk7+tAmd89SREmeuwlLTsQfr/uD2WEJJ
40vWHc3/nYnnJXnNApKklj7VuoszW2hD3MEavQlGXIzLTYCggEtb894DtPC3baH9
9LFXuW8tsgF7kx7v+vpxDaWBRSx32Bxg36hebDfOZwFQm4blPmpVfTMqDvoxrVAx
9Rb4PFdA+KFJTJsY+hnkO2oeo+E+E7+b7GgeD4euQj5k56nI6sLJwmBiWghNJL/6
7Lerw3tPcJZpbyi2RhYTD0w/FK8RXJ7wRouH0Vgrwkyj+8pryPZVnyqpUkpJd1I9
52TZ7KE1F25A5/73xeppVIEZG06g+25QGr/ck0ANiNWYCCgiYOa8/VewFxYXua0n
c4p/hDbAUoR1jEAHLa099PRJm0hn1CYqH5N7R9NqKj54Ve9wPQHU8crlCSiSCxFC
JtTZ1uJJQxVewxuAFB3fKLQGfSZqcIqDEGhtxW9S2lOeLnw+bo1EIKJGKWTlZLio
bxe+K2BK6Vr7P1rMI3saFZlNevpJTQW4VP0rS5WbBxdjRjT/+1UXa0yFammqQraf
o3cMVvfdz+0=
=R562
-----END PGP SIGNATURE-----

Closed
?