gnu: Add ocaml-guile.

  • Done
  • quality assurance status badge
Details
2 participants
  • Julien Lepiller
  • pukkamustard
Owner
unassigned
Submitted by
pukkamustard
Severity
normal
P
P
pukkamustard wrote on 29 Aug 2022 09:07
(address . guix-patches@gnu.org)
86ilmb4j3u.fsf@posteo.net
Hello Guix,

This patch adds ocaml-guile, providing OCaml bindings to Guile.

I think this allows pretty cool combinations of OCaml and Guile code!

Cheers,
pukkamustard
From 0c7bb35ea9304d6dc20a484513f68c841c54670c Mon Sep 17 00:00:00 2001
From: pukkamustard <pukkamustard@posteo.net>
Date: Mon, 29 Aug 2022 09:06:58 +0200
Subject: [PATCH] gnu: Add ocaml-guile.

* gnu/packages/ocaml.scm (ocaml-guile): New variable.
---
gnu/packages/ocaml.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0e8e5b2adc..2fd519ca41 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8741,3 +8741,36 @@ (define-public ocaml-bibtex2html
(description "This package allows you to produce, from a set of
bibliography files in BibTeX format, a bibliography in HTML format.")
(license license:gpl2)))
+
+(define-public ocaml-guile
+ (package
+ (name "ocaml-guile")
+ (version "1.0")
+ (home-page "https://github.com/gopiandcode/guile-ocaml")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yxdkrhrrbwvay5sn0p26rh3f11876k6kdharmpi4afxknml74ql"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests
+ (propagated-inputs
+ (list ocaml-sexplib
+ ocaml-ctypes
+ ocaml-stdio
+ ocaml-odoc))
+ (inputs (list guile-3.0 libffi))
+ (native-inputs
+ (list ocaml-odoc
+ pkg-config))
+ (synopsis "Bindings to GNU Guile Scheme for OCaml")
+ (description
+ "The OCaml guile library provides high-level OCaml bindings to GNU Guile
+3.0, supporting easy interop between OCaml and GNU Guile Scheme.")
+ (license license:gpl3+)))
--
2.37.1
J
J
Julien Lepiller wrote on 3 Sep 2022 20:23
(name . pukkamustard)(address . pukkamustard@posteo.net)(address . 57471@debbugs.gnu.org)
20220903202320.6a49258b@sybil.lepiller.eu
Pushed to master as 5cd7d7b3a27759fbaa990cbd81d8fbf4258691e0, thanks!

(and now I notice I forgot to sign it off)

Le Mon, 29 Aug 2022 07:07:59 +0000,
pukkamustard <pukkamustard@posteo.net> a écrit :

Toggle quote (10 lines)
>
> Hello Guix,
>
> This patch adds ocaml-guile, providing OCaml bindings to Guile.
>
> I think this allows pretty cool combinations of OCaml and Guile code!
>
> Cheers,
> pukkamustard
>
J
J
Julien Lepiller wrote on 3 Sep 2022 20:41
(address . 57471-done@debbugs.gnu.org)
20220903204118.03753461@sybil.lepiller.eu
and forgot to close it, sorry for the noise.

Le Sat, 3 Sep 2022 20:23:20 +0200,
Julien Lepiller <julien@lepiller.eu> a écrit :

Toggle quote (22 lines)
> Pushed to master as 5cd7d7b3a27759fbaa990cbd81d8fbf4258691e0, thanks!
>
> (and now I notice I forgot to sign it off)
>
> Le Mon, 29 Aug 2022 07:07:59 +0000,
> pukkamustard <pukkamustard@posteo.net> a écrit :
>
> >
> > Hello Guix,
> >
> > This patch adds ocaml-guile, providing OCaml bindings to Guile.
> >
> > I think this allows pretty cool combinations of OCaml and Guile
> > code!
> >
> > Cheers,
> > pukkamustard
> >
>
>
>
>
Closed
?