[PATCH] gnu: Add emacs-pdfgrep.

  • Done
  • quality assurance status badge
Details
3 participants
  • Nicolas Goaziou
  • pinoaffe
  • Ricardo Wurmus
Owner
unassigned
Submitted by
pinoaffe
Severity
normal
P
P
pinoaffe wrote on 13 Aug 2022 14:08
(address . guix-patches@gnu.org)
875yiwtkgj.fsf@gmail.com
Date: Sat, 13 Aug 2022 13:59:20 +0200
From ed9c9546ff4ed6f24dd534fc80854755f20d8de1 Mon Sep 17 00:00:00 2001
* gnu/packages/emacs-xyz.scm (emacs-pdfgrep): New variable.
---
gnu/packages/emacs-xyz.scm | 24 +++++++++++++++++++++++-
1 file changed, 23 insertions(+), 1 deletion(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3c1d322db3..18e32a3283 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -70,7 +70,7 @@
;;; Copyright © 2020 Jérémy Korwin-Zmijowski <jeremy@korwin-zmijowski.fr>
;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2020 pinoaffe <pinoaffe@airmail.cc>
+;;; Copyright © 2020, 2022 pinoaffe <pinoaffe@gmail.com>
;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
@@ -3839,6 +3839,28 @@ (define-public emacs-saveplace-pdf-view
restore the saved place.")
(license license:gpl3+)))
+(define-public emacs-pdfgrep
+ (let* ((commit "a4ca0a1e6521de93f28bb6736a5344b4974d144c")
+ (revision "0"))
+ (package
+ (name "emacs-pdfgrep")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jeremy-compostella/pdfgrep.git")
+ (commit commit)))
+ (sha256
+ (base32 "093sm3ywa338lhhz2ib3ylcgklsbxcsqck2qsaq26i2qxr0r7lq2"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list pdfgrep))
+ (home-page "https://github.com/jeremy-compostella/pdfgrep")
+ (synopsis "Run `pdfgrep' within Emacs and display the results.")
+ (description
+ "This package provides the Emacs \"grep\" facilities for the pdfgrep program.")
+ (license license:gpl3+))))
+
(define-public emacs-dash
(package
(name "emacs-dash")
--
2.37.1
R
R
Ricardo Wurmus wrote on 23 Aug 2022 12:07
(address . 57171@debbugs.gnu.org)
87fshnz2y4.fsf@elephly.net
Thanks for the patch.

I’d change the let* to let, because we don’t need previous bindings to
be available in later bindings.

It would also be nice to avoid propagating pdfgrep.
We could probably avoid propagation by patching
and perhaps also line 81 (executable-find "pdfgrep").

In the synopsis I’d remove the `…' quotes, but that’s a nit-pick.

What do you think?

--
Ricardo
P
P
pinoaffe wrote on 19 Sep 2022 22:05
[PATCH v2] gnu: Add emacs-pdfgrep.
(address . 57171@debbugs.gnu.org)
878rmf2kq3.fsf@gmail.com
Date: Sat, 13 Aug 2022 13:59:20 +0200
From 28d500390c6eee5e89b9fb3c756300751b8af598 Mon Sep 17 00:00:00 2001
* gnu/packages/emacs-xyz.scm (emacs-pdfgrep): New variable.
---
gnu/packages/emacs-xyz.scm | 35 ++++++++++++++++++++++++++++++++++-
1 file changed, 34 insertions(+), 1 deletion(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3c1d322db3..8f5c445973 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -70,7 +70,7 @@
;;; Copyright © 2020 Jérémy Korwin-Zmijowski <jeremy@korwin-zmijowski.fr>
;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2020 pinoaffe <pinoaffe@airmail.cc>
+;;; Copyright © 2020, 2022 pinoaffe <pinoaffe@gmail.com>
;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
@@ -3839,6 +3839,39 @@ (define-public emacs-saveplace-pdf-view
restore the saved place.")
(license license:gpl3+)))
+(define-public emacs-pdfgrep
+ (let ((commit "a4ca0a1e6521de93f28bb6736a5344b4974d144c")
+ (revision "0"))
+ (package
+ (name "emacs-pdfgrep")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jeremy-compostella/pdfgrep.git")
+ (commit commit)))
+ (sha256
+ (base32 "093sm3ywa338lhhz2ib3ylcgklsbxcsqck2qsaq26i2qxr0r7lq2"))))
+ (build-system emacs-build-system)
+ (arguments `(#:phases
+ (modify-phases %standard-phases
+ (add-after
+ 'unpack
+ 'patch-pdfgrep-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (make-file-writable "pdfgrep.el")
+ (emacs-substitute-variables "pdfgrep.el"
+ ("pdfgrep-program"
+ (search-input-file inputs "bin/pdfgrep")))
+ #t)))))
+ (inputs (list pdfgrep))
+ (home-page "https://github.com/jeremy-compostella/pdfgrep")
+ (synopsis "Run pdfgrep within Emacs and display the results.")
+ (description
+ "This package provides the Emacs \"grep\" facilities for the pdfgrep program.")
+ (license license:gpl3+))))
+
(define-public emacs-dash
(package
(name "emacs-dash")
--
2.37.2
N
N
Nicolas Goaziou wrote on 20 Sep 2022 21:38
(name . pinoaffe)(address . pinoaffe@gmail.com)(address . 57171-done@debbugs.gnu.org)
87sfklx2d4.fsf@nicolasgoaziou.fr
Hello,

pinoaffe <pinoaffe@gmail.com> writes:

Toggle quote (4 lines)
> Date: Sat, 13 Aug 2022 13:59:20 +0200
> From 28d500390c6eee5e89b9fb3c756300751b8af598 Mon Sep 17 00:00:00 2001
> * gnu/packages/emacs-xyz.scm (emacs-pdfgrep): New variable.

Thank you. Applied with the following changes.

Toggle quote (7 lines)
> +(define-public emacs-pdfgrep
> + (let ((commit "a4ca0a1e6521de93f28bb6736a5344b4974d144c")
> + (revision "0"))
> + (package
> + (name "emacs-pdfgrep")
> + (version (git-version "0" revision commit))

Latest version is actually 1.4. I also downgraded the commit to the one
matching the version bump.

Toggle quote (2 lines)
I removed the ".git" suffix from the URL.
Toggle quote (10 lines)
> + (add-after
> + 'unpack
> + 'patch-pdfgrep-path
> + (lambda* (#:key inputs #:allow-other-keys)
> + (make-file-writable "pdfgrep.el")
> + (emacs-substitute-variables "pdfgrep.el"
> + ("pdfgrep-program"
> + (search-input-file inputs "bin/pdfgrep")))
> + #t)))))

I removed the trailing #t.

Toggle quote (4 lines)
> + (synopsis "Run pdfgrep within Emacs and display the results.")
> + (description
> + "This package provides the Emacs \"grep\" facilities for the pdfgrep program.")

I used the description from the repository, which seemed more clear.

Regards,
--
Nicolas Goaziou
Closed
?