[PATCH] Add package ghc-roman-numerals

  • Done
  • quality assurance status badge
Details
2 participants
  • Alice BRENON
  • Thompson, David
Owner
unassigned
Submitted by
Alice BRENON
Severity
normal
A
A
Alice BRENON wrote on 11 Aug 2022 15:00
(address . guix-patches@gnu.org)
20220811150059.3e5000cb@ens-lyon.fr
Hello guix,

Here is a new haskell package useful to play with roman numerals. The
package's synopsis and description from the hackage import seemed
complete enough, I left them as they were and only applied styling with
the 'format' rule.

Best regards,

Alice
From 564b33c77d1cc00c9bb82729ac6e5abfa3fd1c81 Mon Sep 17 00:00:00 2001
From: Alice BRENON <alice.brenon@ens-lyon.fr>
Date: Thu, 11 Aug 2022 14:29:44 +0200
Subject: [PATCH] gnu: Add ghc-roman-numerals.

* gnu/packages/haskell-xyz.scm (ghc-roman-numerals): New variable.
---
gnu/packages/haskell-xyz.scm | 22 +++++++++++++++++++++-
1 file changed, 21 insertions(+), 1 deletion(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 0ce47e0902..35eab3028f 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -28,7 +28,7 @@
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
;;; Copyright © 2020 Christine Lemmer-Webber <cwebber@dustycloud.org>
-;;; Copyright © 2021 Alice BRENON <alice.brenon@ens-lyon.fr>
+;;; Copyright © 2021, 2022 Alice BRENON <alice.brenon@ens-lyon.fr>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -16105,3 +16105,23 @@ (define-public ghc-singleton-bool
"This package provides Type-level booleans.")
(license license:bsd-3)))
+(define-public ghc-roman-numerals
+ (package
+ (name "ghc-roman-numerals")
+ (version "0.5.1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (hackage-uri "roman-numerals" version))
+ (sha256
+ (base32
+ "10da5vls9l5i255bapms4b2r7dnwmxgsaa1cdll2lrmid5dikixr"))))
+ (build-system haskell-build-system)
+ (inputs (list ghc-base-unicode-symbols))
+ (home-page "https://github.com/roelvandijk/roman-numerals")
+ (synopsis "Parsing and pretty printing of Roman numerals")
+ (description
+ "This library provides functions for parsing and pretty printing Roman numerals.
+Because the notation of Roman numerals has varied through the centuries this
+package allows for some customisation using a configuration that is passed to
+the conversion functions.")
+ (license license:bsd-3)))
--
2.37.1
A
A
Alice BRENON wrote on 31 Aug 2022 16:00
(address . 57139@debbugs.gnu.org)
20220831160016.2fb7cf83@ens-lyon.fr
Following the advice from @lilyp and @dthompson to insert
ghc-roman-numerals alphabetically into haskell-xyz.scm, here's a second
version of the previous patch.


Le Thu, 11 Aug 2022 13:02:02 +0000,
help-debbugs@gnu.org (GNU bug Tracking System) a écrit :

Toggle quote (17 lines)
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
> guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 57139@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
From 8abd49aef89f08c7363b11bb238f603fe1543a92 Mon Sep 17 00:00:00 2001
From: Alice BRENON <alice.brenon@ens-lyon.fr>
Date: Thu, 11 Aug 2022 14:29:44 +0200
Subject: [PATCH] gnu: Add ghc-roman-numerals.

* gnu/packages/haskell-xyz.scm (ghc-roman-numerals): New variable.
---
gnu/packages/haskell-xyz.scm | 23 ++++++++++++++++++++++-
1 file changed, 22 insertions(+), 1 deletion(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 039f4871f2..a01248f355 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -28,7 +28,7 @@
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
;;; Copyright © 2020 Christine Lemmer-Webber <cwebber@dustycloud.org>
-;;; Copyright © 2021 Alice BRENON <alice.brenon@ens-lyon.fr>
+;;; Copyright © 2021, 2022 Alice BRENON <alice.brenon@ens-lyon.fr>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -10913,6 +10913,27 @@ (define-public ghc-rio
@end itemize")
(license license:expat)))
+(define-public ghc-roman-numerals
+ (package
+ (name "ghc-roman-numerals")
+ (version "0.5.1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (hackage-uri "roman-numerals" version))
+ (sha256
+ (base32
+ "10da5vls9l5i255bapms4b2r7dnwmxgsaa1cdll2lrmid5dikixr"))))
+ (build-system haskell-build-system)
+ (inputs (list ghc-base-unicode-symbols))
+ (home-page "https://github.com/roelvandijk/roman-numerals")
+ (synopsis "Parsing and pretty printing of Roman numerals")
+ (description
+ "This library provides functions for parsing and pretty printing Roman numerals.
+Because the notation of Roman numerals has varied through the centuries this
+package allows for some customisation using a configuration that is passed to
+the conversion functions.")
+ (license license:bsd-3)))
+
(define-public ghc-safe
(package
(name "ghc-safe")
--
2.37.1
T
T
Thompson, David wrote on 31 Aug 2022 20:51
(name . Alice BRENON)(address . alice.brenon@ens-lyon.fr)
CAJ=Rwfaui0adLsu0A7bHKkoDeDDfMdgoE8GcpF0VV7Wo3=AQ_w@mail.gmail.com
Hi Alice,

On Wed, Aug 31, 2022 at 10:01 AM Alice BRENON <alice.brenon@ens-lyon.fr> wrote:
Toggle quote (5 lines)
>
> Following the advice from @lilyp and @dthompson to insert
> ghc-roman-numerals alphabetically into haskell-xyz.scm, here's a second
> version of the previous patch.

Thank you for the patch! It builds successfully for me and the code
looks good, so I pushed it.

- Dave
?