[PATCH] gnu: Add emacs-tmr.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Nicolas Goaziou
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote on 7 Aug 2022 05:16
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220807031618.13066-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-tmr): New variable.
---
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2b360e53cc..bc81d3a44b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13675,6 +13675,27 @@ (define-public emacs-logos
(license (list license:gpl3+
license:fdl1.3+)))) ; GFDLv1.3+ for the manual
+(define-public emacs-tmr
+ (package
+ (name "emacs-tmr")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~protesilaos/tmr")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vz9zfqap221baiy41wpxph33g6h2plnanzgpjs0wk8dz1fpwfky"))))
+ (build-system emacs-build-system)
+ (native-inputs (list texinfo))
+ (home-page "https://protesilaos.com/emacs/tmr/")
+ (synopsis "Set timers using a convenient notation")
+ (description
+"Emacs package to set timers using a convenient notation")
+ (license license:gpl3+)))
+
(define-public emacs-gn-mode
(package
(name "emacs-gn-mode")
--
2.37.1
J
[PATCH v2] gnu: Add emacs-tmr.
(address . 57027@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20220810003149.23233-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-tmr): New variable.

Forgot to patch ffplay ;()
---
gnu/packages/emacs-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2691072268..bb63c9bd79 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13676,6 +13676,40 @@ (define-public emacs-logos
(license (list license:gpl3+
license:fdl1.3+)))) ; GFDLv1.3+ for the manual
+(define-public emacs-tmr
+ (package
+ (name "emacs-tmr")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~protesilaos/tmr")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vz9zfqap221baiy41wpxph33g6h2plnanzgpjs0wk8dz1fpwfky"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-ffplay
+ (lambda* (#:key inputs #:allow-other-keys)
+ (make-file-writable "tmr.el")
+ (substitute* "tmr.el"
+ (("\"ffplay")
+ (string-append "\""
+ (search-input-file inputs
+ "/bin/ffplay")))))))))
+ (native-inputs (list texinfo))
+ (inputs (list ffmpeg))
+ (home-page "https://protesilaos.com/emacs/tmr/")
+ (synopsis "Set timers using a convenient notation")
+ (description
+"Emacs package to set timers using a convenient notation.")
+ (license license:gpl3+)))
+
(define-public emacs-gn-mode
(package
(name "emacs-gn-mode")
--
2.37.1
N
N
Nicolas Goaziou wrote on 26 Aug 2022 10:29
(name . jgart)(address . jgart@dismail.de)(address . 57027-done@debbugs.gnu.org)
877d2vquf2.fsf@nicolasgoaziou.fr
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-tmr): New variable.

Applied. Thank you.

Toggle quote (3 lines)
> + (description
> +"Emacs package to set timers using a convenient notation.")

I changed this into a full sentence.

Regards,
--
Nicolas Goaziou
Closed
?