[PATCH] gnu: Add emacs-denote.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Nicolas Goaziou
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote on 7 Aug 2022 05:15
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220807031541.12946-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-denote): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 08b2359577..2b360e53cc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13617,6 +13617,28 @@ (define-public emacs-log4e
you to deal with multiple log levels.")
(license license:gpl3+)))
+(define-public emacs-denote
+ (package
+ (name "emacs-denote")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~protesilaos/denote")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vh0nc416yyhnqsp1vwk889iic0412hx4h1qf49b1gmzjy566v2n"))))
+ (build-system emacs-build-system)
+ (native-inputs (list texinfo))
+ (home-page "https://protesilaos.com/emacs/denote/")
+ (synopsis "Simple notes for Emacs")
+ (description
+"Denote aims to be a simple-to-use, focused-in-scope, and effective
+note-taking tool for Emacs.")
+ (license license:gpl3+)))
+
(define-public emacs-logos
(package
(name "emacs-logos")
--
2.37.1
J
[PATCH v2] gnu: Add emacs-denote.
(address . 57026@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20220811030626.20105-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-denote): New variable.

Just sending a v2 since 0.5.0 was released.

---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 690858ba6a..7df2262429 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13618,6 +13618,28 @@ (define-public emacs-log4e
you to deal with multiple log levels.")
(license license:gpl3+)))
+(define-public emacs-denote
+ (package
+ (name "emacs-denote")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~protesilaos/denote")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0z2q0xl4h6x0b38582mgx4i1h21lrn4i508zj9siripqixzb95ak"))))
+ (build-system emacs-build-system)
+ (native-inputs (list texinfo))
+ (home-page "https://protesilaos.com/emacs/denote/")
+ (synopsis "Simple notes for Emacs")
+ (description
+"Denote aims to be a simple-to-use, focused-in-scope, and effective
+note-taking tool for Emacs.")
+ (license license:gpl3+)))
+
(define-public emacs-logos
(package
(name "emacs-logos")
--
2.37.1
J
(address . 57026@debbugs.gnu.org)
20220811085650.GB1823@gac
On Wed, 10 Aug 2022 22:06:27 -0500 jgart <jgart@dismail.de> wrote:
Toggle quote (4 lines)
> * gnu/packages/emacs-xyz.scm (emacs-denote): New variable.
>
> Just sending a v2 since 0.5.0 was released.

This version might have a bug. I need to ask prot about it.

When calling `denote` it throws an error and doesn't display the header lines (front matter?).

Is anybody able to reproduce that?

all best,

jgart

Toggle quote (41 lines)
>
> ---
> gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
> 1 file changed, 22 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 690858ba6a..7df2262429 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -13618,6 +13618,28 @@ (define-public emacs-log4e
> you to deal with multiple log levels.")
> (license license:gpl3+)))
>
> +(define-public emacs-denote
> + (package
> + (name "emacs-denote")
> + (version "0.5.0")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://git.sr.ht/~protesilaos/denote")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "0z2q0xl4h6x0b38582mgx4i1h21lrn4i508zj9siripqixzb95ak"))))
> + (build-system emacs-build-system)
> + (native-inputs (list texinfo))
> + (home-page "https://protesilaos.com/emacs/denote/")
> + (synopsis "Simple notes for Emacs")
> + (description
> +"Denote aims to be a simple-to-use, focused-in-scope, and effective
> +note-taking tool for Emacs.")
> + (license license:gpl3+)))
> +
> (define-public emacs-logos
> (package
> (name "emacs-logos")
> --
> 2.37.1
>
J
[PATCH v3] gnu: Add emacs-denote.
(address . 57026@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20220811223333.9050-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-denote): New variable.

0.5.1 is here! yayyyyyyyy

---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 690858ba6a..53641a7afa 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13618,6 +13618,28 @@ (define-public emacs-log4e
you to deal with multiple log levels.")
(license license:gpl3+)))
+(define-public emacs-denote
+ (package
+ (name "emacs-denote")
+ (version "0.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~protesilaos/denote")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00f50dhw0x1hn87rc6vkrdwpybnbphg5z0g2c6c4r4cbgaiia8bi"))))
+ (build-system emacs-build-system)
+ (native-inputs (list texinfo))
+ (home-page "https://protesilaos.com/emacs/denote/")
+ (synopsis "Simple notes for Emacs")
+ (description
+"Denote aims to be a simple-to-use, focused-in-scope, and effective
+note-taking tool for Emacs.")
+ (license license:gpl3+)))
+
(define-public emacs-logos
(package
(name "emacs-logos")
--
2.37.1
N
N
Nicolas Goaziou wrote on 26 Aug 2022 10:37
(name . jgart)(address . jgart@dismail.de)(address . 57026-done@debbugs.gnu.org)
8735djqu25.fsf@nicolasgoaziou.fr
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-denote): New variable.

Applied. Thank you.

Toggle quote (4 lines)
> + (description
> +"Denote aims to be a simple-to-use, focused-in-scope, and effective
> +note-taking tool for Emacs.")

I replaced this with the description from the homepage. It seemed more
useful.

Regards,
--
Nicolas Goaziou
Closed
?