[PATCH] gnu: Add font-latin-modern.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nguy?n Gia Phong
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Nguy?n Gia Phong
Severity
normal
N
N
Nguy?n Gia Phong wrote on 22 Jul 2022 13:35
(address . guix-patches@gnu.org)(name . Nguy?n Gia Phong)(address . mcsinyx@disroot.org)
20220722113554.3896-1-mcsinyx@disroot.org
* gnu/packages/fonts.scm (font-latin-modern): New variable.
---
gnu/packages/fonts.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index a381f061af94..f7fa124edf00 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
+;;; Copyright © 2022 Nguy?n Gia Phong <mcsinyx@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -731,6 +732,23 @@ (define-public font-tex-gyre
Heros, Pagella, Schola, Termes.")
(license license:gfl1.0)))
+(define-public font-latin-modern
+ (package
+ (name "font-latin-modern")
+ (version "2.004")
+ (source
+ (origin
+ (method url-fetch/zipbomb)
+ (uri (string-append "http://www.gust.org.pl/projects/e-foundry/"
+ "latin-modern/download/lm" version "otf.zip"))
+ (sha256
+ (base32 "06qnvd6kh07gy2197vx3nmskhiqhp7ip9cpi2rkbwa1p3l2kc0jv"))))
+ (build-system font-build-system)
+ (home-page "http://www.gust.org.pl/projects/e-foundry/latin-modern")
+ (synopsis "OpenType fonts based on Computer Modern")
+ (description "The Latin Modern fonts are a set of scalable fonts based on the PostScript Type 1 version of the Computer Modern fonts and contain many additional characters (mostly accented ones). This package provides the OpenType variant of these fonts.")
+ (license license:gfl1.0)))
+
(define-public font-amiri
(package
(name "font-amiri")
--
2.37.0
N
N
Nguy?n Gia Phong wrote on 3 Aug 2022 03:22
[PATCH v2] gnu: Add font-latin-modern.
(address . 56705@debbugs.gnu.org)(name . Nguy?n Gia Phong)(address . mcsinyx@disroot.org)
20220803012239.23378-1-mcsinyx@disroot.org
* gnu/packages/fonts.scm (font-latin-modern): New variable.
---
This time with secure links.
gnu/packages/fonts.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index a381f061af94..59116eccff55 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
+;;; Copyright © 2022 Nguy?n Gia Phong <mcsinyx@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -731,6 +732,23 @@ (define-public font-tex-gyre
Heros, Pagella, Schola, Termes.")
(license license:gfl1.0)))
+(define-public font-latin-modern
+ (package
+ (name "font-latin-modern")
+ (version "2.004")
+ (source
+ (origin
+ (method url-fetch/zipbomb)
+ (uri (string-append "https://www.gust.org.pl/projects/e-foundry/"
+ "latin-modern/download/lm" version "otf.zip"))
+ (sha256
+ (base32 "06qnvd6kh07gy2197vx3nmskhiqhp7ip9cpi2rkbwa1p3l2kc0jv"))))
+ (build-system font-build-system)
+ (home-page "https://www.gust.org.pl/projects/e-foundry/latin-modern")
+ (synopsis "OpenType fonts based on Computer Modern")
+ (description "The Latin Modern fonts are a set of scalable fonts based on the PostScript Type 1 version of the Computer Modern fonts and contain many additional characters (mostly accented ones). This package provides the OpenType variant of these fonts.")
+ (license license:gfl1.0)))
+
(define-public font-amiri
(package
(name "font-amiri")
--
2.37.1
N
N
Nguy?n Gia Phong wrote on 18 Aug 2022 08:06
(address . 56705@debbugs.gnu.org)
CM8XGCNWV539.90TRIXVOMTQT@nix
Could someone please take a look at this?
R
R
Ricardo Wurmus wrote on 18 Aug 2022 22:56
[PATCH] gnu: Add font-latin-modern.
(address . 56705-done@debbugs.gnu.org)
87wnb52rsq.fsf@elephly.net
Thank you for your patch! I broke the long line of the description into
a paragraph and pushed the patch to the master branch with commit
“9cde566b9cd84c999c0074c906928e2cbef1ef30”.

--
Ricardo
Closed
N
N
Nguy?n Gia Phong wrote on 19 Aug 2022 06:44
Re: [PATCH v2] gnu: Add font-latin-modern.
CM9QC5YLS1BP.1ZUJ3EW0RDP2W@nix
Thanks! BTW how do I subscribe to a specific debbugs ticket
(not the whole guix-patches)? I did not get your response,
only the ticket done notification.
?