test failures tests/channels.scm and tests/texlive.scm

  • Open
  • quality assurance status badge
Details
3 participants
  • Chris Keschnat
  • Ludovic Courtès
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Chris Keschnat
Severity
normal
C
C
Chris Keschnat wrote on 20 Jul 2022 16:29
(address . bug-guix@gnu.org)
86pmhzu9ph.fsf@catsu.it
Hello,
I am trying to follow "16.1 Building from Git"[1] but this results
in two test failures on my machine.

Initially I ran:

#+begin_src sh

cd guix
git fetch origin keyring:keyring
guix git authenticate 9edb3f66fd807b096b48283debdcddccfea34bad \
"BBB0 2DDF 2CEA F6A8 0D1D E643 A2A0 6DF2 A33A 54FA"
guix environment guix --pure --ad-hoc help2man git strace
./bootstrap
./configure --localstatedir=/var
make && make check

#+end_src

Rerunning only the failed tests:

#+begin_src sh

make check TESTS="tests/channels.scm tests/texlive.scm"

#+end_src

Output:

#+begin_src sh

$ make check TESTS="tests/channels.scm tests/texlive.scm"
make check-recursive
make[1]: Entering directory '/home/ck/tmp/guix'
Making check in po/guix
make[2]: Entering directory '/home/ck/tmp/guix/po/guix'
make[2]: Nothing to be done for 'check'.
make[2]: Leaving directory '/home/ck/tmp/guix/po/guix'
Making check in po/packages
make[2]: Entering directory '/home/ck/tmp/guix/po/packages'
make[2]: Nothing to be done for 'check'.
make[2]: Leaving directory '/home/ck/tmp/guix/po/packages'
make[2]: Entering directory '/home/ck/tmp/guix'
Compiling Scheme modules...
Compiling Scheme modules...
Compiling Scheme modules...
Compiling Scheme modules...
make check-TESTS check-local
make[3]: Entering directory '/home/ck/tmp/guix'
make[4]: Entering directory '/home/ck/tmp/guix'
FAIL: tests/channels.scm
FAIL: tests/texlive.scm
============================================================================
Testsuite summary for GNU Guix 1.3.0.22336-479d9e
============================================================================
# TOTAL: 19
# PASS: 13
# SKIP: 4
# XFAIL: 0
# FAIL: 2
# XPASS: 0
# ERROR: 0
============================================================================
See ./test-suite.log
Please report to bug-guix@gnu.org
============================================================================
make[4]: *** [Makefile:5964: test-suite.log] Error 1
make[4]: Leaving directory '/home/ck/tmp/guix'
make[3]: *** [Makefile:6072: check-TESTS] Error 2
make[3]: Leaving directory '/home/ck/tmp/guix'
make[2]: *** [Makefile:6321: check-am] Error 2
make[2]: Leaving directory '/home/ck/tmp/guix'
make[1]: *** [Makefile:5849: check-recursive] Error 1
make[1]: Leaving directory '/home/ck/tmp/guix'
make: *** [Makefile:6323: check] Error 2

#+end_src

And results in the attached =test-suite.log=
Attachment: test-suite.log
Am I doing anything wrong? I tried reading the results but cannot figure
out what is wrong.
.



Thank you
Chris
L
L
Ludovic Courtès wrote on 21 Jul 2022 01:29
(name . Chris Keschnat)(address . chris@catsu.it)(address . 56667@debbugs.gnu.org)
87v8rrnz15.fsf@gnu.org
Hi,

Chris Keschnat <chris@catsu.it> skribis:

Toggle quote (6 lines)
> test-name: channel-news, one entry
> location: /home/ck/tmp/guix/tests/channels.scm:323
> source:
> + (test-assert
> + "channel-news, one entry"

[...]

Toggle quote (3 lines)
> + (entry (tag "tag-for-first-news-entry")
> + (title (en "Old news.") (eo "Malnova?oj."))

The question mark above suggests you were not running the test in a
Unicode-capable locale. I think you may need to first run:

export LC_ALL=en_US.UTF-8

or something similar.

Could you check whether that helps?

Toggle quote (9 lines)
> FAIL: tests/texlive
> ===================
>
> (package (inherit (simple-texlive-package "texlive-texsis" (list "bibtex/bst/texsis/" "doc/man/man1/" "doc/otherformats/texsis/base/" "tex/texsis/base/" "tex/texsis/config/") (base32 "17ckkii656y2g1h5h8lc1bsy10a0bfgnsakhxii4hxfmvrfvc097") #:trivial? #t)) (version "59745") (propagated-inputs (list texlive-cm texlive-hyphen-base texlive-knuth-lib texlive-plain texlive-tex)) (home-page "https://www.tug.org/texlive/") (synopsis "Plain TeX macros for Physicists") (description "TeXsis is a TeX macro package which provides useful features for typesetting\nresearch papers and related documents. For example, it includes support\nspecifically for: Automatic numbering of equations, figures, tables and\nreferences; Simplified control of type sizes, line spacing, footnotes, running\nheadlines and footlines, and tables of contents, figures and tables; Specialized\ndocument formats for research papers, preprints and \"e-prints\", conference\nproceedings, theses, books, referee reports, letters, and memoranda; Simplified\nmeans of constructing an index for a book or thesis; Easy to use double column\nformatting; Specialized environments for lists, theorems and proofs, centered or\nnon-justified text, and listing computer code; Specialized macros for easily\nconstructing ruled tables. TeXsis was originally developed for physicists, but\nothers may also find it useful. It is completely compatible with Plain TeX.") (license lppl))
>
> ;;; (fail (package (inherit (simple-texlive-package "texlive-texsis" (list "bibtex/bst/texsis/" "doc/man/man1/" "doc/otherformats/texsis/base/" "tex/texsis/base/" "tex/texsis/config/") (base32 "17ckkii656y2g1h5h8lc1bsy10a0bfgnsakhxii4hxfmvrfvc097") #:trivial? #t)) (version "59745") (propagated-inputs (list texlive-cm texlive-hyphen-base texlive-knuth-lib texlive-plain texlive-tex)) (home-page "https://www.tug.org/texlive/") (synopsis "Plain TeX macros for Physicists") (description "TeXsis is a TeX macro package which provides useful features for typesetting\nresearch papers and related documents. For example, it includes support\nspecifically for: Automatic numbering of equations, figures, tables and\nreferences; Simplified control of type sizes, line spacing, footnotes, running\nheadlines and footlines, and tables of contents, figures and tables; Specialized\ndocument formats for research papers, preprints and \"e-prints\", conference\nproceedings, theses, books, referee reports, letters, and memoranda; Simplified\nmeans of constructing an index for a book or thesis; Easy to use double column\nformatting; Specialized environments for lists, theorems and proofs, centered or\nnon-justified text, and listing computer code; Specialized macros for easily\nconstructing ruled tables. TeXsis was originally developed for physicists, but\nothers may also find it useful. It is completely compatible with Plain TeX.") (license lppl)) #f)
> test-name: texlive->guix-package
> location: /home/ck/tmp/guix/tests/texlive.scm:161

Hmm this one is unclear; it passes on my laptop. Needs more
investigation…

Thanks for reporting the issue!

Ludo’.
C
C
Chris Keschnat wrote on 21 Jul 2022 09:58
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 56667@debbugs.gnu.org)
865yjqopzf.fsf@catsu.it
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (24 lines)
> Hi,
>
> Chris Keschnat <chris@catsu.it> skribis:
>
>> test-name: channel-news, one entry
>> location: /home/ck/tmp/guix/tests/channels.scm:323
>> source:
>> + (test-assert
>> + "channel-news, one entry"
>
> [...]
>
>> + (entry (tag "tag-for-first-news-entry")
>> + (title (en "Old news.") (eo "Malnova?oj."))
>
> The question mark above suggests you were not running the test in a
> Unicode-capable locale. I think you may need to first run:
>
> export LC_ALL=en_US.UTF-8
>
> or something similar.
>
> Could you check whether that helps?

Hi Ludovic,
thank you, that does indeed make the test pass.

Toggle quote (1 lines)
> [...]
L
L
Ludovic Courtès wrote on 22 Jul 2022 22:50
(name . Chris Keschnat)(address . chris@catsu.it)
875yjohnxw.fsf@gnu.org
Hi,

Chris Keschnat <chris@catsu.it> skribis:

Toggle quote (9 lines)
> FAIL: tests/texlive
> ===================
>
> (package (inherit (simple-texlive-package "texlive-texsis" (list "bibtex/bst/texsis/" "doc/man/man1/" "doc/otherformats/texsis/base/" "tex/texsis/base/" "tex/texsis/config/") (base32 "17ckkii656y2g1h5h8lc1bsy10a0bfgnsakhxii4hxfmvrfvc097") #:trivial? #t)) (version "59745") (propagated-inputs (list texlive-cm texlive-hyphen-base texlive-knuth-lib texlive-plain texlive-tex)) (home-page "https://www.tug.org/texlive/") (synopsis "Plain TeX macros for Physicists") (description "TeXsis is a TeX macro package which provides useful features for typesetting\nresearch papers and related documents. For example, it includes support\nspecifically for: Automatic numbering of equations, figures, tables and\nreferences; Simplified control of type sizes, line spacing, footnotes, running\nheadlines and footlines, and tables of contents, figures and tables; Specialized\ndocument formats for research papers, preprints and \"e-prints\", conference\nproceedings, theses, books, referee reports, letters, and memoranda; Simplified\nmeans of constructing an index for a book or thesis; Easy to use double column\nformatting; Specialized environments for lists, theorems and proofs, centered or\nnon-justified text, and listing computer code; Specialized macros for easily\nconstructing ruled tables. TeXsis was originally developed for physicists, but\nothers may also find it useful. It is completely compatible with Plain TeX.") (license lppl))
>
> ;;; (fail (package (inherit (simple-texlive-package "texlive-texsis" (list "bibtex/bst/texsis/" "doc/man/man1/" "doc/otherformats/texsis/base/" "tex/texsis/base/" "tex/texsis/config/") (base32 "17ckkii656y2g1h5h8lc1bsy10a0bfgnsakhxii4hxfmvrfvc097") #:trivial? #t)) (version "59745") (propagated-inputs (list texlive-cm texlive-hyphen-base texlive-knuth-lib texlive-plain texlive-tex)) (home-page "https://www.tug.org/texlive/") (synopsis "Plain TeX macros for Physicists") (description "TeXsis is a TeX macro package which provides useful features for typesetting\nresearch papers and related documents. For example, it includes support\nspecifically for: Automatic numbering of equations, figures, tables and\nreferences; Simplified control of type sizes, line spacing, footnotes, running\nheadlines and footlines, and tables of contents, figures and tables; Specialized\ndocument formats for research papers, preprints and \"e-prints\", conference\nproceedings, theses, books, referee reports, letters, and memoranda; Simplified\nmeans of constructing an index for a book or thesis; Easy to use double column\nformatting; Specialized environments for lists, theorems and proofs, centered or\nnon-justified text, and listing computer code; Specialized macros for easily\nconstructing ruled tables. TeXsis was originally developed for physicists, but\nothers may also find it useful. It is completely compatible with Plain TeX.") (license lppl)) #f)
> test-name: texlive->guix-package
> location: /home/ck/tmp/guix/tests/texlive.scm:161

Actually I’m now experiencing it, and I think it’s caused by commit
be7b314f3fe22273e935accac22f313e44d3d970, which changes the ‘texlive’
importer.

Ricardo, WDYT?

Thanks,
Ludo’.
R
R
Ricardo Wurmus wrote on 22 Jul 2022 23:04
(name . Ludovic Courtès)(address . ludo@gnu.org)
87pmhwrh9g.fsf@elephly.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (62 lines)
> Hi,
>
> Chris Keschnat <chris@catsu.it> skribis:
>
>> FAIL: tests/texlive
>> ===================
>>
>> (package (inherit (simple-texlive-package "texlive-texsis" (list
>> "bibtex/bst/texsis/" "doc/man/man1/" "doc/otherformats/texsis/base/"
>> "tex/texsis/base/" "tex/texsis/config/") (base32
>> "17ckkii656y2g1h5h8lc1bsy10a0bfgnsakhxii4hxfmvrfvc097") #:trivial?
>> #t)) (version "59745") (propagated-inputs (list texlive-cm
>> texlive-hyphen-base texlive-knuth-lib texlive-plain texlive-tex))
>> (home-page "https://www.tug.org/texlive/") (synopsis "Plain TeX
>> macros for Physicists") (description "TeXsis is a TeX macro package
>> which provides useful features for typesetting\nresearch papers and
>> related documents. For example, it includes support\nspecifically
>> for: Automatic numbering of equations, figures, tables
>> and\nreferences; Simplified control of type sizes, line spacing,
>> footnotes, running\nheadlines and footlines, and tables of contents,
>> figures and tables; Specialized\ndocument formats for research
>> papers, preprints and \"e-prints\", conference\nproceedings, theses,
>> books, referee reports, letters, and memoranda; Simplified\nmeans of
>> constructing an index for a book or thesis; Easy to use double
>> column\nformatting; Specialized environments for lists, theorems and
>> proofs, centered or\nnon-justified text, and listing computer code;
>> Specialized macros for easily\nconstructing ruled tables. TeXsis
>> was originally developed for physicists, but\nothers may also find
>> it useful. It is completely compatible with Plain TeX.") (license
>> lppl))
>>
>> ;;; (fail (package (inherit (simple-texlive-package "texlive-texsis"
>> (list "bibtex/bst/texsis/" "doc/man/man1/"
>> "doc/otherformats/texsis/base/" "tex/texsis/base/"
>> "tex/texsis/config/") (base32
>> "17ckkii656y2g1h5h8lc1bsy10a0bfgnsakhxii4hxfmvrfvc097") #:trivial?
>> #t)) (version "59745") (propagated-inputs (list texlive-cm
>> texlive-hyphen-base texlive-knuth-lib texlive-plain texlive-tex))
>> (home-page "https://www.tug.org/texlive/") (synopsis "Plain TeX
>> macros for Physicists") (description "TeXsis is a TeX macro package
>> which provides useful features for typesetting\nresearch papers and
>> related documents. For example, it includes support\nspecifically
>> for: Automatic numbering of equations, figures, tables
>> and\nreferences; Simplified control of type sizes, line spacing,
>> footnotes, running\nheadlines and footlines, and tables of contents,
>> figures and tables; Specialized\ndocument formats for research
>> papers, preprints and \"e-prints\", conference\nproceedings, theses,
>> books, referee reports, letters, and memoranda; Simplified\nmeans of
>> constructing an index for a book or thesis; Easy to use double
>> column\nformatting; Specialized environments for lists, theorems and
>> proofs, centered or\nnon-justified text, and listing computer code;
>> Specialized macros for easily\nconstructing ruled tables. TeXsis
>> was originally developed for physicists, but\nothers may also find
>> it useful. It is completely compatible with Plain TeX.") (license
>> lppl)) #f)
>> test-name: texlive->guix-package
>> location: /home/ck/tmp/guix/tests/texlive.scm:161
>
> Actually I’m now experiencing it, and I think it’s caused by commit
> be7b314f3fe22273e935accac22f313e44d3d970, which changes the ‘texlive’
> importer.

My apologies. Fixed with commit c9a37f57cbb18be01436a709cbdd96ffea41caf5.

--
Ricardo
?