[PATCH] gnu: Add python-django-cleanup.

  • Done
  • quality assurance status badge
Details
2 participants
  • Luis Felipe
  • Marius Bakke
Owner
unassigned
Submitted by
Luis Felipe
Severity
normal
L
L
Luis Felipe wrote on 13 Jul 2022 18:50
(name . Luis Felipe via Guix-patches)(address . guix-patches@gnu.org)
xagcat1kZc0pGtxkxgjzCSrKzNja-9gtncKZaWS663jq4WQ_IplAheO6lgMIqAmgs6BmOPoIxFjeRarX0suOzjpaWFsLgWcEzKKNqBStwYA=@protonmail.com
Hi, a new package here.


---
Luis Felipe López Acevedo
From 16f5e77b90c262e672ac7c32b25911518a4f1743 Mon Sep 17 00:00:00 2001
From: Luis Felipe <luis.felipe.la@protonmail.com>
Date: Wed, 13 Jul 2022 11:23:02 -0500
Subject: [PATCH] gnu: Add python-django-cleanup.

* gnu/packages/django.scm (python-django-cleanup): New variable.
---
gnu/packages/django.scm | 51 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index b32faab183..7f2783d071 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -1361,3 +1361,54 @@ (define-public python-django-svg-image-form-field
models that use Django's standard @code{ImageField}, in addition to the
image files already supported by it.")
(license license:expat)))
+
+(define-public python-django-cleanup
+ (package
+ (name "python-django-cleanup")
+ (version "6.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/un1t/django-cleanup")
+ (commit (string-append version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0c1nghn1bnlq0a4d3sy3s363ksqsnxksixbimdy3cc6a0vk4sjps"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-tests-settings
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; django-cleanup optionally integrates with
+ ;; sorl-thumbnail, which is not available in Guix yet, so
+ ;; this patch comments it out to avoid import failures in
+ ;; test settings.
+ (substitute* "django_cleanup/testapp/settings.py"
+ (("'sorl\\.thumbnail',") "# 'sorl.thumbnail',"))))
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ ;; Add CWD to PYTHONPATH so that the tests can find the
+ ;; testapp package in the source.
+ (setenv "PYTHONPATH" (getcwd))
+ (invoke "pytest")))))))
+ (native-inputs
+ (list ;; python-django-sorl-thumbnail ; TODO: Add to Guix.
+ python-easy-thumbnails
+ python-pillow
+ python-pytest
+ python-pytest-cov
+ python-pytest-django
+ python-pytest-xdist))
+ (propagated-inputs
+ (list python-django))
+ (home-page "https://github.com/un1t/django-cleanup")
+ (synopsis "Automatically deletes unused media files")
+ (description "This application automatically deletes user-uploaded
+files when a model is modified or deleted. It works for FileField,
+ImageField and their subclasses. Files set as default values for any
+FileField are not deleted.")
+ (license license:expat)))
--
2.36.1
Attachment: signature.asc
L
M
M
Marius Bakke wrote on 29 Aug 2022 17:59
87a67ndos6.fsf@gnu.org
Luis Felipe via Guix-patches via <guix-patches@gnu.org> skriver:

Toggle quote (2 lines)
> Hi, a new package here.

[...]

Toggle quote (2 lines)
> * gnu/packages/django.scm (python-django-cleanup): New variable.

Applied, thanks!
-----BEGIN PGP SIGNATURE-----

iIUEARYKAC0WIQRNTknu3zbaMQ2ddzTocYulkRQQdwUCYwziSQ8cbWFyaXVzQGdu
dS5vcmcACgkQ6HGLpZEUEHfj/gD+IH/WWkz6R+MqiIo7nOt/8UK2tOR9r5nu2nWs
59Va6M0A/0xKsONc4MSIPp2WAm9GmU8R+mz5fe1wWiLtDPhYMuQI
=JRIg
-----END PGP SIGNATURE-----

Closed
?