[PATCH] gnu: Add cl-string-pokemonize.

  • Done
  • quality assurance status badge
Details
3 participants
  • jgart
  • Liliana Marie Prikler
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220710084107.11471-1-jgart@dismail.de
* gnu/packages/lisp-xyz.scm (cl-string-pokemonize): New variable.
---
gnu/packages/lisp-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 129b99e485..18c36ec3f6 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -22647,6 +22647,41 @@ (define-public cl-sketch
(define-public ecl-sketch
(sbcl-package->ecl-package sbcl-sketch))
+(define-public sbcl-string-pokemonize
+ (let ((commit "2dc01643defb497e4d1eb833def71dfc1e8d5da6")
+ (revision "0"))
+ (package
+ (name "sbcl-string-pokemonize")
+ (version (git-version "20210503" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/phoe/string-pokemonize")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zk5klc94pxv7mhx6qrp93rk4ypwd6wfijap7gf9l0wpphg90r9x"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:asd-files '("string-pokemonize.asd")
+ #:asd-systems '("string-pokemonize")))
+ (synopsis "Function to alternate uppercase and lowercase characters")
+ (description
+"Provides a function, @code{string-pokemonize} that alternates uppercase
+and lowercase characters for a given string. The entire code base is
+also entirely stylized in alternating uppercase and lowercase characters
+exemplifying Common Lisp's case insensitivity.")
+ (home-page "https://github.com/phoe/string-pokemonize")
+ (license license:expat))))
+
+(define-public cl-string-pokemonize
+ (sbcl-package->cl-source-package sbcl-string-pokemonize))
+
+(define-public ecl-string-pokemonize
+ (sbcl-package->ecl-package sbcl-string-pokemonize))
+
(define-public sbcl-binary-types
(let ((commit "9ec42042a50403961c08179a892ae3de725b1d7a"))
(package
--
2.37.0
J
[PATCH v2] gnu: Add cl-string-pokemonize.
(address . 56478@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20220710174140.17951-1-jgart@dismail.de
* gnu/packages/lisp-xyz.scm (cl-string-pokemonize): New variable.

Fixes a redundant wording in the description.
---
gnu/packages/lisp-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 129b99e485..60000a504a 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -22647,6 +22647,41 @@ (define-public cl-sketch
(define-public ecl-sketch
(sbcl-package->ecl-package sbcl-sketch))
+(define-public sbcl-string-pokemonize
+ (let ((commit "2dc01643defb497e4d1eb833def71dfc1e8d5da6")
+ (revision "0"))
+ (package
+ (name "sbcl-string-pokemonize")
+ (version (git-version "20210503" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/phoe/string-pokemonize")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zk5klc94pxv7mhx6qrp93rk4ypwd6wfijap7gf9l0wpphg90r9x"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:asd-files '("string-pokemonize.asd")
+ #:asd-systems '("string-pokemonize")))
+ (synopsis "Function to alternate uppercase and lowercase characters")
+ (description
+"Provides a function, @code{string-pokemonize} that alternates uppercase
+and lowercase characters for a given string. The code base is also
+entirely stylized in alternating uppercase and lowercase characters
+exemplifying Common Lisp's case insensitivity.")
+ (home-page "https://github.com/phoe/string-pokemonize")
+ (license license:expat))))
+
+(define-public cl-string-pokemonize
+ (sbcl-package->cl-source-package sbcl-string-pokemonize))
+
+(define-public ecl-string-pokemonize
+ (sbcl-package->ecl-package sbcl-string-pokemonize))
+
(define-public sbcl-binary-types
(let ((commit "9ec42042a50403961c08179a892ae3de725b1d7a"))
(package
--
2.37.0
L
L
Liliana Marie Prikler wrote on 12 Jul 2022 12:02
6c4c7b53c409fc2ee7572b5e8b5a277486e7c0f7.camel@ist.tugraz.at
Am Sonntag, dem 10.07.2022 um 12:41 -0500 schrieb jgart:
Toggle quote (38 lines)
> * gnu/packages/lisp-xyz.scm (cl-string-pokemonize): New variable.
>
> Fixes a redundant wording in the description.
> ---
>  gnu/packages/lisp-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
>  1 file changed, 35 insertions(+)
>
> diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
> index 129b99e485..60000a504a 100644
> --- a/gnu/packages/lisp-xyz.scm
> +++ b/gnu/packages/lisp-xyz.scm
> @@ -22647,6 +22647,41 @@ (define-public cl-sketch
>  (define-public ecl-sketch
>    (sbcl-package->ecl-package sbcl-sketch))
>  
> +(define-public sbcl-string-pokemonize
> +  (let ((commit "2dc01643defb497e4d1eb833def71dfc1e8d5da6")
> +        (revision "0"))
> +    (package
> +     (name "sbcl-string-pokemonize")
> +     (version (git-version "20210503" revision commit))
> +     (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/phoe/string-pokemonize")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32
> "1zk5klc94pxv7mhx6qrp93rk4ypwd6wfijap7gf9l0wpphg90r9x"))))
> +     (build-system asdf-build-system/sbcl)
> +     (arguments
> +      `(#:tests? #f ; There are no tests.
> +        #:asd-files '("string-pokemonize.asd")
> +        #:asd-systems '("string-pokemonize")))
> +     (synopsis "Function to alternate uppercase and lowercase
> characters")
SiMpLiFy tO "aLtErNaTe uPpEr aNd lOwErCaSe".
Toggle quote (6 lines)
> +     (description
> +"Provides a function, @code{string-pokemonize} that alternates
> uppercase
> +and lowercase characters for a given string. The code base is also
> +entirely stylized in alternating uppercase and lowercase characters
> +exemplifying Common Lisp's case insensitivity.")
ThE DeScRiPtIoN Of a pAcKaGe sHoUlD CoNsIsT Of cOmPlEtE SeNtEnCeS OnLy.
aLsO DoN'T FoRgEt tO PrOpErLy iNdEnT iT.


ChEeRs
J
[PATCH v2] gnu: Add cl-string-pokemonize.
(address . 56478@debbugs.gnu.org)
20220720051226.23611-1-jgart@dismail.de
* gnu/packages/lisp-xyz.scm (cl-string-pokemonize): New variable.

Hi, LiLiAnA

HeRe'S VeRsIoN 2.

ThAnK YoU fOR tHe ReViEw!!!

AlL bEsT,

jGaRt

---
gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2f6d22fe7d..0ada001bb9 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -22715,6 +22715,39 @@ (define-public cl-sketch
(define-public ecl-sketch
(sbcl-package->ecl-package sbcl-sketch))
+(define-public sbcl-string-pokemonize
+ (let ((commit "2dc01643defb497e4d1eb833def71dfc1e8d5da6")
+ (revision "0"))
+ (package
+ (name "sbcl-string-pokemonize")
+ (version (git-version "20210503" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/phoe/string-pokemonize")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zk5klc94pxv7mhx6qrp93rk4ypwd6wfijap7gf9l0wpphg90r9x"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:asd-files '("string-pokemonize.asd")
+ #:asd-systems '("string-pokemonize")))
+ (synopsis "aLtErNaTe uPpEr aNd lOwErCaSe")
+ (description
+"@code{string-pokemonize} provides a function that alternates uppercase
+and lowercase characters for a given string.")
+ (home-page "https://github.com/phoe/string-pokemonize")
+ (license license:expat))))
+
+(define-public cl-string-pokemonize
+ (sbcl-package->cl-source-package sbcl-string-pokemonize))
+
+(define-public ecl-string-pokemonize
+ (sbcl-package->ecl-package sbcl-string-pokemonize))
+
(define-public sbcl-binary-types
(let ((commit "9ec42042a50403961c08179a892ae3de725b1d7a"))
(package
--
2.37.1
L
L
Liliana Marie Prikler wrote on 20 Jul 2022 18:58
0ac8698c7d278736db246beff8cc92eb42cfa92f.camel@gmail.com
Am Mittwoch, dem 20.07.2022 um 00:12 -0500 schrieb jgart:
Toggle quote (46 lines)
> * gnu/packages/lisp-xyz.scm (cl-string-pokemonize): New variable.
>
> Hi, LiLiAnA
>
> HeRe'S VeRsIoN 2.
>
> ThAnK YoU fOR tHe ReViEw!!!
>
> AlL bEsT,
>
> jGaRt
>
> ---
>  gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
>  1 file changed, 33 insertions(+)
>
> diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
> index 2f6d22fe7d..0ada001bb9 100644
> --- a/gnu/packages/lisp-xyz.scm
> +++ b/gnu/packages/lisp-xyz.scm
> @@ -22715,6 +22715,39 @@ (define-public cl-sketch
>  (define-public ecl-sketch
>    (sbcl-package->ecl-package sbcl-sketch))
>  
> +(define-public sbcl-string-pokemonize
> +  (let ((commit "2dc01643defb497e4d1eb833def71dfc1e8d5da6")
> +        (revision "0"))
> +    (package
> +     (name "sbcl-string-pokemonize")
> +     (version (git-version "20210503" revision commit))
> +     (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/phoe/string-pokemonize")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32
> "1zk5klc94pxv7mhx6qrp93rk4ypwd6wfijap7gf9l0wpphg90r9x"))))
> +     (build-system asdf-build-system/sbcl)
> +     (arguments
> +      `(#:tests? #f ; There are no tests.
> +        #:asd-files '("string-pokemonize.asd")
> +        #:asd-systems '("string-pokemonize")))
> +     (synopsis "aLtErNaTe uPpEr aNd lOwErCaSe")
I didn't mean to actually alternate the case in the synopsis. Is this
intended or should I fix it?
Toggle quote (16 lines)
> +     (description
> +"@code{string-pokemonize} provides a function that alternates
> uppercase
> +and lowercase characters for a given string.")
> +     (home-page "https://github.com/phoe/string-pokemonize")
> +     (license license:expat))))
> +
> +(define-public cl-string-pokemonize
> +  (sbcl-package->cl-source-package sbcl-string-pokemonize))
> +
> +(define-public ecl-string-pokemonize
> +  (sbcl-package->ecl-package sbcl-string-pokemonize))
> +
>  (define-public sbcl-binary-types
>    (let ((commit "9ec42042a50403961c08179a892ae3de725b1d7a"))
>      (package
J
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 56478@debbugs.gnu.org)
20220721180842.GB28321@gac
Toggle quote (3 lines)
> I didn't mean to actually alternate the case in the synopsis. Is this
> intended or should I fix it?

I intended that but if you prefer for it to not be in pokemon case for
consistency with other Guix packages then feel free to change it and not use
the pokemon case in the synopsis.

all best,

jGaRt
L
L
Liliana Marie Prikler wrote on 16 Aug 2022 21:28
(name . jgart)(address . jgart@dismail.de)(address . 56478-done@debbugs.gnu.org)
5778aaf3058a2fa93e1d824e134b4b8a849c1c37.camel@gmail.com
Am Donnerstag, dem 21.07.2022 um 18:08 -0500 schrieb jgart:
Toggle quote (6 lines)
> > I didn't mean to actually alternate the case in the synopsis.  Is
> > this intended or should I fix it?
>
> I intended that but if you prefer for it to not be in pokemon case
> for consistency with other Guix packages then feel free to change it
> and not use the pokemon case in the synopsis.
PuShEd wItHoUt tHe pOkEmOn cAsE SyNoPsIs.

ChEeRs
Closed
J
Re: [PATCH] gnu: Add cl-string-pokemonize.
(address . guix-patches@gnu.org)
20220816145230.GB1343@gac
On Sun, 10 Jul 2022 03:41:07 -0500 jgart <jgart@dismail.de> wrote:

ThAnKs!
?