[PATCH] computed-file: Clarify comment about guile record field.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Maxim Cournoyer
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote on 4 Jul 2022 22:02
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220704200228.17157-1-jgart@dismail.de
* guix/gexp.scm (<computed-file>): Clarify that what goes in the guile
record field is any variant of a guile package record instance.
---
guix/gexp.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/guix/gexp.scm b/guix/gexp.scm
index ef92223048..eba65e92cf 100644
--- a/guix/gexp.scm
+++ b/guix/gexp.scm
@@ -581,7 +581,7 @@ (define-record-type <computed-file>
computed-file?
(name computed-file-name) ;string
(gexp computed-file-gexp) ;gexp
- (guile computed-file-guile) ;<package>
+ (guile computed-file-guile) ;<package guile-*>
(options computed-file-options)) ;list of arguments
(define* (computed-file name gexp
--
2.36.1
M
M
Maxim Cournoyer wrote on 7 Jul 2022 23:39
(name . jgart)(address . jgart@dismail.de)(address . 56387-done@debbugs.gnu.org)
87r12wvbzg.fsf@gmail.com
Hi jgart,

jgart <jgart@dismail.de> writes:

Toggle quote (18 lines)
> * guix/gexp.scm (<computed-file>): Clarify that what goes in the guile
> record field is any variant of a guile package record instance.
> ---
> guix/gexp.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/guix/gexp.scm b/guix/gexp.scm
> index ef92223048..eba65e92cf 100644
> --- a/guix/gexp.scm
> +++ b/guix/gexp.scm
> @@ -581,7 +581,7 @@ (define-record-type <computed-file>
> computed-file?
> (name computed-file-name) ;string
> (gexp computed-file-gexp) ;gexp
> - (guile computed-file-guile) ;<package>
> + (guile computed-file-guile) ;<package guile-*>
> (options computed-file-options)) ;list of arguments

If this was a statically typed language, the proper type of the argument
accepted would be <package>, not <package guile-*>, so I'm inclined to
leave it the way it is (also, we'd have to survey the whole code base to
adjust for our current convention, which is to use <package>).

Closing,

Thanks,

Maxim
Closed
?