[BUG] emacs-parsebib and emacs-ebib out of sync

DoneSubmitted by Christopher Rodriguez.
Details
2 participants
  • Nicolas Goaziou
  • Christopher Rodriguez
Owner
unassigned
Severity
normal
C
C
Christopher Rodriguez wrote on 2 Jul 00:40 +0200
(address . bug-guix@gnu.org)
87czeobg5b.fsf@gmail.com
Hello,

The emacs-ebib package has been updated recently to depend upon new
functionality in the emacs-parsebib package, however there has not been
a release to allow emacs-parsebib to be updated, causing things to break
on a purely-guix install of these packages.

There has not been an upstream release tag created for emacs-parsebib
since 2021-12-08 (which was version 3.1.0). However, 11 days ago, the
actual library's version info was bumped to 4.1.0. This indicates that
there was a breaking change (which there apparently was).

I have commented on the commit bumping the internal version number[1]
and I opened an issue to the same effect[2]. I am also in the process of
recompiling the packages in my declaration that rely on emac-parsebib to
rely on the commit mentioned above.

So long as that works, I'll send a patch updating the Guix version of
this package to this more-recent 'release' of emacs-ebib.



--

Christopher Rodriguez
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEJMQbvYVxvZ0eF/84XZ6FgaGVz3sFAmK/eoAACgkQXZ6FgaGV
z3uYZBAA0OawDM1tYTnpCOp4kqZl57Axi1FUcXjMJEdalSnt/k4WDzos2eXIT6+G
TTLrrf8OVWpZwUCAi4cGiiMBmo4NieSAP+PZ1V3BEo8lzyU8zsiZLSha3gVVGjWP
JmD75EVfM0s4E1hOA/GSO4xX2pUcFTtxXzdmXHgRVZjbmYXgzwE+qaKN2LqSy4yh
EaEmMrDASNgNkuXxFgnEQXuim8zjfa+cmaWld1/jcS3bNhqCIMpiDRmKQ7+cgKZn
OitOEsiHyRZfRj1vN23jAqsioqfI3prIvxsssyklcayOVSds3jqjlB6f36CUXDRb
fWh/dRj0zEKZhbOjWP89Z7oAoKiHNlGX8PdAfhOOjW3hQjHPyALYwqP/bcoN833H
01lv8s7K6UYAvrgOkOfFOfaFp6DNqSuuaWZCxr+x+jYeRzNL5mRYX49l4HNGrbF9
Svv85rESW6c54ItkiZPrHVU1/sLH+8bHQEY2CJMQoT/tYY3587GjIoCu6+yd8InL
PhzZWUcE+tw5mQkcoORJ1emDXTIygFsUJ9RTvJtZWOwvHiXN93Q29MRT/P029B4l
/HO4OXbbhQDzRl+FUEJKIQroZBpY4EZULvBjJm9Ausifp1MAdzJrm11gyDbPWT2E
1PDsL9iLCgzMQVUntQZtemtT2L4ZnhzNQ1K7DvfY9pS+keII3GA=
=7T5Z
-----END PGP SIGNATURE-----

N
N
Nicolas Goaziou wrote on 5 Jul 10:11 +0200
(name . Christopher Rodriguez)(address . yewscion@gmail.com)(address . 56346-done@debbugs.gnu.org)
87a69ornbr.fsf@nicolasgoaziou.fr
Hello,

Christopher Rodriguez <yewscion@gmail.com> writes:

Toggle quote (18 lines)
> The emacs-ebib package has been updated recently to depend upon new
> functionality in the emacs-parsebib package, however there has not been
> a release to allow emacs-parsebib to be updated, causing things to break
> on a purely-guix install of these packages.
>
> There has not been an upstream release tag created for emacs-parsebib
> since 2021-12-08 (which was version 3.1.0). However, 11 days ago, the
> actual library's version info was bumped to 4.1.0. This indicates that
> there was a breaking change (which there apparently was).
>
> I have commented on the commit bumping the internal version number[1]
> and I opened an issue to the same effect[2]. I am also in the process of
> recompiling the packages in my declaration that rely on emac-parsebib to
> rely on the commit mentioned above.
>
> So long as that works, I'll send a patch updating the Guix version of
> this package to this more-recent 'release' of emacs-ebib.

Thank you for the report.

I updated emacs-parsebib to 4.1. Closing.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send email to 56346@debbugs.gnu.org