[PATCH] import: github: Fix updater.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hartmut Goebel
  • Ludovic Courtès
Owner
unassigned
Submitted by
Hartmut Goebel
Severity
normal
H
H
Hartmut Goebel wrote on 30 Jun 2022 09:42
(address . guix-patches@gnu.org)
49ed104eb9117af150eea008a2029cfae703c79a.1656574934.git.h.goebel@crazy-compilers.com
* guix/import/github.scm(updated-url): For one one of the
cases add missing 'prefix' and set new version.
---
guix/import/github.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (27 lines)
diff --git a/guix/import/github.scm b/guix/import/github.scm
index 51118d1d39..e1a1af7133 100644
--- a/guix/import/github.scm
+++ b/guix/import/github.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -95,8 +96,8 @@ false if none is recognized"
((string-suffix? (string-append "/releases/download/" repo "-"
version "/" repo "-" version ext)
url)
- (string-append "/releases/download/" repo "-" version "/" repo "-"
- version ext))
+ (string-append prefix "/releases/download/" repo "-" new-version "/"
+ repo "-" new-version ext))
(#t #f))) ; Some URLs are not recognised.
#f))

base-commit: d7449142f56cb0b34860f4ac90fc322aee32d177
--
2.30.4
L
L
Ludovic Courtès wrote on 8 Jul 2022 23:44
(name . Hartmut Goebel)(address . h.goebel@crazy-compilers.com)(address . 56318@debbugs.gnu.org)
87k08ns2hx.fsf@gnu.org
Hi,

Hartmut Goebel <h.goebel@crazy-compilers.com> skribis:

Toggle quote (3 lines)
> * guix/import/github.scm(updated-url): For one one of the
> cases add missing 'prefix' and set new version.

Could you add an example of a case that is fixed by this change in the
commit log? (Like “‘guix refresh foo’ would fail to find the new
release of ‘foo’ before this change.”)

Also in the commit log: I’d suggest something like “Use correct URL
scheme” instead of “Fix updater”, for clarity.

Otherwise LGTM (assuming the URL scheme is correct), thanks!

Ludo’.
H
H
Hartmut Goebel wrote on 11 Jul 2022 15:36
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 56318-close@debbugs.gnu.org)
60446b39-4500-68c0-5882-e1db815df977@crazy-compilers.com
Thanks for the review. I amended the commit-message an pushed as
e8cd9e3d12c8c24b7c81e8787207f21e277da540

--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
?