[PATCH 0/7] Update octave.

  • Done
  • quality assurance status badge
Details
3 participants
  • Greg Hogan
  • Guillaume Le Vaillant
  • Maxime Devos
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 28 Jun 2022 17:19
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
cover.1656429407.git.code@greghogan.com
This patchset updates octave and failing dependent packages, with the
exception of the currently failing r-ifultools.

Greg Hogan (7):
gnu: octave: Update to 7.1.0.
gnu: Add r-metadat.
gnu: Add r-mathjaxr.
gnu: r-metafor: Update to 3.4-0.
gnu: gnuradio: Update to 3.10.3.0.
gnu: gr-satellites: Update to 4.6.0.
gnu: gnss-sdr: Update to 0.0.17.

gnu/packages/cran.scm | 46 +++++++++++++++++++++++++++++++++++++++---
gnu/packages/maths.scm | 4 ++--
gnu/packages/radio.scm | 21 ++++++++++++-------
3 files changed, 59 insertions(+), 12 deletions(-)

--
2.36.1
G
G
Greg Hogan wrote on 28 Jun 2022 17:22
[PATCH 1/7] gnu: octave: Update to 7.1.0.
(address . 56282@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
67f49b28c5583ce33875698a21a89834d20d2a6d.1656429407.git.code@greghogan.com
* gnu/packages/maths.scm (octave): Update to 7.1.0.
---
gnu/packages/maths.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 5e8fd7ae2d..8268b8954e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2657,7 +2657,7 @@ (define-public ceres-solver-benchmarks
(define-public octave-cli
(package
(name "octave-cli")
- (version "6.2.0")
+ (version "7.1.0")
(source
(origin
(method url-fetch)
@@ -2665,7 +2665,7 @@ (define-public octave-cli
version ".tar.xz"))
(sha256
(base32
- "06id09zspya24gshcwgp039cp35c06150mdlxysawgnbrhj16wkv"))))
+ "0wv26nsfi6cq80np6p4av4wfrvbaflca6szajf6c60mbpdg63m1z"))))
(build-system gnu-build-system)
(inputs
`(("alsa-lib" ,alsa-lib)
--
2.36.1
G
G
Greg Hogan wrote on 28 Jun 2022 17:22
[PATCH 2/7] gnu: Add r-metadat.
(address . 56282@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
af6995b98425a05e6b71c3fe1f15bad8fff083dd.1656429407.git.code@greghogan.com
* gnu/packages/cran.scm (r-metadat): New variable.
---
gnu/packages/cran.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 96dca393e6..bb2519bcda 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33438,3 +33438,24 @@ (define-public r-zoeppritz
coefficients or scattering amplitudes, for seismological P and S-waves at an
interface.")
(license license:gpl2+)))
+
+(define-public r-metadat
+ (package
+ (name "r-metadat")
+ (version "1.2-0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "metadat" version))
+ (sha256
+ (base32
+ "1f7mb3pw5d0akr09jjva06ay223izhpzbr21bapnw99x1kiybk7h"))))
+ (properties `((upstream-name . "metadat")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-mathjaxr))
+ (home-page "https://github.com/wviechtb/metadat")
+ (synopsis "Meta-Analysis Datasets")
+ (description
+ "This package provides a collection of meta-analysis datasets for teaching
+purposes, illustrating/testing meta-analytic methods, and validating published
+analyses.")
+ (license license:gpl2+)))
--
2.36.1
G
G
Greg Hogan wrote on 28 Jun 2022 17:22
[PATCH 3/7] gnu: Add r-mathjaxr.
(address . 56282@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
3d1c2a399c5e6d604c5c1f3891d2a833d79e1632.1656429407.git.code@greghogan.com
* gnu/packages/cran.scm (r-mathjaxr): New variable.
---
gnu/packages/cran.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bb2519bcda..b7387e444f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33459,3 +33459,22 @@ (define-public r-metadat
purposes, illustrating/testing meta-analytic methods, and validating published
analyses.")
(license license:gpl2+)))
+
+(define-public r-mathjaxr
+ (package
+ (name "r-mathjaxr")
+ (version "1.6-0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "mathjaxr" version))
+ (sha256
+ (base32
+ "0yf1sfkb2kjsplipl2v4k2gp20li9xzsynclg228sy0v243pdi7c"))))
+ (properties `((upstream-name . "mathjaxr")))
+ (build-system r-build-system)
+ (home-page "https://github.com/wviechtb/mathjaxr")
+ (synopsis "Using 'Mathjax' in Rd Files")
+ (description
+ "This package provides 'MathJax' and macros to enable its use within Rd files for
+rendering equations in the HTML help files.")
+ (license license:gpl3)))
--
2.36.1
G
G
Greg Hogan wrote on 28 Jun 2022 17:22
[PATCH 4/7] gnu: r-metafor: Update to 3.4-0.
(address . 56282@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
a87e1d089b864d0d5bc06db6b31eff87daa40b3d.1656429407.git.code@greghogan.com
* gnu/packages/cran.scm (r-metafor): Update to 3.4-0.
[propagated-inputs]: Add r-mathjaxr r-metadat r-pbapply.
---
gnu/packages/cran.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b7387e444f..3fa6101900 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -29149,18 +29149,18 @@ (define-public r-mlecens
(define-public r-metafor
(package
(name "r-metafor")
- (version "2.4-0")
+ (version "3.4-0")
(source
(origin
(method url-fetch)
(uri (cran-uri "metafor" version))
(sha256
(base32
- "1b599fxk7s0brkchmx698fr5k4g1kzkia2rnlvhg349ffs5nfjmn"))))
+ "0vn244xfgq7yxwl6ykvadb305z360ssc9vzva7kbcdfiqhhvrqcj"))))
(properties `((upstream-name . "metafor")))
(build-system r-build-system)
(propagated-inputs
- (list r-matrix r-nlme))
+ (list r-mathjaxr r-matrix r-metadat r-nlme r-pbapply))
(home-page "https://cran.r-project.org/web/packages/metafor/")
(synopsis "Meta-analysis package for R")
(description
--
2.36.1
G
G
Greg Hogan wrote on 28 Jun 2022 17:22
[PATCH 5/7] gnu: gnuradio: Update to 3.10.3.0.
(address . 56282@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
5409679a741dcda25b4ab705eec99964110c8d9d.1656429407.git.code@greghogan.com
* gnu/packages/radio.scm (gnuradio): Update to 3.10.3.0.
[native-inputs]: Add python-jsonschema and soapysdr.
[propagated-inputs]: Add spdlog.
[arguments]<#:configure-flags>: Add -DENABLE_GRC=ON.
---
gnu/packages/radio.scm | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index c25cdbc20c..e014707e44 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -542,7 +542,7 @@ (define-public redsea
(define-public gnuradio
(package
(name "gnuradio")
- (version "3.9.2.0")
+ (version "3.10.3.0")
(source
(origin
(method git-fetch)
@@ -551,7 +551,7 @@ (define-public gnuradio
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "01wyqazrpphmb0fl69j93k0w4vm4d1l4177m1fyg7qx8hzia0aaq"))))
+ (base32 "0xdhb2blzajxpi0f2ch23hh6bzdwz5q7syi3bmiqzdjlj2yjfzd4"))))
(build-system cmake-build-system)
(native-inputs
`(("doxygen" ,doxygen)
@@ -589,6 +589,7 @@ (define-public gnuradio
("python" ,python)
("python-click" ,python-click)
("python-click-plugins" ,python-click-plugins)
+ ("python-jsonschema" ,python-jsonschema)
("python-lxml" ,python-lxml)
("python-matplotlib" ,python-matplotlib)
("python-numpy" ,python-numpy)
@@ -600,8 +601,11 @@ (define-public gnuradio
("qtbase" ,qtbase-5)
("qwt" ,qwt)
("sdl" ,sdl)
+ ("soapysdr" ,soapysdr)
("volk" ,volk)
("zeromq" ,zeromq)))
+ (propagated-inputs
+ (list spdlog))
(arguments
`(#:modules ((guix build cmake-build-system)
((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
@@ -612,7 +616,8 @@ (define-public gnuradio
(guix build glib-or-gtk-build-system)
(guix build python-build-system))
#:configure-flags
- (list (string-append "-DMATHJAX2_ROOT="
+ (list "-DENABLE_GRC=ON"
+ (string-append "-DMATHJAX2_ROOT="
(assoc-ref %build-inputs "js-mathjax")
"/share/javascript/mathjax"))
#:phases
--
2.36.1
G
G
Greg Hogan wrote on 28 Jun 2022 17:22
[PATCH 6/7] gnu: gr-satellites: Update to 4.6.0.
(address . 56282@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
bc4e1a15f744f6b7c13d5c638f20cd5929d3e5e0.1656429407.git.code@greghogan.com
* gnu/packages/radio.scm (gr-satellites): Update to 4.6.0.
---
gnu/packages/radio.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index e014707e44..d7b7f60d97 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -847,7 +847,7 @@ (define-public gr-iqbal
(define-public gr-satellites
(package
(name "gr-satellites")
- (version "4.2.0")
+ (version "4.6.0")
(source
(origin
(method git-fetch)
@@ -856,7 +856,7 @@ (define-public gr-satellites
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "01p9cnwjxas3pkqr9m5fnrgm45cji0sfdqqa51hzy7izx9vgzaf8"))))
+ (base32 "0mcrxwb27n2v8v8vmcmmm1pbmy3c02a22mz2wnpdsfb2163qpchw"))))
(build-system cmake-build-system)
(native-inputs
(list pkg-config pybind11 python-six))
--
2.36.1
G
G
Greg Hogan wrote on 28 Jun 2022 17:22
[PATCH 7/7] gnu: gnss-sdr: Update to 0.0.17.
(address . 56282@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
afaa670f527e316bcd0e33ecd3ca1981fd8b8f19.1656429407.git.code@greghogan.com
* gnu/packages/radio.scm (gnss-sdr): Update to 0.0.17.
[inputs]: Add fmt.
---
gnu/packages/radio.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index d7b7f60d97..efee0e2f31 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -79,6 +79,7 @@ (define-module (gnu packages radio)
#:use-module (gnu packages popt)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages protobuf)
+ #:use-module (gnu packages pretty-print)
#:use-module (gnu packages python)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-web)
@@ -2506,7 +2507,7 @@ (define-public urh
(define-public gnss-sdr
(package
(name "gnss-sdr")
- (version "0.0.15")
+ (version "0.0.17")
(source
(origin
(method git-fetch)
@@ -2515,7 +2516,7 @@ (define-public gnss-sdr
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1m41rnlfr1nrzbg382jfsk5x0by2ym48v3innd2rbc6phd85q223"))))
+ (base32 "0kxn98vmrsd2a157cf3hsmivi6p4k4a3907j5w8hmcs0nn92786i"))))
(build-system cmake-build-system)
(native-inputs
`(("gfortran" ,gfortran)
@@ -2527,6 +2528,7 @@ (define-public gnss-sdr
(inputs
(list armadillo
boost
+ fmt
gflags
glog
gmp
--
2.36.1
G
G
Guillaume Le Vaillant wrote on 30 Jun 2022 11:25
Re: [bug#56282] [PATCH 0/7] Update octave.
(name . Greg Hogan)(address . code@greghogan.com)(address . 56282-done@debbugs.gnu.org)
875yki7b9b.fsf@kitej
Patches pushed as 4eddce8ce9337fd4d8f4fd97b7d41ac3cef4e3f0 and
following.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYr1sQA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9C7AD+N/F3jeUcqE8TwX+fKNS2qZloeEO1vbNIY5GR
MglkYUEA/iKjl1mHX4Ug6lZjvD2HmSodHrjIwUt9IUC5kQCehA//
=920J
-----END PGP SIGNATURE-----

Closed
M
M
Maxime Devos wrote on 30 Jun 2022 11:54
Re: [bug#56282] [PATCH 3/7] gnu: Add r-mathjaxr.
9f4a38e9a53c665d326131fececea3b767bf8c00.camel@telenet.be
Greg Hogan schreef op di 28-06-2022 om 15:22 [+0000]:
Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-mathjaxr): New variable.

This patch was (will be?) reverted as mentioned on #guix because ...

Toggle quote (7 lines)
> + (source (origin
> + (method url-fetch)
> + (uri (cran-uri "mathjaxr" version))
> + (sha256
> + (base32
> + "0yf1sfkb2kjsplipl2v4k2gp20li9xzsynclg228sy0v243pdi7c"))))

... it bundles mathjax, and it isn't built from source.

Toggle quote (9 lines)
> + (properties `((upstream-name . "mathjaxr")))
> + (build-system r-build-system)
> + (home-page "https://github.com/wviechtb/mathjaxr")
> + (synopsis "Using 'Mathjax' in Rd Files")
> + (description
> + "This package provides 'MathJax' and macros to enable its use within Rd files for
> +rendering equations in the HTML help files.")
> + (license license:gpl3)))

also, the license information is incorrect -- the mathjax is
Apache 2.0, and it's a rather important component, so I think it should
be listed.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYr1yyxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7tYjAQCv8goOM4BfCxAIjlt1SWtn+bFY
Zf19OLF2DLpS6f1/YgD/XqwRhLcEwa4WMJYEyOR6HFVyoGgvCfMTmURHWtUydg4=
=py4s
-----END PGP SIGNATURE-----


?