[PATCH 0/3] "Update" harfbuzz and pango

  • Done
  • quality assurance status badge
Details
One participant
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 25 Jun 2022 08:43
(address . guix-patches@gnu.org)
e523de748ba3a4e87d1d74ec6e62ea9b61ee7b32.camel@gmail.com
Hi Guix,

the following patch set updates harfbuzz-3 to the latest version
(including a variable rename), adds harfbuzz-4 and pango-1.90.

Cheers

Liliana Marie Prikler (3):
gnu: harfbuzz-3: Update to 3.4.0.
gnu: Add harfbuzz-4.
gnu: Add pango-1.90.

gnu/packages/chromium.scm | 2 +-
gnu/packages/gtk.scm | 42 ++++++++++++++++++++++++++++++++++++---
2 files changed, 40 insertions(+), 4 deletions(-)

--
2.36.1
L
L
Liliana Marie Prikler wrote on 24 Jun 2022 23:10
[PATCH 2/3] gnu: Add harfbuzz-4.
(address . 56211@debbugs.gnu.org)
dca6d07796164a1dbfe86be03e560f0e2be0040d.camel@gmail.com
* gnu/packages/gtk.scm (harfbuzz-4): New variable.
---
gnu/packages/gtk.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 9c4af3e512..7418acb31e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -292,6 +292,19 @@ (define-public harfbuzz-3
(base32
"0lprrl8iih8ji1n17xwm5llz05a1hv4g04b7a3y229dq9myahn3i"))))))
+(define-public harfbuzz-4
+ (package
+ (inherit harfbuzz)
+ (version "4.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/harfbuzz/harfbuzz"
+ "/releases/download/" version
+ "/harfbuzz-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0c5mzwgz43d37h75p4b6cgjg4v24jdd96i7gjpgxirn8qks2i5m4"))))))
+
(define-public libdatrie
(package
(name "libdatrie")
--
2.36.1
L
L
Liliana Marie Prikler wrote on 24 Jun 2022 23:08
[PATCH 1/3] gnu: harfbuzz-3: Update to 3.4.0.
(address . 56211@debbugs.gnu.org)
b1509ad6de5c11b16eb8264bb727135f4af0eec1.camel@gmail.com
* gnu/packages/gtk.scm (harfbuzz-3.0): Rename to...
(harfbuzz-3): ... this. Update to 3.4.0.
* gnu/packages/chromium.scm (ungoogled-chromium): Adjust accordingly.
---
gnu/packages/chromium.scm | 2 +-
gnu/packages/gtk.scm | 6 +++---
2 files changed, 4 insertions(+), 4 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index bdfebed99e..fd19831884 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -884,7 +884,7 @@ (define-public ungoogled-chromium
gdk-pixbuf
glib
gtk+
- harfbuzz-3.0
+ harfbuzz-3
icu4c
jsoncpp
lcms
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 73b313520f..9c4af3e512 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -279,10 +279,10 @@ (define-public harfbuzz
"See 'COPYING' in the distribution."))
(home-page "https://www.freedesktop.org/wiki/Software/HarfBuzz/")))
-(define-public harfbuzz-3.0
+(define-public harfbuzz-3
(package
(inherit harfbuzz)
- (version "3.0.0")
+ (version "3.4.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/harfbuzz/harfbuzz"
@@ -290,7 +290,7 @@ (define-public harfbuzz-3.0
"/harfbuzz-" version ".tar.xz"))
(sha256
(base32
- "1ngk8vn06rryx3s4v5pbl91bw1j1pd4431n77rw3j5a533hhwsq3"))))))
+ "0lprrl8iih8ji1n17xwm5llz05a1hv4g04b7a3y229dq9myahn3i"))))))
(define-public libdatrie
(package
--
2.36.1
L
L
Liliana Marie Prikler wrote on 24 Jun 2022 23:10
[PATCH 3/3] gnu: Add pango-1.90.
(address . 56211@debbugs.gnu.org)
599fe173c7937b263cb99997b94bc030abbc04ec.camel@gmail.com
* gnu/packages/gtk.scm (pango-1.90): New variable.
---
gnu/packages/gtk.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 7418acb31e..3fce6255e3 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -468,6 +468,29 @@ (define-public pango-1.42
(("test-layout\\$\\(EXEEXT\\)") ""))
#t)))))))
+(define-public pango-1.90
+ (package
+ (inherit pango)
+ (name "pango")
+ (version "1.90.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/pango/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (patches (search-patches "pango-skip-libthai-test.patch"))
+ (sha256
+ (base32
+ "1zqif72jxa819bwi4jv2vgac574qas3w37f7qvn8l31rm1jgjf7i"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ (substitute* "pango/pangocairo-font.c"
+ (("cairo_user_font_face_set_render_color_glyph_func")
+ "cairo_user_font_face_set_render_glyph_func"))))))
+ (inputs (modify-inputs (package-inputs pango)
+ (prepend harfbuzz-4)))))
+
(define-public pangox-compat
(package
(name "pangox-compat")
--
2.36.1
L
L
Liliana Marie Prikler wrote on 9 Jul 2022 10:48
Re: [PATCH 0/3] "Update" harfbuzz and pango
(address . 56211-done@debbugs.gnu.org)
4a74696cf4bdaaa4ee7a013a4c3101ea7ac74562.camel@gmail.com
Am Samstag, dem 25.06.2022 um 08:43 +0200 schrieb Liliana Marie
Prikler:
Toggle quote (16 lines)
> Hi Guix,
>
> the following patch set updates harfbuzz-3 to the latest version
> (including a variable rename), adds harfbuzz-4 and pango-1.90.
>
> Cheers
>
> Liliana Marie Prikler (3):
>   gnu: harfbuzz-3: Update to 3.4.0.
>   gnu: Add harfbuzz-4.
>   gnu: Add pango-1.90.
>
>  gnu/packages/chromium.scm |  2 +-
>  gnu/packages/gtk.scm      | 42 ++++++++++++++++++++++++++++++++++++-
> --
>  2 files changed, 40 insertions(+), 4 deletions(-)
Pushed as 15b4579a5a2dfa06dfc1b8d3892caed4c4f0a2ce.

Cheers
Closed
?