[PATCH] gnu: Add python-http-client.

  • Done
  • quality assurance status badge
Details
2 participants
  • Antero Mejr
  • Ludovic Courtès
Owner
unassigned
Submitted by
Antero Mejr
Severity
normal
A
A
Antero Mejr wrote on 24 Jun 2022 17:27
(address . guix-patches@gnu.org)
20220624152757.9469-1-antero@mailbox.org
* gnu/packages/python-web.scm (python-http-client): New variable.
---
gnu/packages/python-web.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6c121907e6..05fb5ab304 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -51,6 +51,7 @@
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7546,3 +7547,25 @@ (define-public python-zeep
@end itemize")
(license license:expat)))
+(define-public python-http-client
+ (package
+ (name "python-http-client")
+ (version "3.3.7")
+ (home-page "https://github.com/sendgrid/python-http-client")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0z0ziw3f4zw5fj4spiwhhs2x8qs3i5999ry2p6a5sc8b1lkkj2zi"))
+ (snippet #~(begin
+ (use-modules ((guix build utils)))
+ (delete-file "tests/profile.py")))))
+ (build-system python-build-system)
+ (synopsis "HTTP REST client for Python")
+ (description
+ "This package provides access to any RESTful or RESTful-like API.")
+ (license license:expat)))
--
2.36.1
L
L
Ludovic Courtès wrote on 26 Jun 2022 23:14
(name . Antero Mejr)(address . antero@mailbox.org)(address . 56196-done@debbugs.gnu.org)
87mtdzqg8d.fsf@gnu.org
Antero Mejr <antero@mailbox.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/python-web.scm (python-http-client): New variable.

Applied, thanks!
Closed
?