[PATCH] gnu: Add python-deepdish.

  • Done
  • quality assurance status badge
Details
3 participants
  • Antero Mejr
  • Ludovic Courtès
  • Maxime Devos
Owner
unassigned
Submitted by
Antero Mejr
Severity
normal
A
A
Antero Mejr wrote on 24 Jun 2022 14:50
(address . guix-patches@gnu.org)
20220624125033.5605-1-antero@mailbox.org
* gnu/packages/python-science.scm (python-deepdish): New variable.
---
gnu/packages/python-science.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 56f109e3d5..0f5403b36b 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1367,3 +1367,34 @@ (define-public python-gpy
Python, from the Sheffield machine learning group. GPy implements a range of
machine learning algorithms based on GPs.")
(license license:bsd-3)))
+
+(define-public python-deepdish
+ (package
+ (name "python-deepdish")
+ (version "0.3.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "deepdish" version))
+ (sha256
+ (base32
+ "1wqzwh3y0mjdyba5kfbvlamn561d3afz50zi712c7klkysz3mzva"))))
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'dont-vendor-six
+ (lambda _
+ (delete-file "deepdish/six.py")
+ (substitute* "deepdish/io/hdf5io.py"
+ (("from deepdish import six") "import six"))
+ (substitute* "deepdish/io/ls.py"
+ (("from deepdish import io, six, __version__")
+ "from deepdish import io, __version__
+import six
+")))))))
+ (build-system python-build-system)
+ (native-inputs (list python-pandas))
+ (propagated-inputs (list python-numpy python-scipy python-six
+ python-tables))
+ (home-page "https://github.com/uchicago-cs/deepdish")
+ (synopsis "Python library for HDF5 file saving and loading")
+ (description "HDF5 saving/loading and other data science tools.")
+ (license license:bsd-3)))
--
2.36.1
L
L
Ludovic Courtès wrote on 3 Jul 2022 13:11
(name . Antero Mejr)(address . antero@mailbox.org)(address . 56186-done@debbugs.gnu.org)
87r132zc1b.fsf@gnu.org
Hi Antero,

Antero Mejr <antero@mailbox.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/python-science.scm (python-deepdish): New variable.

Applied with the changes below (inspired by ‘README.rst’), as per

Thanks,
Ludo’.
Toggle diff (16 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 135c6a99ff..747c84d493 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1396,5 +1396,10 @@ (define-public python-deepdish
python-tables))
(home-page "https://github.com/uchicago-cs/deepdish")
(synopsis "Python library for HDF5 file saving and loading")
- (description "HDF5 saving/loading and other data science tools.")
+ (description
+ "Deepdish is a Python library to load and save HDF5 files.
+The primary feature of deepdish is its ability to save and load all kinds of
+data as HDF5. It can save any Python data structure, offering the same ease
+of use as pickling or @code{numpy.save}, but with the language
+interoperability offered by HDF5.")
(license license:bsd-3)))
Closed
M
M
Maxime Devos wrote on 30 Jul 2022 22:54
Re: [bug#56186] [PATCH] gnu: Add python-deepdish.
ffd8e30e-d3ab-84e8-2711-fb51a76a8a92@telenet.be
On 24-06-2022 14:50, Antero Mejr via Guix-patches via wrote:
Toggle quote (8 lines)
> + (add-after 'unpack 'dont-vendor-six
> + (lambda _
> + (delete-file "deepdish/six.py")
> + (substitute* "deepdish/io/hdf5io.py"
> + (("from deepdish import six") "import six"))
> + (substitute* "deepdish/io/ls.py"
> + (("from deepdish import io, six, __version__")
> + "from deepdish import io, __version__
If you move it to an origin snippet, then the result of "guix build
--source" becomes 'cleaner' in the sense that it actually corresponds to
what is built, could it be moved there?
Greetings,
Maxime.
Attachment: OpenPGP_signature
A
A
Antero Mejr wrote on 1 Aug 2022 21:34
[PATCH] gnu: Update python-deepdish package definition.
(address . 56186@debbugs.gnu.org)
20220801193439.2471378-1-antero@mailbox.org
* gnu/packages/python-science.scm (python-deepdish): Move code patch
to source snippet.
---
gnu/packages/python-science.scm | 22 +++++++++-------------
1 file changed, 9 insertions(+), 13 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 57c9325f49..905de853e0 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1377,19 +1377,15 @@ (define-public python-deepdish
(uri (pypi-uri "deepdish" version))
(sha256
(base32
- "1wqzwh3y0mjdyba5kfbvlamn561d3afz50zi712c7klkysz3mzva"))))
- (arguments
- (list #:phases #~(modify-phases %standard-phases
- (add-after 'unpack 'dont-vendor-six
- (lambda _
- (delete-file "deepdish/six.py")
- (substitute* "deepdish/io/hdf5io.py"
- (("from deepdish import six") "import six"))
- (substitute* "deepdish/io/ls.py"
- (("from deepdish import io, six, __version__")
- "from deepdish import io, __version__
-import six
-")))))))
+ "1wqzwh3y0mjdyba5kfbvlamn561d3afz50zi712c7klkysz3mzva"))
+ (modules '((guix build utils)))
+ (snippet #~(begin (delete-file "deepdish/six.py")
+ (substitute* "deepdish/io/hdf5io.py"
+ (("from deepdish import six") "import six"))
+ (substitute* "deepdish/io/ls.py"
+ (("from deepdish import io, six, __version__")
+ "from deepdish import io, __version__
+import six"))))))
(build-system python-build-system)
(native-inputs (list python-pandas))
(propagated-inputs (list python-numpy python-scipy python-six
--
2.37.1
?