[PATCH] gnu: freedesktop: Add basu 0.2.0.

  • Done
  • quality assurance status badge
Details
4 participants
  • Liliana Marie Prikler
  • Liliana Marie Prikler
  • muradm
  • Maxime Devos
Owner
unassigned
Submitted by
muradm
Severity
normal
M
M
muradm wrote on 22 Jun 2022 10:40
(address . guix-patches@gnu.org)(name . Liliana Marie Prikler)(address . liliana.prikler@ist.tugraz.at)
20220622084035.10863-1-mail@muradm.net
* gnu/packages/freedesktop.scm (basu): New variable.
---
gnu/packages/freedesktop.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 29bb7c1664..7269520a21 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2021, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
+;;; Copyright © 2022 muradm <mail@muradm.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -702,6 +703,30 @@ (define-public elogind
of a the system to know what users are logged in, and where.")
(license license:lgpl2.1+)))
+(define-public basu
+ (package
+ (name "basu")
+ (version "0.2.0")
+ (home-page "https://git.sr.ht/~emersion/basu")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0h23n7wg18xc7xwldca18wi00iajyliixwicqyvv38qx831d8q18"))))
+ (build-system meson-build-system)
+ (inputs
+ (list pkg-config python gperf libcap))
+ (synopsis "The sd-bus library, extracted from systemd.")
+ (description "Some projects rely on the sd-bus library for DBus support.
+However not all systems have systemd or elogind installed.
+This library provides just sd-bus (and the busctl utility).")
+ (license license:gpl2)))
+
(define-public localed
;; XXX: This package is extracted from systemd but we retain so little of it
;; that it would make more sense to maintain a fork of the bits we need.
--
2.36.1
L
L
Liliana Marie Prikler wrote on 22 Jun 2022 11:31
Re: [PATCH v2] gnu: wm: Switch sway from elogind to basu.
(address . control@debbugs.gnu.org)
7f0ede4db5c5039dbd0b456435eccd1cbd5bc5f1.camel@ist.tugraz.at
block 56094 by 56136
thanks

Am Mittwoch, dem 22.06.2022 um 12:27 +0300 schrieb muradm:
Toggle quote (1 lines)
> * gnu/packages/wm.scm (basu): Switch sway from elogind to basu.
Should be sway.
Toggle quote (1 lines)
> [inputs]: Replace elogind with basu for sd-bus library dependency.
This can be simplified to "Replace ‘elogind’ with ‘basu’."
Toggle quote (1 lines)
> [arguments]: Use G-expressions.
Actually, you don't, and even if, that ought to be a separate commit.
Toggle quote (1 lines)
> <#:configure-flags>: Request building against basu.
Is this necessary? Doesn't sway have autodetection for basu?


Cheers
M
M
Maxime Devos wrote on 22 Jun 2022 12:02
Re: [bug#56136] [PATCH] gnu: freedesktop: Add basu 0.2.0.
(name . Liliana Marie Prikler)(address . liliana.prikler@ist.tugraz.at)
83ba2eda3d3d73d7566e7f61dfd8ec776dc97885.camel@telenet.be
muradm schreef op wo 22-06-2022 om 11:40 [+0300]:
Toggle quote (2 lines)
> +    (license license:gpl2)))

Looking at
seems to be LGPL2.1+, not GPL-2-only?

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYrLoqhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7glPAP9ZOGQ8CEIjIShi3blOEt6Q95Xb
yfRFJJ3kR62B2fQ+2QD+NgVaGoMdhrvHRdMv5B+37LlH0RYDG6bs4ONxksKFnAw=
=ygVi
-----END PGP SIGNATURE-----


M
M
muradm wrote on 22 Jun 2022 12:32
[PATCH v2] gnu: freedesktop: Add basu 0.2.0.
(name . Liliana Marie Prikler)(address . liliana.prikler@ist.tugraz.at)
20220622103229.18330-1-mail@muradm.net
* gnu/packages/freedesktop.scm (basu): New variable.
---
gnu/packages/freedesktop.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 29bb7c1664..bcd083a316 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2021, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
+;;; Copyright © 2022 muradm <mail@muradm.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -702,6 +703,30 @@ (define-public elogind
of a the system to know what users are logged in, and where.")
(license license:lgpl2.1+)))
+(define-public basu
+ (package
+ (name "basu")
+ (version "0.2.0")
+ (home-page "https://git.sr.ht/~emersion/basu")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0h23n7wg18xc7xwldca18wi00iajyliixwicqyvv38qx831d8q18"))))
+ (build-system meson-build-system)
+ (inputs
+ (list pkg-config python gperf libcap))
+ (synopsis "The sd-bus library, extracted from systemd.")
+ (description "Some projects rely on the sd-bus library for DBus support.
+However not all systems have systemd or elogind installed.
+This library provides just sd-bus (and the busctl utility).")
+ (license license:lgpl2.1+)))
+
(define-public localed
;; XXX: This package is extracted from systemd but we retain so little of it
;; that it would make more sense to maintain a fork of the bits we need.
--
2.36.1
M
M
Maxime Devos wrote on 22 Jun 2022 13:54
Re: [bug#56136] [PATCH] gnu: freedesktop: Add basu 0.2.0.
(name . Liliana Marie Prikler)(address . liliana.prikler@ist.tugraz.at)
6de426083100110524ba722152e898d82ff083b7.camel@telenet.be
muradm schreef op wo 22-06-2022 om 11:40 [+0300]:
Toggle quote (3 lines)
> +    (inputs
> +     (list pkg-config python gperf libcap))

(Didn't notice this previously):

* gperf is a binary (usually) run during the build to generate stuff,
so it needs to be in native-inputs for cross-compilation to work.

* pkg-config is almost surely needs to be native-inputs (it's like a
(cross-) compiler). "./pre-inst-env guix lint basu" probably would
report this.

As a test, you can try
"./pre-inst-env guix build basu --target=aarch64-linux-gnu" or
such.

* whether python is native- or non-native depends on how it is used.

* libcap looks fine from here.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYrMC9BccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7gdQAP4ySPH+XEtkqPnjTnr/fLTUlN/7
4wnK06+hW+dT0FdvwgD/abQ8Zpg+OS6j3xg1Eluy7svVNLaM9G3dFwqDqggqGQU=
=q+fM
-----END PGP SIGNATURE-----


M
M
muradm wrote on 22 Jun 2022 14:00
[PATCH v3] gnu: freedesktop: Add basu 0.2.0.
(name . Liliana Marie Prikler)(address . liliana.prikler@ist.tugraz.at)
20220622120059.20287-1-mail@muradm.net
* gnu/packages/freedesktop.scm (basu): New variable.
---
gnu/packages/freedesktop.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 29bb7c1664..1b0f21c0e4 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2021, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
+;;; Copyright © 2022 muradm <mail@muradm.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -702,6 +703,32 @@ (define-public elogind
of a the system to know what users are logged in, and where.")
(license license:lgpl2.1+)))
+(define-public basu
+ (package
+ (name "basu")
+ (version "0.2.0")
+ (home-page "https://git.sr.ht/~emersion/basu")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0h23n7wg18xc7xwldca18wi00iajyliixwicqyvv38qx831d8q18"))))
+ (build-system meson-build-system)
+ (native-inputs
+ (list pkg-config python gperf))
+ (inputs
+ (list libcap))
+ (synopsis "The sd-bus library, extracted from systemd.")
+ (description "Some projects rely on the sd-bus library for DBus support.
+However not all systems have systemd or elogind installed.
+This library provides just sd-bus (and the busctl utility).")
+ (license license:lgpl2.1+)))
+
(define-public localed
;; XXX: This package is extracted from systemd but we retain so little of it
;; that it would make more sense to maintain a fork of the bits we need.
--
2.36.1
M
M
muradm wrote on 22 Jun 2022 14:07
Re: [bug#56136] [PATCH] gnu: freedesktop: Add basu 0.2.0.
(name . Maxime Devos)(address . maximedevos@telenet.be)
87wnd8c31j.fsf@muradm.net
Fixed in v3

Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (17 lines)
> [[PGP Signed Part:Undecided]]
> muradm schreef op wo 22-06-2022 om 11:40 [+0300]:
>> +    (inputs
>> +     (list pkg-config python gperf libcap))
>
> (Didn't notice this previously):
>
> * gperf is a binary (usually) run during the build to generate
> stuff,
> so it needs to be in native-inputs for cross-compilation to
> work.
>
> * pkg-config is almost surely needs to be native-inputs (it's
> like a
> (cross-) compiler). "./pre-inst-env guix lint basu"
> probably would
> report this.
Didn't see any warning or else.

Toggle quote (8 lines)
>
> As a test, you can try
> "./pre-inst-env guix build basu --target=aarch64-linux-gnu"
> or
> such.
>
> * whether python is native- or non-native depends on how it is
> used.
Python nedeed by gperf scripts, so native- also.

Toggle quote (7 lines)
>
> * libcap looks fine from here.
>
> Greetings,
> Maxime.
>
> [[End of PGP Signed Part]]
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEESPY5lma9A9l5HGLP6M7O0mLOBeIFAmKzBpgACgkQ6M7O0mLO
BeL0gRAAkjApug9A5ypoY6RvSDHhY65nr1UC7r/EhbMrwntg1O7Ka6L6QlmlpMHw
U1wGvxxEU1wTMdaPdVTeu9UIbUMk19A3go+e3Y92X+UhhM+A6PVD4qg0z05B66gC
ZuMb1F5/ZQNQb6vCWEq3j1Izew3Zl0p1eapVe0Hc3qtdh9USXPEKWisMPQ2eOc35
pycmKZiUXLzB+wvBA+MCwn+TTEur1ciQnHJWxnNXuXeuT/fksoJWuwbGnWIQMhXj
PU19p6g+AFEJnBpLDAeEuTBM/vEjnAfDKJfueUea0v1fzx+8HIiJd/Vnz1VSBxpf
ta6slcmMyBRZB+JAEwhzn5XTipx6n99/UIZBb5yjeBJ7ORSMdZnsQ85XRiw3sHwx
C3WbCNHS1qPshjHuFt21hR3sGW61Afd9RT3X1vgcp02REf5hZKnOM/f4HMaBezTb
CZaYre4gK5xgqJKbyUdi4I/ROqtJFNXRJls9WIBa1LnlTiCbMbbOpxg6UrSNws+q
nYoW+aQBQFtuSUHAWCYm5sb62jrRnPGlgf/LuvfDHU/aWmlo826xjrgBa5rnb2E4
Z5R7gdqTSNOEBqb6UjDwDYdJ/KvZnTdXfXEDM/ME4UJb84Jr8YdPDMtwq+zbjyp0
tElQRuTKfd2K5hkR++XQJ3RKivclGlv7knLwEIrLktkK5l7+s2g=
=8NOp
-----END PGP SIGNATURE-----

M
M
Maxime Devos wrote on 22 Jun 2022 15:08
(name . muradm)(address . mail@muradm.net)
1f1adb50a6b31ab7762a2779d48a53284579dc80.camel@telenet.be
muradm schreef op wo 22-06-2022 om 15:07 [+0300]:
Toggle quote (7 lines)
> >    * pkg-config is almost surely needs to be native-inputs (it's
> >    like a
> >      (cross-) compiler).  "./pre-inst-env guix lint basu"
> >      probably would
> >      report this.
> Didn't see any warning or else.

Can't reproduce:

$ guix lint -L . basu # (*)
./a.scm:24:5: basu@0.2.0: ‘pkg-config’ zou waarschijnlijk inheemse voer moeten zijn
./a.scm:25:14: basu@0.2.0: geen punt toegestaan aan het einde van de synopsis
fetching CVE database for 2022...
fetching CVE database for 2021...
fetching CVE database for 2020...
[...]

(i.e.: the translation for 'native' is in retrospect confusing, pkg-config should
probably be a native-input instead and a synopsis may not end with a period)

(*): I put the package definition into a separate file, hence the -L .. In your case,
that would be './pre-inst-env guix lint basu' instead

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYrMUaxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7gjTAQC9J3abxNPUVacs04SWw0R6DbYq
8NpLX5dy1+NLBfdwdgEA67yGZbdFXUw0J2ErlKJ4bswyqupOdGtjKC+j6SVGsQQ=
=Mp6H
-----END PGP SIGNATURE-----


M
M
muradm wrote on 22 Jun 2022 15:14
(name . Maxime Devos)(address . maximedevos@telenet.be)
87o7ykbztl.fsf@muradm.net
For v3 with lint I got only this:

gnu/packages/freedesktop.scm:726:14: basu@0.2.0: no period allowed
at the end of the synopsis

v4 has no lint warnings.

--
muradm

Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (35 lines)
> [[PGP Signed Part:Undecided]]
> muradm schreef op wo 22-06-2022 om 15:07 [+0300]:
>> >    * pkg-config is almost surely needs to be native-inputs
>> > (it's
>> >    like a
>> >      (cross-) compiler).  "./pre-inst-env guix lint basu"
>> >      probably would
>> >      report this.
>> Didn't see any warning or else.
>
> Can't reproduce:
>
> $ guix lint -L . basu # (*)
> ./a.scm:24:5: basu@0.2.0: ‘pkg-config’ zou waarschijnlijk
> inheemse voer moeten zijn
> ./a.scm:25:14: basu@0.2.0: geen punt toegestaan aan het einde
> van de synopsis
> fetching CVE database for 2022...
> fetching CVE database for 2021...
> fetching CVE database for 2020...
> [...]
>
> (i.e.: the translation for 'native' is in retrospect confusing,
> pkg-config should
> probably be a native-input instead and a synopsis may not end
> with a period)
>
> (*): I put the package definition into a separate file, hence
> the -L .. In your case,
> that would be './pre-inst-env guix lint basu' instead
>
> Greetings,
> Maxime.
>
> [[End of PGP Signed Part]]
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEESPY5lma9A9l5HGLP6M7O0mLOBeIFAmKzFuYACgkQ6M7O0mLO
BeLEKw/9GNMTH2VHWKspIy+tz42DQqZ6zLksGUNdsEW+JcNk0v/BrKYpRLuKBA06
yfCHrebJToi8wqMLoLAuCN4keBLph31yW8VyEBhWzgWL+aGBTEjVb5okCaGYPsAs
K/lKoJwL+EOuzALnNfuuI3iI/e/1zv7EwmPw3d2Dl7+pKO0r66cgim7yJiWILrbS
lflIdtv+2rffO0EGkRNtVBo+iNfS94xm3P+Utl59Sa15ekbJLdrKyKGJw4DniduL
opvZ/rlItFqN6e0pGjbkul1R76zo/ZRLcmjVNYx1sgFbp9P7YRUzhMp547GF/knF
bYppdROQ/GCSZElcWgX5odEnkBIRftVsBefT6G8nykKmUm4deN/E5rPtHrBQ309R
SqZ/K9ijq/ULIxFisPCGV4dUzs+gQHASG4wq31yAgr90/e+9dR/jgzZTvkoMnYiL
CWnpNhWzqD7j3zS26jNPsp33Vfw4sW8pBuhdoxBj0S0lwMTzgfA8iFb3tWTabm+3
DMdc+L1swGZizqXi1r/IXqxIzqs80dLjne4ymzcBjuJoOhO9H51SHx9ROIHS0HrL
9JPMpinkuJnRd51jmGjMoWpamHrIqGElBgbZ4BWJycVH3xumVi2LiYh2/Y87fGTZ
idn31gTRG+FWpjASBXwDPP8mD1aoTv8rrdeSQmFuKRnTh/E1+Oo=
=UHsu
-----END PGP SIGNATURE-----

M
M
muradm wrote on 22 Jun 2022 15:21
[PATCH v4] gnu: freedesktop: Add basu 0.2.0.
(name . Liliana Marie Prikler)(address . liliana.prikler@ist.tugraz.at)
20220622132141.24086-1-mail@muradm.net
* gnu/packages/freedesktop.scm (basu): New variable.
---
gnu/packages/freedesktop.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 29bb7c1664..4d06235771 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2021, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
+;;; Copyright © 2022 muradm <mail@muradm.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -702,6 +703,32 @@ (define-public elogind
of a the system to know what users are logged in, and where.")
(license license:lgpl2.1+)))
+(define-public basu
+ (package
+ (name "basu")
+ (version "0.2.0")
+ (home-page "https://git.sr.ht/~emersion/basu")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0h23n7wg18xc7xwldca18wi00iajyliixwicqyvv38qx831d8q18"))))
+ (build-system meson-build-system)
+ (native-inputs
+ (list pkg-config python gperf))
+ (inputs
+ (list libcap))
+ (synopsis "The sd-bus library, extracted from systemd")
+ (description "Some projects rely on the sd-bus library for DBus support.
+However not all systems have systemd or elogind installed.
+This library provides just sd-bus (and the busctl utility).")
+ (license license:lgpl2.1+)))
+
(define-public localed
;; XXX: This package is extracted from systemd but we retain so little of it
;; that it would make more sense to maintain a fork of the bits we need.
--
2.36.1
M
M
Maxime Devos wrote on 22 Jun 2022 18:32
Re: [bug#56136] [PATCH] gnu: freedesktop: Add basu 0.2.0.
(name . muradm)(address . mail@muradm.net)
bd50388de568089b14c6f76982e3e7fef326b800.camel@telenet.be
muradm schreef op wo 22-06-2022 om 16:14 [+0300]:
Toggle quote (5 lines)
> For v3 with lint I got only this:
>
> gnu/packages/freedesktop.scm:726:14: basu@0.2.0: no period allowed
> at the end of the synopsis

My comment was on the v2, not the v3. You wrote that:

Toggle quote (7 lines)
> > * pkg-config is almost surely needs to be native-inputs (it's
> > like a
> > (cross-) compiler). "./pre-inst-env guix lint basu"
> > probably would
> > report this.
> Didn't see any warning or else.

... which would seem to be somehow a bug in "guix lint" or an incorrect
use of "guix lint". Basically, I don't understand how you didn't get
any warnings.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYrNEBBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7jqnAP9cJ0ezhQgTQ9y5vFf+nlvgEqQU
I3sMScPxugl1pxGHGgEA2byKy0IrtaGJcWIjIiTEMjT/Iw+n5S90Tt7JU42LLgA=
=ABmk
-----END PGP SIGNATURE-----


L
L
Liliana Marie Prikler wrote on 22 Jun 2022 21:36
Re: [PATCH v4] gnu: freedesktop: Add basu 0.2.0.
81828717d0937860994521ee13250cd29c438356.camel@gmail.com
Am Mittwoch, dem 22.06.2022 um 16:21 +0300 schrieb muradm:
Toggle quote (1 lines)
> * gnu/packages/freedesktop.scm (basu): New variable.
Pushed along with the original issue. Reworded both slightly.

Cheers
Closed
?