[PATCH] gnu: Add python-pynrrd.

  • Done
  • quality assurance status badge
Details
2 participants
  • Antero Mejr
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Antero Mejr
Severity
normal
A
A
Antero Mejr wrote on 16 Jun 2022 20:37
(address . guix-patches@gnu.org)
20220616183716.9088-1-antero@mailbox.org
* gnu/packages/python-science.scm (python-pynrrd): New variable.
---
gnu/packages/python-science.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 0684826a6c..f7be371512 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1367,3 +1367,29 @@ (define-public python-gpy
Python, from the Sheffield machine learning group. GPy implements a range of
machine learning algorithms based on GPs.")
(license license:bsd-3)))
+
+(define-public python-pynrrd
+ (package
+ (name "python-pynrrd")
+ (version "0.4.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mhe/pynrrd")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12vlgx2k7jxbq9r9maiix4dbk8alixa0il420bqwhzln08s3chz1"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (delete 'ensure-no-mtimes-pre-1980))))
+ (propagated-inputs (list python-numpy))
+ (home-page "https://github.com/mhe/pynrrd")
+ (synopsis "Python module for reading and writing NRRD files")
+ (description
+ "@code{pynrrd} is a Python module for reading and writing NRRD
+files into and from numpy arrays.")
+ (license license:expat)))
--
2.36.1
S
S
Sharlatan Hellseher wrote on 6 Feb 22:22 +0100
(address . 56026-done@debbugs.gnu.org)
87jznhuw24.fsf@gmail.com
Hi,

Pushed as 36f5db706c22d7d643154fc841d0a4018195189b to master.

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXCozMACgkQdtcnv/Ys
0rUsqBAAhhIILuqu4nzyNkURYTLl3fiJ/lDmO/Qh6WjBz+Y4iqnnXk6bL5nLeDCR
RSEGKEQ/aE7SSli2yxWixpBpPmjE2bL8RGCvNHw2w0dbAww19h4+/ne3Hb/1Kn6Y
1DNWliQIwGgvpVCwyhVkXlkbrTHWtBejAUYcg8Wip8ZADXxrIrAgq5GrptuBEE8z
c5sKyuids/CJbA2m9sQY3RxRAS6tpPMn0WTRZG+ooqk++t+8GyIAxNWrigmwbE15
dnHhbmB40MVfBBGhMPDGMXsOzrTf1lhVS0yGaNF+lgET2DCaIMZ2drGNpitRAND2
nurt1xbHgqb9EthpauM16vcqBUX488o54DtTfW94MiHZ1zYyrCGABeCBuwVDuXWs
AyOEjJMKuHz8qB9UBbULiisMxbihK446yeFB/NxiOAtg1Vf+5sbQXRMkLu/QdUw1
3BEbaLGPFMM+L1AfE+DIXu2VcEOBYlwUg1r+AtkR+ft9WOcwVU9lyTr8Av8BBtuO
VzfUPVjhmiPFuUiT9y+iKRCRDkDgtYUZqN2t/jYdoD25OQMG5ncKtR6jAJijddW+
sfMMgCuKigtO6C7RDo1sqRvZwp6pIuNRj5d6UqQOlvWtVh6O0ViublfggHr7ZZIu
/+G6vf336GiPPqONiZjTYKQ5KWvWhEDrTbQ0QOSty11+Q+Y9atc=
=aCoj
-----END PGP SIGNATURE-----

Closed
?