[PATCH] gnu: packages: Fix and update pinfo.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • (
Owner
unassigned
Submitted by
(
Severity
normal
(
(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
20220615210132.5911-1-paren@disroot.org
* gnu/packages/texinfo.scm (pinfo): Update to commit
3d76eecde211e41ccc28b04e229f159b3f924399.

This modification indirectly fixes the build. (For some reason, they had
a completely broken commit tagged as the latest version...)
---
gnu/packages/texinfo.scm | 79 +++++++++++++++++++---------------------
1 file changed, 37 insertions(+), 42 deletions(-)

Toggle diff (107 lines)
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index fc1dac9df9..8cf90855a3 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,6 +28,7 @@
(define-module (gnu packages texinfo)
#:use-module (gnu packages autotools)
+ #:use-module (guix gexp)
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix utils)
@@ -254,49 +256,42 @@ (define-public texi2html-1.82
(base32 "1wdli2szkgm3l0vx8rf6lylw0b0m47dlz9iy004n928nqkzix76n"))))))
(define-public pinfo
- (package
- (name "pinfo")
- (version "0.6.13")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/baszoetekouw/pinfo")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "173d2p22irwiabvr4z6qvr6zpr6ysfkhmadjlyhyiwd7z62larvy"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-Werror
- (lambda _
- (substitute* "configure.ac"
- (("-Werror") ""))
- #t))
- (add-after 'unpack 'embed-reference-to-clear
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* '("src/manual.c"
- "src/mainfunction.c"
- "src/utils.c")
- (("\"clear\"")
- (string-append "\"" (which "clear") "\"")))
- #t)))))
- (inputs
- (list ncurses readline))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("gettext" ,gettext-minimal)
- ("libtool" ,libtool)
- ("texinfo" ,texinfo)))
- (home-page "https://github.com/baszoetekouw/pinfo")
- (synopsis "Lynx-style Info file and man page reader")
- (description
- "Pinfo is an Info file viewer. Pinfo is similar in use to the Lynx web
+ (let ((commit "3d76eecde211e41ccc28b04e229f159b3f924399")
+ (revision "0"))
+ (package
+ (name "pinfo")
+ ;; Latest tag is completely broken and does not build.
+ (version (git-version "0.6.13" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/baszoetekouw/pinfo")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qym323d9my5l4bhw9vry453hhlxhjjvy8mcdi38sk0bqqid0vd1"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'embed-reference-to-clear
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((ncurses (assoc-ref inputs "ncurses")))
+ (substitute* (list "src/manual.c"
+ "src/mainfunction.c"
+ "src/utils.c")
+ (("\"clear\"")
+ (string-append "\"" ncurses "/bin/clear\"")))))))))
+ (inputs
+ (list ncurses readline))
+ (native-inputs
+ (list autoconf automake gettext-minimal libtool texinfo))
+ (home-page "https://github.com/baszoetekouw/pinfo")
+ (synopsis "Lynx-style Info file and man page reader")
+ (description
+ "Pinfo is an Info file viewer. Pinfo is similar in use to the Lynx web
browser. You just move across info nodes, and select links, follow them, etc.
It supports many colors. Pinfo also supports viewing of manual pages -- they
are colorized like in the midnight commander's viewer, and additionally they
are hypertextualized.")
- (license gpl2+)))
+ (license gpl2+))))
--
2.36.1
(
(address . control@debbugs.gnu.org)
CKU42LZG7VBB.HESMQBGPA5YO@guix-aspire
close 56001
thanks

Thanks Ludo' for merging this! Looks like you forgot to close it tho :)

-- (
L
L
Ludovic Courtès wrote on 19 Jun 2022 23:15
(name . ()(address . paren@disroot.org)(address . 56001-done@debbugs.gnu.org)
87v8swbbhv.fsf@gnu.org
Hi,

"(" <paren@disroot.org> skribis:

Toggle quote (6 lines)
> * gnu/packages/texinfo.scm (pinfo): Update to commit
> 3d76eecde211e41ccc28b04e229f159b3f924399.
>
> This modification indirectly fixes the build. (For some reason, they had
> a completely broken commit tagged as the latest version...)

Pushed as 3e24393e8727984239a48136848fa089f483b7d6, thanks!

Ludo’.
Closed
?