[PATCH] gnu: Add python-jsonnet.

  • Done
  • quality assurance status badge
Details
2 participants
  • Antero Mejr
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Antero Mejr
Severity
normal
A
A
Antero Mejr wrote on 15 Jun 2022 22:22
(address . guix-patches@gnu.org)
20220615202213.12173-1-antero@mailbox.org
Tested both public functions, evaluate_file() and evaluate_snippet().

* gnu/packages/cpp.scm (python-jsonnet): New variable.
---
gnu/packages/cpp.scm | 11 +++++++++++
1 file changed, 11 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 78e4f3bd8e..4ab9f33ae7 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 Attila Lendvai <attila@lendvai.name>
;;; Copyright © 2022 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1724,6 +1725,16 @@ (define-public jsonnet
syntax with variables, conditions, functions and more.")
(license license:asl2.0)))
+(define-public python-jsonnet
+ (package
+ (inherit jsonnet)
+ (name "python-jsonnet")
+ (build-system python-build-system)
+ (arguments '())
+ (synopsis "Python bindings for Jsonnet, the data templating language")
+ (description "This package provides a Python library named @code{_jsonnet}
+which can evaluate Jsonnet files and expressions.")))
+
(define-public simdjson
(package
(name "simdjson")
--
2.36.1
R
R
Ricardo Wurmus wrote on 2 Sep 2023 09:17
(address . 56000-done@debbugs.gnu.org)
87y1hpcad4.fsf@elephly.net
Applied, thank you!

--
Ricardo
Closed
?