[PATCH 2/2] gnu: Add gdcm.

  • Done
  • quality assurance status badge
Details
2 participants
  • Antero Mejr
  • Ludovic Courtès
Owner
unassigned
Submitted by
Antero Mejr
Severity
normal
A
A
Antero Mejr wrote on 15 Jun 2022 03:27
(address . guix-patches@gnu.org)
20220615012714.1414-2-antero@mailbox.org
* gnu/packages/bioinformatics.scm (gdcm): New variable.
---
gnu/packages/bioinformatics.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 87df6c3515..d151172725 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2021 Hong Li <hli@mdc-berlin.de>
;;; Copyright © 2021, 2022 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -15745,3 +15746,33 @@ (define-public wfmash
module capable of computing base-level alignments for very large sequences.")
(home-page "https://github.com/ekg/wfmash")
(license license:expat)))
+
+(define-public gdcm
+ (package
+ (name "gdcm")
+ (version "2.8.9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/malaterre/gdcm")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0v8ggym2kz26rwyvsyy3mg7j5jbvd1pz5cwchh29iyclagf0l9ry"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ ;; dev claims release branches (even numbered minor rev) don't need tests
+ ;; so the check step is not generated
+ #:tests? #f)) ;see CMakeLists.txt
+ (home-page "http://gdcm.sourceforge.net/wiki/index.php/Main_Page")
+ (synopsis "Grassroots DICOM library")
+ (description
+ "Grassroots DICOM (GDCM) is an implementation of the DICOM
+standard designed to be open source so that researchers may access clinical
+data directly. GDCM includes a file format definition and a network
+communications protocol, both of which should be extended to provide a full set
+of tools for a researcher or small medical imaging vendor to interface with an
+existing medical database.")
+ (license license:bsd-2)))
--
2.36.1
L
L
Ludovic Courtès wrote on 8 Jan 2023 16:06
control message for bug #55988
(address . control@debbugs.gnu.org)
87eds5uku8.fsf@gnu.org
close 55988
quit
?