[PATCH core-updates] gnu: gobject-introspection: Update to 1.72.0.

  • Done
  • quality assurance status badge
Details
One participant
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 9 Jun 2022 20:49
(address . guix-patches@gnu.org)
9e3d90ade0281802e0afebd265755fa9f11a1780.camel@gmail.com
* gnu/packages/glib.scm (gobject-introspection): Update to 1.72.0.
* gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch: Adjust
to changes in upstream source.
---
gnu/packages/glib.scm | 4 +-
...ct-introspection-absolute-shlib-path.patch | 49 +++++++++----------
2 files changed, 25 insertions(+), 28 deletions(-)

Toggle diff (129 lines)
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 95839a856d..06639aae8f 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -427,14 +427,14 @@ (define target-name
(define gobject-introspection
(package
(name "gobject-introspection")
- (version "1.68.0")
+ (version "1.72.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/"
"gobject-introspection/" (version-major+minor version)
"/gobject-introspection-" version ".tar.xz"))
(sha256
- (base32 "09sawnv3xj9pzgy2qrrk87dl3jibfphnswb61i5bh0d2h4j28afj"))
+ (base32 "1g5aps3b20ck96ahy7fjl4nhp9nabkd9rlqd0s1qzn3111cqxzh2"))
(patches (search-patches
"gobject-introspection-cc.patch"
"gobject-introspection-girepository.patch"
diff --git a/gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch b/gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch
index c23b054a39..adc38e39bf 100644
--- a/gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch
+++ b/gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch
@@ -13,10 +13,10 @@ gobject-introspection.
tests/scanner/test_shlibs.py | 3 ++-
4 files changed, 65 insertions(+), 20 deletions(-)
-diff --git a/giscanner/scannermain.py b/giscanner/scannermain.py
-index 957ba0b7..78f9b11b 100644
---- a/giscanner/scannermain.py
-+++ b/giscanner/scannermain.py
+Index: gobject-introspection-1.72.0/giscanner/scannermain.py
+===================================================================
+--- gobject-introspection-1.72.0.orig/giscanner/scannermain.py
++++ gobject-introspection-1.72.0/giscanner/scannermain.py
@@ -95,6 +95,39 @@ def get_windows_option_group(parser):
return group
@@ -57,7 +57,7 @@ index 957ba0b7..78f9b11b 100644
def _get_option_parser():
parser = optparse.OptionParser('%prog [options] sources',
version='%prog ' + giscanner.__version__)
-@@ -214,6 +247,10 @@ match the namespace prefix.""")
+@@ -217,6 +250,10 @@ match the namespace prefix.""")
parser.add_option("", "--filelist",
action="store", dest="filelist", default=[],
help="file containing headers and sources to be scanned")
@@ -65,13 +65,13 @@ index 957ba0b7..78f9b11b 100644
+ action="store", dest="fallback_libpath",
+ default=_get_default_fallback_libpath(),
+ help="Path to prepend to unknown shared libraries")
-
- group = get_preprocessor_option_group(parser)
- parser.add_option_group(group)
-diff --git a/giscanner/shlibs.py b/giscanner/shlibs.py
-index 9f8ab5df..8aa37c99 100644
---- a/giscanner/shlibs.py
-+++ b/giscanner/shlibs.py
+ parser.add_option("", "--compiler",
+ action="store", dest="compiler", default=None,
+ help="the C compiler to use internally")
+Index: gobject-introspection-1.72.0/giscanner/shlibs.py
+===================================================================
+--- gobject-introspection-1.72.0.orig/giscanner/shlibs.py
++++ gobject-introspection-1.72.0/giscanner/shlibs.py
@@ -57,6 +57,14 @@ def _ldd_library_pattern(library_name):
$""" % re.escape(library_name), re.VERBOSE)
@@ -87,7 +87,7 @@ index 9f8ab5df..8aa37c99 100644
# This is a what we do for non-la files. We assume that we are on an
# ELF-like system where ldd exists and the soname extracted with ldd is
# a filename that can be opened with dlopen().
-@@ -108,7 +116,8 @@ def _resolve_non_libtool(options, binary, libraries):
+@@ -108,7 +116,8 @@ def _resolve_non_libtool(options, binary
output = output.decode("utf-8", "replace")
shlibs = resolve_from_ldd_output(libraries, output)
@@ -122,7 +122,7 @@ index 9f8ab5df..8aa37c99 100644
if len(patterns) == 0:
return []
-@@ -141,8 +149,12 @@ def resolve_from_ldd_output(libraries, output):
+@@ -141,8 +149,12 @@ def resolve_from_ldd_output(libraries, o
if line.endswith(':'):
continue
for word in line.split():
@@ -137,11 +137,11 @@ index 9f8ab5df..8aa37c99 100644
if m:
del patterns[library]
shlibs.append(m.group())
-diff --git a/giscanner/utils.py b/giscanner/utils.py
-index 45807f17..8a319cd1 100644
---- a/giscanner/utils.py
-+++ b/giscanner/utils.py
-@@ -113,16 +113,11 @@ def extract_libtool_shlib(la_file):
+Index: gobject-introspection-1.72.0/giscanner/utils.py
+===================================================================
+--- gobject-introspection-1.72.0.orig/giscanner/utils.py
++++ gobject-introspection-1.72.0/giscanner/utils.py
+@@ -114,16 +114,11 @@ def extract_libtool_shlib(la_file):
if dlname is None:
return None
@@ -163,10 +163,10 @@ index 45807f17..8a319cd1 100644
# Returns arguments for invoking libtool, if applicable, otherwise None
-diff --git a/tests/scanner/test_shlibs.py b/tests/scanner/test_shlibs.py
-index a8337c60..7f123103 100644
---- a/tests/scanner/test_shlibs.py
-+++ b/tests/scanner/test_shlibs.py
+Index: gobject-introspection-1.72.0/tests/scanner/test_shlibs.py
+===================================================================
+--- gobject-introspection-1.72.0.orig/tests/scanner/test_shlibs.py
++++ gobject-introspection-1.72.0/tests/scanner/test_shlibs.py
@@ -40,7 +40,8 @@ class TestLddParser(unittest.TestCase):
self.assertEqual(
@@ -177,6 +177,3 @@ index a8337c60..7f123103 100644
def test_unresolved_library(self):
output = ''
---
-2.33.0
-
--
2.36.1
L
L
Liliana Marie Prikler wrote on 12 Aug 2022 18:55
(address . 55899-done@debbugs.gnu.org)
1f80dae78dccda3ae840a41cd0154673fa08d939.camel@gmail.com
Am Donnerstag, dem 09.06.2022 um 20:49 +0200 schrieb Liliana Marie
Prikler:
Toggle quote (3 lines)
> * gnu/packages/glib.scm (gobject-introspection): Update to 1.72.0.
> * gnu/packages/patches/gobject-introspection-absolute-shlib-
> path.patch: Adjust to changes in upstream source.
Turns out this was already applied by someone else and I pushed two
noise commits.

Marking as done.
Closed
?