[PATCH] gnu: quodlibet: Add dependencies for plugins to work.

  • Done
  • quality assurance status badge
Details
3 participants
  • Wamm K. D
  • Liliana Marie Prikler
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Wamm K. D
Severity
normal
W
W
Wamm K. D wrote on 3 Jun 2022 07:02
(address . guix-patches@gnu.org)(name . Wamm K. D)(address . jaft.r@outlook.com)
BN8PR07MB7027B7A3811C66F33FB041D899A19@BN8PR07MB7027.namprd07.prod.outlook.com
* gnu/packages/music.scm (quodlibet): Add dependencies for plugins to work.
---
gnu/packages/music.scm | 13 ++++++++++++-
1 file changed, 12 insertions(+), 1 deletion(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 554d70f266..3751305b3c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2022 Sughosha <sughosha@disroot.org>
;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -179,6 +180,7 @@ (define-module (gnu packages music)
#:use-module (gnu packages vim) ;for 'xxd'
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
+ #:use-module (gnu packages wm)
#:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
@@ -6752,7 +6754,16 @@ (define-public quodlibet
python-pygobject
python-pytest
python-sgmllib3k
- python-toml))
+ python-toml
+ ;; optional but needed for multimedia keys not under Gnome
+ keybinder-3.0
+ ;; optional but needed for Undo/Redo
+ ;; support for multiline text fields
+ gtksourceview
+ ;; optional but needed for the auto library update plugin
+ python-pyinotify
+ ;; optional but needed for the Musicbrainz plugin
+ python-musicbrainzngs))
(home-page "https://github.com/quodlibet/quodlibet")
(synopsis "Music manager and player")
(description "Quod Libet provides several ways to browse and view your
--
2.36.1
L
L
Liliana Marie Prikler wrote on 3 Jun 2022 08:04
5d389f5061f937d238b758b23c61c3621a519b9c.camel@ist.tugraz.at
Am Freitag, dem 03.06.2022 um 00:02 -0500 schrieb Wamm K. D:
Toggle quote (2 lines)
> * gnu/packages/music.scm (quodlibet): Add dependencies for plugins to
> work.
Should be ... (quodlibet)[inputs]: Add ACTUAL_INPUTS...

Toggle quote (40 lines)
> ---
>  gnu/packages/music.scm | 13 ++++++++++++-
>  1 file changed, 12 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
> index 554d70f266..3751305b3c 100644
> --- a/gnu/packages/music.scm
> +++ b/gnu/packages/music.scm
> @@ -47,6 +47,7 @@
>  ;;; Copyright © 2022 Sughosha <sughosha@disroot.org>
>  ;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
>  ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
> +;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -179,6 +180,7 @@ (define-module (gnu packages music)
>    #:use-module (gnu packages vim)       ;for 'xxd'
>    #:use-module (gnu packages web)
>    #:use-module (gnu packages webkit)
> +  #:use-module (gnu packages wm)
>    #:use-module (gnu packages wxwidgets)
>    #:use-module (gnu packages xdisorg)
>    #:use-module (gnu packages xml)
> @@ -6752,7 +6754,16 @@ (define-public quodlibet
>             python-pygobject
>             python-pytest
>             python-sgmllib3k
> -           python-toml))
> +           python-toml
> +           ;; optional but needed for multimedia keys not under
> Gnome
> +           keybinder-3.0
> +           ;; optional but needed for Undo/Redo
> +           ;; support for multiline text fields
> +           gtksourceview
> +           ;; optional but needed for the auto library update plugin
> +           python-pyinotify
> +           ;; optional but needed for the Musicbrainz plugin
> +           python-musicbrainzngs))
YMMV, but it's better for inputs to be sorted alphabetically. Use line
comments to demarcate specific features, e.g. 
keybinder-3.0 ; keybindings outside of GNOME
gtksourceview ; undo, redo, multiline text fields
...
Don't forget the 79 character limit; when in doubt claim less features.
If possible, try to line up the comments.

Also, comments like "musicbrainz plugin needs python-musicbrainz" are
not as informative as you'd think and can probably be dropped :)

Cheers
W
W
Wamm K. D. wrote on 3 Jun 2022 15:13
(name . Liliana Marie Prikler)(address . liliana.prikler@ist.tugraz.at)(address . 55774@debbugs.gnu.org)
BN8PR07MB7027D5E62AE9D9E4CB9692C199A19@BN8PR07MB7027.namprd07.prod.outlook.com
On Fri. (Jun 03, 2022) at 08:04:10 AM +02, Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> wrote:
Toggle quote (5 lines)
> Am Freitag, dem 03.06.2022 um 00:02 -0500 schrieb Wamm K. D:
>> * gnu/packages/music.scm (quodlibet): Add dependencies for plugins to
>> work.
> Should be ... (quodlibet)[inputs]: Add ACTUAL_INPUTS...

?; I'll get that updated.

Toggle quote (8 lines)
> YMMV, but it's better for inputs to be sorted alphabetically. Use line
> comments to demarcate specific features, e.g. 
> keybinder-3.0 ; keybindings outside of GNOME
> gtksourceview ; undo, redo, multiline text fields
> ...
> Don't forget the 79 character limit; when in doubt claim less features.
> If possible, try to line up the comments.

Fair; I'll get those updated, as well. Yeah, I was trying to weigh what
to include vs. not but, due to the installation structure of Guix, you
wouldn't be able to use these features by just installing the
dependencies (leastwise, with just a naïve straightforward install, when
I tried) so I figured they were worth including, from that perspective.

Toggle quote (3 lines)
> Also, comments like "musicbrainz plugin needs python-musicbrainz" are
> not as informative as you'd think and can probably be dropped :)

Haha; fair. While I could see repeating "musicbrainz" as being
repetitive, I was figuring it's easy to lose track that the dependency
was present specifically due to a plugin, for future developers who
might work on the package, and was mostly trying to capture it was
plugin-related. Thanks for pointing it out and I'll that adjusted.

I'll try making the updates later tonight; thanks a ton.
L
L
Liliana Marie Prikler wrote on 3 Jun 2022 15:22
(name . Wamm K. D.)(address . jaft.r@outlook.com)(address . 55774@debbugs.gnu.org)
35c268b3ff822a5a6d5d6a81d46e3a9d15bfc1c9.camel@ist.tugraz.at
Am Freitag, dem 03.06.2022 um 08:13 -0500 schrieb Wamm K. D.:
Toggle quote (17 lines)
>
> > YMMV, but it's better for inputs to be sorted alphabetically.  Use
> > line
> > comments to demarcate specific features, e.g. 
> >   keybinder-3.0 ; keybindings outside of GNOME
> >   gtksourceview ; undo, redo, multiline text fields
> >   ...
> > Don't forget the 79 character limit; when in doubt claim less
> > features.
> > If possible, try to line up the comments.
>
> Fair; I'll get those updated, as well. Yeah, I was trying to weigh
> what to include vs. not but, due to the installation structure of
> Guix, you wouldn't be able to use these features by just installing
> the dependencies (leastwise, with just a naïve straightforward
> install, when I tried) so I figured they were worth including, from
> that perspective.
Oh, you understood me wrongly. Do add all the inputs, but per input
you might not have enough space to describe *all* that it enables, so
if you run out of horizontal space, stick to the most useful features.

Toggle quote (10 lines)
> > Also, comments like "musicbrainz plugin needs python-musicbrainz"
> > are not as informative as you'd think and can probably be dropped
> > :)
>
> Haha; fair. While I could see repeating "musicbrainz" as being
> repetitive, I was figuring it's easy to lose track that the
> dependency was present specifically due to a plugin, for future
> developers who might work on the package, and was mostly trying to
> capture it was plugin-related. Thanks for pointing it out and I'll
> that adjusted.
IIUC much of quodlibet is actually just plugins, so future packagers
looking into it shouldn't be too confused. Plus we aim for complete
feature sets in pretty much everything except -minimal package variants
:)

Cheers
W
W
Wamm K. D wrote on 4 Jun 2022 00:59
[PATCH v2] gnu: quodlibet: Add dependencies for plugins to work.
(address . 55774@debbugs.gnu.org)
BY5PR07MB702975B990629DF0E69C6F4099A19@BY5PR07MB7029.namprd07.prod.outlook.com
* gnu/packages/music.scm (quodlibet)[inputs]: Add gtksourceview, keybinder-3.0,
python-musicbrainzngs, and python-pyinotify for plugins to work.
---
gnu/packages/music.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 554d70f266..afd7ff40cf 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2022 Sughosha <sughosha@disroot.org>
;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -179,6 +180,7 @@ (define-module (gnu packages music)
#:use-module (gnu packages vim) ;for 'xxd'
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
+ #:use-module (gnu packages wm)
#:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
@@ -6738,7 +6740,9 @@ (define-public quodlibet
gst-plugins-ugly
gstreamer
gtk+
+ gtksourceview ; undo, redo, multiline text fields
hicolor-icon-theme
+ keybinder-3.0 ; keybindings outside of GNOME
librsvg
libsoup-minimal-2
python
@@ -6747,9 +6751,11 @@ (define-public quodlibet
python-feedparser
python-gst
python-iniconfig
+ python-musicbrainzngs
python-mutagen
python-pycairo
python-pygobject
+ python-pyinotify
python-pytest
python-sgmllib3k
python-toml))
--
2.36.1
L
L
Liliana Marie Prikler wrote on 4 Jun 2022 09:50
4d7282c611eb7334897fb2ee92a662fe729cd9f0.camel@gmail.com
Am Freitag, dem 03.06.2022 um 17:59 -0500 schrieb Wamm K. D:
Toggle quote (3 lines)
> * gnu/packages/music.scm (quodlibet)[inputs]: Add gtksourceview,
> keybinder-3.0, python-musicbrainzngs, and python-pyinotify for
> plugins to work.
Pushed with a slight change in the commit message.  

Thanks
L
L
Liliana Marie Prikler wrote on 4 Jun 2022 10:35
389499c399cab0c50189ba9007a467aadf2d98b4.camel@gmail.com
Am Samstag, dem 04.06.2022 um 09:50 +0200 schrieb Liliana Marie
Prikler:
Toggle quote (7 lines)
> Am Freitag, dem 03.06.2022 um 17:59 -0500 schrieb Wamm K. D:
> > * gnu/packages/music.scm (quodlibet)[inputs]: Add gtksourceview,
> > keybinder-3.0, python-musicbrainzngs, and python-pyinotify for
> > plugins to work.
> Pushed with a slight change in the commit message.  
>
> Thanks
Forgot to mark as done.
Closed
?