[PATCH] gnu: Add edlin.

  • Done
  • quality assurance status badge
Details
2 participants
  • Foo Chuan Wei
  • Ludovic Courtès
Owner
unassigned
Submitted by
Foo Chuan Wei
Severity
normal
F
F
Foo Chuan Wei wrote on 2 Jun 2022 15:59
(address . guix-patches@gnu.org)
PU1PR01MB215506D1F52E1C3899FC8B408DDE9@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/text-editors.scm (edlin): New variable.
---
gnu/packages/text-editors.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index cb86a907ff..1c936be6a8 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2021 Calum Irwin <calumirwin1@gmail.com>
;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
+;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1132,6 +1133,38 @@ systems that displays its buffer(s) as a hex dump. The user interface is kept
similar to vi/ex.")
(license license:bsd-3)))
+(define-public edlin
+ (package
+ (name "edlin")
+ (version "2.20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/freedos-edlin/freedos-edlin/"
+ version "/edlin-" version ".tar.bz2"))
+ (sha256
+ (base32 "0cdv42ffminncwj5ph9lw0j7zpbv8l35acppy90wj7x1qm4qk6x8"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'make-read-only
+ (lambda _
+ ;; Remove executable bits.
+ (chmod "COPYING" #o444)
+ (chmod "edlin.htm" #o444)))
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((doc-dir (string-append (assoc-ref outputs "out")
+ "/share/doc/edlin-" ,version)))
+ (mkdir-p doc-dir)
+ (install-file "edlin.htm" doc-dir)))))))
+ (home-page "https://sourceforge.net/projects/freedos-edlin/")
+ (synopsis "The line editor of the FreeDOS operating system")
+ (description "The @code{edlin} program is a small line editor, written for
+FreeDOS as a functional clone of the old MS-DOS program edlin.")
+ (license license:gpl2+)))
+
(define-public tree-sitter
(package
(name "tree-sitter")

base-commit: 08565c07ddf45292175a85e60bdd604705ef5d15
--
2.25.1
L
L
Ludovic Courtès wrote on 7 Jun 2022 18:24
(address . 55766-done@debbugs.gnu.org)
874k0wa1by.fsf@gnu.org
Hi,

Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/text-editors.scm (edlin): New variable.

Applied, thanks!

Ludo’.
Closed
?