[PATCH] gnu: Add emacs-popon.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Nicolas Goaziou
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220529184028.24629-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-popon): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index eea15cac98..43c37da756 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31353,6 +31353,32 @@ (define-public emacs-osm
parallel fetching of tiles with cURL, and more.")
(license license:gpl3+)))
+(define-public emacs-popon
+ (let ((commit "26224d2345ca4e39e376d1d39c96c81bb533de8b")
+ (revision "0"))
+ (package
+ (name "emacs-popon")
+ (version (git-version "0.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://codeberg.org/akib/emacs-popon")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1p6nsgnfsmbh3lpa15pzbxz2350krf1kpm2dykkvsw6iv19q0a3h"))))
+ (build-system emacs-build-system)
+ (home-page "https://codeberg.org/akib/emacs-popon/")
+ (synopsis "Pop floating text on a window")
+ (description
+"@code{emacs-popon} allows you to pop text on a window, what we call
+a popon. Popons are window-local and sticky, they don't move while
+scrolling, and they even don't go away when switching buffer, but you
+can bind a popon to a specific buffer to only show on that buffer.")
+ (license license:gpl3+))))
+
(define-public emacs-bitbake-modes
(package
(name "emacs-bitbake-modes")
--
2.35.3
N
N
Nicolas Goaziou wrote on 7 Jun 2022 21:03
(name . jgart via Guix-patches via)(address . guix-patches@gnu.org)
87wndsqosk.fsf@nicolasgoaziou.fr
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-popon): New variable.

I bumped version to 0.4, dropped git-version since commit used matches
version bump and applied your patch. Thank you.

Regards,
--
Nicolas Goaziou
?