[PATCH] services: ddclient: No need to import (ice-9 rdelim) from the host.

  • Done
  • quality assurance status badge
Details
2 participants
  • Attila Lendvai
  • Ludovic Courtès
Owner
unassigned
Submitted by
Attila Lendvai
Severity
normal
A
A
Attila Lendvai wrote on 26 May 2022 15:07
(address . guix-patches@gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
20220526130745.28781-1-attila@lendvai.name
* gnu/services/dns.scm (ddclient-activation): Remove (ice-9 rdelim) from the
with-imported-modules form.
---

this gets rid of a warning (and a potential error with a substantially
different guile version on the two sides).

gnu/services/dns.scm | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/services/dns.scm b/gnu/services/dns.scm
index a220b33f15..50753b7ab6 100644
--- a/gnu/services/dns.scm
+++ b/gnu/services/dns.scm
@@ -978,8 +978,7 @@ (define (ddclient-account config)
(define (ddclient-activation config)
"Return the activation GEXP for CONFIG."
- (with-imported-modules '((guix build utils)
- (ice-9 rdelim))
+ (with-imported-modules '((guix build utils))
#~(begin
(use-modules (guix build utils)
(ice-9 rdelim))
--
2.35.1
L
L
Ludovic Courtès wrote on 3 Jun 2022 23:51
(name . Attila Lendvai)(address . attila@lendvai.name)(address . 55658-done@debbugs.gnu.org)
87czfph0uo.fsf@gnu.org
Hi,

Attila Lendvai <attila@lendvai.name> skribis:

Toggle quote (3 lines)
> * gnu/services/dns.scm (ddclient-activation): Remove (ice-9 rdelim) from the
> with-imported-modules form.

Good catch. Applied, thanks!

Ludo’.
Closed
?