[PATCH] gnu: Add archivebox.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Pradana Adrinusa AUMARS
Owner
unassigned
Submitted by
Pradana Adrinusa AUMARS
Severity
normal
P
P
Pradana Adrinusa AUMARS wrote on 22 May 2022 15:30
(address . guix-patches@gnu.org)
c87ce9f8b812cc8a871f6de7397970f8af26d5bd.camel@courrier.dev
From 597e0ee3e2073cc3bbf2a8a997fcbeef750b9f98 Mon Sep 17 00:00:00 2001
From: Pradana AUMARS <paumars@courrier.dev>
Date: Sun, 22 May 2022 15:27:02 +0200
Subject: [PATCH] gnu: Add archivebox.

* gnu/packages/web.scm (archivebox): New variable.
---
gnu/packages/web.scm | 44 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (90 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 600ef0c895..72b78b4d43 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -56,6 +56,7 @@
;;; Copyright © 2021 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2022 cage <cage-dev@twistfold.it>
+;;; Copyright © 2022 Pradana Aumars <paumars@courrier.dev>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -112,6 +113,7 @@ (define-module (gnu packages web)
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages django)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages emacs)
@@ -154,6 +156,7 @@ (define-module (gnu packages web)
#:use-module (gnu packages markup)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages networking)
+ #:use-module (gnu packages node)
#:use-module (gnu packages nss)
#:use-module (gnu packages openldap)
#:use-module (gnu packages openstack)
@@ -162,6 +165,8 @@ (define-module (gnu packages web)
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
@@ -177,7 +182,9 @@ (define-module (gnu packages web)
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages version-control)
+ #:use-module (gnu packages video)
#:use-module (gnu packages vim)
+ #:use-module (gnu packages wget)
#:use-module (gnu packages xml)
#:use-module ((srfi srfi-1) #:select (delete-duplicates)))
@@ -8218,3 +8225,40 @@ (define-public quark
;; "cpe:2.3:a:comelz:quark" package. The proper fix is for (guix cve)
;; to account for "vendor names".
(properties '((lint-hidden-cve . ("CVE-2019-15520")))))))
+
+(define-public archivebox
+ (package
+ (name "archivebox")
+ (version "0.6.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri name version))
+ (sha256
+ (base32
+ "1mnq82ynq01l7vx957bbx4bvgwdh59qsnx6pdydaqszbakp74yyc"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list curl
+ node))
+ (inputs
+ (list python
+ youtube-dl
+ wget
+ git
+ python-w3lib
+ python-ipython
+ python-croniter
+ python-crontab
+ python-dateparser
+ python-django-extensions
+ python-django-3.1.14
+ python-mypy-extensions))
+ (native-inputs
+ (list python-wheel))
+ (synopsis "Open source self-hosted web archiving")
+ (description "ArchiveBox is a powerful, self-hosted internet archiving
+solution to collect, save, and view sites you want to preserve offline.
+You can feed it URLs one at a time, or schedule regular imports. It saves
+snapshots of the URLs you feed it in several formats.")
+ (home-page "https://archivebox.io/")
+ (license license:expat)))
--
2.36.0
P
P
Pradana Adrinusa AUMARS wrote on 22 May 2022 15:33
(address . 55575@debbugs.gnu.org)
87d707f0957914326c8c6fd64be801afaa32cd55.camel@courrier.dev
This patch requires python-django-3.1.14, which is added in patch
bug#54187, so the latter would need to be admitted in first.
L
L
Ludovic Courtès wrote on 23 May 2022 16:23
(name . Pradana Adrinusa AUMARS)(address . paumars@courrier.dev)(address . 55575-done@debbugs.gnu.org)
8735h05nv9.fsf@gnu.org
Hi,

Pradana Adrinusa AUMARS <paumars@courrier.dev> skribis:

Toggle quote (7 lines)
>>From 597e0ee3e2073cc3bbf2a8a997fcbeef750b9f98 Mon Sep 17 00:00:00 2001
> From: Pradana AUMARS <paumars@courrier.dev>
> Date: Sun, 22 May 2022 15:27:02 +0200
> Subject: [PATCH] gnu: Add archivebox.
>
> * gnu/packages/web.scm (archivebox): New variable.

[...]

Toggle quote (2 lines)
> + (synopsis "Open source self-hosted web archiving")

I removed “Open source” (everything is free software in Guix, no need to
be explicit) and applied it.

Thanks,
Ludo’.
Closed
?