[PATCH] gnu: Add cl-listopia.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 19 May 2022 13:15
(address . guix-patches@gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20220519111544.27207-1-arunisaac@systemreboot.net
* gnu/packages/lisp-xyz.scm (sbcl-listopia, cl-listopia, ecl-listopia): New
variables.
---
gnu/packages/lisp-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index fa234af3c3..7fa0db59f9 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -21322,3 +21322,31 @@ (define-public sbcl-lmdb
(define-public cl-lmdb
(sbcl-package->cl-source-package sbcl-lmdb))
+
+(define-public sbcl-listopia
+ (package
+ (name "sbcl-listopia")
+ (version "0.12.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Dimercel/listopia")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07xa2s2s60h9f40az3zdacybl5pk1x8bhvga9phsra0czbv44lx2"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-prove))
+ (home-page "https://github.com/Dimercel/listopia")
+ (synopsis "List manipulation library for Common Lisp")
+ (description "This package is a list manipulation library for Common Lisp
+inspired by Haskell package @code{Data.List}.")
+ (license license:llgpl)))
+
+(define-public cl-listopia
+ (sbcl-package->cl-source-package sbcl-listopia))
+
+(define-public ecl-listopia
+ (sbcl-package->ecl-package sbcl-listopia))
--
2.36.0
G
G
Guillaume Le Vaillant wrote on 20 May 2022 11:08
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 55520@debbugs.gnu.org)
87ee0omuy9.fsf@kitej
Arun Isaac <arunisaac@systemreboot.net> skribis:

Toggle quote (3 lines)
> * gnu/packages/lisp-xyz.scm (sbcl-listopia, cl-listopia, ecl-listopia): New
> variables.

LGTM.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYodazg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j97NAEAgO8rkxkNYlXPXHxtHZJkddt9fPVpLRIy8H4l
C2amfN0A/iINCwgAEmlPALwDTNcrL09u6vndXjEhCszDeot/3bc7
=Js8V
-----END PGP SIGNATURE-----

A
A
Arun Isaac wrote on 20 May 2022 14:50
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 55520-done@debbugs.gnu.org)
875ym0tlkc.fsf@systemreboot.net
Pushed, thanks!
Closed
?