[PATCH] gnu: python-geopandas: Fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Felix Gruber
  • Ludovic Courtès
Owner
unassigned
Submitted by
Felix Gruber
Severity
normal
F
F
Felix Gruber wrote on 18 May 2022 21:21
(address . guix-patches@gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20220518192111.20342-1-felgru@posteo.net
* gnu/packages/geo.scm (python-geopandas)[arguments]: Disable broken
tests. Re-enable test_fillna_no_op_returns_copy which does not fail
anymore.
---
gnu/packages/geo.scm | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index c2569c27d4..0c9240eea7 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -715,9 +715,14 @@ pyproj, Rtree, and Shapely.")
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "pytest"
- ; Disable test that fails with
- ; NotImplementedError in pandas.
- "-k" "not test_fillna_no_op_returns_copy"
+ ; Disable tests that fail due to incompatibilities
+ ; with our pandas version.
+ "-k"
+ (string-append
+ "not test_getitem_invalid"
+ " and not test_value_counts"
+ " and not test_setitem_invalid"
+ " and not test_insert_invalid")
; Disable tests that require internet access.
"-m" "not web")))))))
(propagated-inputs
--
2.30.2
L
L
Ludovic Courtès wrote on 21 May 2022 00:14
(name . Felix Gruber)(address . felgru@posteo.net)(address . 55508-done@debbugs.gnu.org)
87mtfbvolu.fsf@gnu.org
Hi,

Felix Gruber <felgru@posteo.net> skribis:

Toggle quote (4 lines)
> * gnu/packages/geo.scm (python-geopandas)[arguments]: Disable broken
> tests. Re-enable test_fillna_no_op_returns_copy which does not fail
> anymore.

Applied, thanks!

Ludo’.
Closed
?