[PATCH] daemon: runChild() is forbidden to talk during environment set up

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • yarl-baudig
Owner
unassigned
Submitted by
yarl-baudig
Severity
normal
Y
Y
yarl-baudig wrote on 17 May 2022 23:08
(address . guix-patches@gnu.org)
ea-mime-62840ee6-4587-244ac94a@www-8.mailo.com
DerivationGoal::startBuilder() is waiting for an empty line as a check that
the environment set up is fine.

---
nix/libstore/build.cc | 1 -
1 file changed, 1 deletion(-)

Toggle diff (14 lines)
diff --git a/nix/libstore/build.cc b/nix/libstore/build.cc
index f6431bb726..9305208009 100644
--- a/nix/libstore/build.cc
+++ b/nix/libstore/build.cc
@@ -2057,7 +2057,6 @@ void DerivationGoal::runChild()
Path source = i->second;
Path target = chrootRootDir + i->first;
if (source == "/proc") continue; // backwards compatibility
- debug(format("bind mounting `%1%' to `%2%'") % source % target);
if (stat(source.c_str(), &st) == -1)
throw SysError(format("getting attributes of path `%1%'") % source);
if (S_ISDIR(st.st_mode))
--
2.36.0
L
L
Ludovic Courtès wrote on 19 May 2022 16:48
(address . yarl-baudig@mailoo.org)
87zgjdy3x2.fsf@gnu.org
Hi,

yarl-baudig@mailoo.org skribis:

Toggle quote (5 lines)
> DerivationGoal::startBuilder() is waiting for an empty line as a check that
> the environment set up is fine.
>
> Fixes <https://issues.guix.gnu.org/55324>

Oh, good catch!

I tweaked the commit log and applied it.

Thank you!

Ludo’.
Closed
?