[PATCH] gnu: wla-dx: Update to 10.1.

  • Done
  • quality assurance status badge
Details
3 participants
  • Felix Gruber
  • Ludovic Courtès
  • Maxime Devos
Owner
unassigned
Submitted by
Felix Gruber
Severity
normal
F
F
Felix Gruber wrote on 17 May 2022 19:24
(address . guix-patches@gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20220517172445.14740-1-felgru@posteo.net
* gnu/packages/assembly.scm (wla-dx): Update to 10.1.
[native-inputs]: Use new style.
---
gnu/packages/assembly.scm | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index b2830716e1..534cffd7df 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -342,7 +342,7 @@ package for the Game Boy and Game Boy Color. It consists of:
(define-public wla-dx
(package
(name "wla-dx")
- (version "9.12")
+ (version "10.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -351,10 +351,9 @@ package for the Game Boy and Game Boy Color. It consists of:
(file-name (git-file-name name version))
(sha256
(base32
- "1wlbqv2rgk9q6m9an1mi0i29250zl8lw7zipki2bbi9mczpyczli"))))
+ "1nh2k2xn5fj389gq68f3fxgrxakgn8c6dw2ffqay86s3706hac9w"))))
(build-system cmake-build-system)
- (native-inputs
- `(("sphinx" ,python-sphinx))) ; to generate man pages
+ (native-inputs (list python-sphinx)) ; to generate man pages
(arguments
`(#:tests? #f)) ; no tests
(home-page "https://github.com/vhelin/wla-dx")
--
2.30.2
M
M
Maxime Devos wrote on 17 May 2022 20:02
6594adb380aae45e285994fd609fde8858affcae.camel@telenet.be
Felix Gruber schreef op di 17-05-2022 om 17:24 [+0000]:
Toggle quote (2 lines)
>       `(#:tests? #f))                    ; no tests

10.1 appears to have lots of tests in

It looks like you can run them with run_tests.sh:


Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYoPjJRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7uWXAQDBhNytnwT0YvWiBKSJQA+/Fp51
f78h6Li/Uo9oXt/t6wD+IYYd3Nop4o0FSKyslRrb8mAoL/CMOPYXCCC2UplVAgM=
=ko0w
-----END PGP SIGNATURE-----


F
F
Felix Gruber wrote on 18 May 2022 19:28
1058e0a8-5965-a14d-f0ab-4baf64ac4715@posteo.net
Hi Maxime,

On 5/17/22 20:02, Maxime Devos wrote:
Toggle quote (10 lines)
> Felix Gruber schreef op di 17-05-2022 om 17:24 [+0000]:
>>       `(#:tests? #f))                    ; no tests
>
> 10.1 appears to have lots of tests in
> <https://github.com/vhelin/wla-dx/tree/v10.1/tests>.
>
> It looks like you can run them with run_tests.sh:
>
> https://github.com/vhelin/wla-dx/blob/master/run_tests.sh

Thanks for the hint. I'll send a new patch that uses this run_tests.sh
script in its 'check phase.

Kind regards,
Felix
F
F
Felix Gruber wrote on 18 May 2022 19:31
[PATCH v2] gnu: wla-dx: Update to 10.1.
(name . Felix Gruber)(address . felgru@posteo.net)
20220518173118.17979-1-felgru@posteo.net
* gnu/packages/assembly.scm (wla-dx): Update to 10.1.
[native-inputs]: Use new style.
[arguments]: Add custom 'check phase to run run_tests.sh.
---
gnu/packages/assembly.scm | 19 ++++++++++++++-----
1 file changed, 14 insertions(+), 5 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index b2830716e1..ca50b00a06 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -342,7 +343,7 @@ package for the Game Boy and Game Boy Color. It consists of:
(define-public wla-dx
(package
(name "wla-dx")
- (version "9.12")
+ (version "10.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -351,12 +352,20 @@ package for the Game Boy and Game Boy Color. It consists of:
(file-name (git-file-name name version))
(sha256
(base32
- "1wlbqv2rgk9q6m9an1mi0i29250zl8lw7zipki2bbi9mczpyczli"))))
+ "1nh2k2xn5fj389gq68f3fxgrxakgn8c6dw2ffqay86s3706hac9w"))))
(build-system cmake-build-system)
- (native-inputs
- `(("sphinx" ,python-sphinx))) ; to generate man pages
+ (native-inputs (list python-sphinx)) ; to generate man pages
(arguments
- `(#:tests? #f)) ; no tests
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'copy-tests-to-build-directory
+ (lambda _
+ (copy-recursively "../source/tests" "tests")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (let ((sh (which "sh")))
+ (when tests?
+ (invoke sh "../source/run_tests.sh"))))))))
(home-page "https://github.com/vhelin/wla-dx")
(synopsis "Assemblers for various processors")
(description "WLA DX is a set of tools to assemble assembly files to
--
2.30.2
L
L
Ludovic Courtès wrote on 29 May 2022 23:35
Re: bug#55485: [PATCH] gnu: wla-dx: Update to 10.1.
(name . Felix Gruber)(address . felgru@posteo.net)
87o7zg81jp.fsf_-_@gnu.org
Hi,

Felix Gruber <felgru@posteo.net> skribis:

Toggle quote (4 lines)
> * gnu/packages/assembly.scm (wla-dx): Update to 10.1.
> [native-inputs]: Use new style.
> [arguments]: Add custom 'check phase to run run_tests.sh.

Applied, thank you & thanks Maxime!

Ludo’.
Closed
?