[PATCH 0/2] Packaging kivymd

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Ryan Prior
Owner
unassigned
Submitted by
Ryan Prior
Severity
normal
R
R
Ryan Prior wrote on 8 May 2022 03:38
(address . guix-patches@gnu.org)
20220508013852.27922-1-rprior@protonmail.com
The kivymd package requires a major version bump of our python-kivy package, so I had to tweak a few things around. Hopefully that should not be disruptive; kivy doesn't have many dependencies in Guix. I tested that this kivy+kivymd work in practice, even though neither of their tests run in Guix due to heavy requirements.

Ryan Prior (2):
gnu: python-kivy: Update to 2.1.0.
gnu: Add python-kivymd.

gnu/packages/python-xyz.scm | 34 +++++++++++++++++++++++++++++++---
1 file changed, 31 insertions(+), 3 deletions(-)

--
2.36.0
R
R
Ryan Prior wrote on 8 May 2022 03:45
[PATCH 1/2] gnu: python-kivy: Update to 2.1.0.
(address . 55308@debbugs.gnu.org)
20220508014521.28894-1-rprior@protonmail.com
* gnu/packages/python-xyz.scm (python-kivy): Update to 2.1.0.
---
gnu/packages/python-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2861593edb..1ac2d67da9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17514,7 +17514,7 @@ (define-public python-kivy-garden
(define-public python-kivy
(package
(name "python-kivy")
- (version "1.10.1")
+ (version "2.1.0")
(source
(origin
(method url-fetch)
@@ -17522,7 +17522,7 @@ (define-public python-kivy
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1zzxjdp78hfjjiklzr82l4zwibwcq4j6kgicspqs6iyyfn5yisbw"))))
+ "1cq4djfn7h8560mvz94dydsldg2jpp5w9rby7nafgmbh7fxg65is"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; Tests require many optional packages
@@ -17532,7 +17532,7 @@ (define-public python-kivy
(lambda* (#:key inputs #:allow-other-keys)
(setenv "KIVY_SDL2_PATH"
(search-input-directory inputs "/include/SDL2"))))
- (add-before 'sanity-check 'set-home
+ (add-before 'build 'set-home
(lambda _
;; 'kivy/__init__.py' wants to create $HOME/.kivy.
(setenv "HOME" (getcwd)))))))
--
2.36.0
R
R
Ryan Prior wrote on 8 May 2022 03:45
[PATCH 2/2] gnu: Add python-kivymd.
(address . 55308@debbugs.gnu.org)
20220508014521.28894-2-rprior@protonmail.com
* gnu/packages/python-xyz.scm (python-kivymd): New symbol.
---
gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1ac2d67da9..dd9d71b89b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17552,6 +17552,34 @@ (define-public python-kivy
multitouch applications.")
(license license:expat)))

+(define-public python-kivymd
+ (package
+ (name "python-kivymd")
+ (version "0.104.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "kivymd" version))
+ (sha256
+ (base32 "04lwy6j0agrdwa4a6dl6qs97nx9ysmscmm8psvdzjpyj8aa1zg4p"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'sanity-check 'set-home
+ (lambda _
+ ;; 'kivy/__init__.py' wants to create $HOME/.kivy.
+ (setenv "HOME" (getcwd))))))) ; Tests require network
+ (propagated-inputs
+ (list python-kivy python-pillow python-pygments python-docutils python-kivy-garden))
+ (home-page "https://github.com/kivymd/KivyMD")
+ (synopsis "A collection of Material Design compliant widgets for use with Kivy")
+ (description
+ "This package provides Kivy widgets that approximate Google's Material
+Design spec without sacrificing ease of use or application performance.")
+ (license license:expat)))
+
(define-public python2-kivy
(package-with-python2 python-kivy))

--
2.36.0
L
L
Ludovic Courtès wrote on 20 May 2022 20:13
Re: bug#55308: [PATCH 0/2] Packaging kivymd
(name . Ryan Prior)(address . rprior@protonmail.com)(address . 55308-done@debbugs.gnu.org)
87h75kxebj.fsf_-_@gnu.org
Hello,

Ryan Prior <rprior@protonmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-kivymd): New symbol.

Applied both patches, with the changes below on this one (suggested by
‘guix lint’).

Thanks!

Ludo’.
Toggle diff (27 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 19daf8cd05..b8fd857fd6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18682,17 +18682,18 @@ (define-public python-kivymd
(base32 "04lwy6j0agrdwa4a6dl6qs97nx9ysmscmm8psvdzjpyj8aa1zg4p"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f
+ `(#:tests? #f ;tests require network
#:phases
(modify-phases %standard-phases
(add-before 'sanity-check 'set-home
(lambda _
;; 'kivy/__init__.py' wants to create $HOME/.kivy.
- (setenv "HOME" (getcwd))))))) ; Tests require network
+ (setenv "HOME" (getcwd)))))))
+ (native-inputs (list python-docutils))
(propagated-inputs
- (list python-kivy python-pillow python-pygments python-docutils python-kivy-garden))
+ (list python-kivy python-pillow python-pygments python-kivy-garden))
(home-page "https://github.com/kivymd/KivyMD")
- (synopsis "A collection of Material Design compliant widgets for use with Kivy")
+ (synopsis "Material Design compliant widgets for use with Kivy")
(description
"This package provides Kivy widgets that approximate Google's Material
Design spec without sacrificing ease of use or application performance.")
Closed
?