[PATCH] gnu: Add xkblayout.

  • Done
  • quality assurance status badge
Details
3 participants
  • Attila Lendvai
  • Ludovic Courtès
  • Maxime Devos
Owner
unassigned
Submitted by
Attila Lendvai
Severity
normal
A
A
Attila Lendvai wrote on 5 May 2022 18:46
(address . guix-patches@gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
20220505164658.4654-1-attila@lendvai.name
* gnu/packages/xdisorg.scm (xkblayout): New variable.
---
gnu/packages/xdisorg.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index d41c520962..b88f1b9445 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -387,6 +387,29 @@ (define-public xkb-switch
state.")
(license license:gpl3+)))
+(define-public xkblayout
+ ;; Upstream has no tags as of 2022-05-04
+ (let ((revision "0")
+ (commit "c0851b0f4bc9bc1a07240605baac8e50abe63fa8"))
+ (package
+ (name "xkblayout")
+ (version (string-append "0.0.0-" revision "-" (substring commit 0 7)))
+ (home-page "https://gitlab.freedesktop.org/whot/xkblayout")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0057988l5l7pmwg7dp6cqvj5l4lr0g5z3wq189g6kz36l9rmh675"))))
+ (build-system python-build-system)
+ (synopsis "XKB layout template generator")
+ (description "xkblayout is a CLI application to generate templates for
+a new XKB layout, either in the user's home directory or the system directory.")
+ (license license:gpl3+))))
+
(define-public xclip
(package
(name "xclip")
--
2.35.1
M
M
Maxime Devos wrote on 5 May 2022 19:18
9c79815f59e5e354d03242401099c7f5d4dfc766.camel@telenet.be
Attila Lendvai schreef op do 05-05-2022 om 18:46 [+0200]:
Toggle quote (5 lines)
> +(define-public xkblayout
> +  ;; Upstream has no tags as of 2022-05-04
> +  (let ((revision "0")
> +        (commit "c0851b0f4bc9bc1a07240605baac8e50abe63fa8"))

I don't think the lack of tags matters, what relevant is whether there
is some kind of version number system. So I'd go for

;; Upstream doesn't have any version numbers

However, upstream does have versions:


... but it's an old version, so maybe upstream could be asked if it's a
’good’ version?

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYnQG/xccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7uLOAP0Y8YCe1Bsxx19TC6fQ+0M9yoKb
bGZD4CuYNqzZaGKQ8QD+PV7WgzdKUSAi6I/D+IhwZENpPQ+83MvKjqBPElxVeQk=
=boMo
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 5 May 2022 19:19
9c3363c446724a055ad9314b37257398bf50418d.camel@telenet.be
Attila Lendvai schreef op do 05-05-2022 om 18:46 [+0200]:
Toggle quote (2 lines)
> +      (version (string-append "0.0.0-" revision "-" (substring commit 0 7)))

'git-version'?
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYnQHDRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7phfAQDCT2Ey67OTRnCS/TtVMYIJ3Wa0
xHVVu+piAUr5nFJSvwD+PSD7Zc8NLCFrdilsQ08YXH/iDgYeAf6Woam3jgK/ugY=
=CP2m
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 5 May 2022 19:19
b2589094b0919baab39809b1c689e20bace48b04.camel@telenet.be
Attila Lendvai schreef op do 05-05-2022 om 18:46 [+0200]:
Toggle quote (2 lines)
> +      (license license:gpl3+))))

xkblayout.py says otherwise (some kind of BSD maybe?)

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYnQHPRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7tMqAQDc5hkRWHStI86rfdAzGX0n9u1E
ihMOLTyhUG0XVaoIzAD/eOUaNeB2DsSgkUUrIdT4K+sbK9iPqobGP0KJBZxI3QY=
=QJuI
-----END PGP SIGNATURE-----


A
A
Attila Lendvai wrote on 6 May 2022 08:22
[PATCH v2] gnu: Add xkblayout.
(address . 55276@debbugs.gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
20220506062254.8926-1-attila@lendvai.name
* gnu/packages/xdisorg.scm (xkblayout): New variable.
---

i've addressed the issues i could, but i'm not sure anymore
whether this should be packaged for Guix at all. maybe
people should just clone the repo and run it from there?

feel free to reject it.

either way, i've requested some clarifications:


licensing is contradictory, COPYING says GPL.

gnu/packages/xdisorg.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index d41c520962..08f4780fc2 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -387,6 +387,30 @@ (define-public xkb-switch
state.")
(license license:gpl3+)))
+(define-public xkblayout
+ ;; Upstream doesn't have any version numbers
+ (let ((version "0.0.0")
+ (revision "0")
+ (commit "c0851b0f4bc9bc1a07240605baac8e50abe63fa8"))
+ (package
+ (name "xkblayout")
+ (version (git-version version revision commit))
+ (home-page "https://gitlab.freedesktop.org/whot/xkblayout")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0057988l5l7pmwg7dp6cqvj5l4lr0g5z3wq189g6kz36l9rmh675"))))
+ (build-system python-build-system)
+ (synopsis "XKB layout template generator")
+ (description "xkblayout is a CLI application to generate templates for
+a new XKB layout, either in the user's home directory or the system directory.")
+ (license license:gpl3+))))
+
(define-public xclip
(package
(name "xclip")
--
2.35.1
M
M
Maxime Devos wrote on 6 May 2022 14:19
711b784aa512cdffbfbeb8a78b07eaa02ba86cbe.camel@telenet.be
Attila Lendvai schreef op vr 06-05-2022 om 08:22 [+0200]:
Toggle quote (5 lines)
> +  ;; Upstream doesn't have any version numbers
> +  (let ((version "0.0.0")
> +        (revision "0")
> +        (commit "c0851b0f4bc9bc1a07240605baac8e50abe63fa8"))

TBC I don't think this is a blocker, it's more of an ‘it would be
convenient to have them’ thing.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYnUSShccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7moMAP9OjnT7nk7qiJrKrXFXw/as5hdc
IsK9oTZ/XeD/IVz+PwD+PYwTUOuvTadOkpmXHeGglHOmaCvngWmk3rqxBQ1sLQ0=
=mBta
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 6 May 2022 14:21
41b846a7334c0638c8064c756abb6a9874b94950.camel@telenet.be
Attila Lendvai schreef op vr 06-05-2022 om 08:22 [+0200]:
Toggle quote (6 lines)
> * gnu/packages/xdisorg.scm (xkblayout): New variable.
> ---
>
> i've addressed the issues i could, but i'm not sure anymore
> whether this should be packaged for Guix at all.

I don't see why not, it's software and Guix is a software distribution
and some people create their own layouts. Though you can close the
debbugs issue if you want to.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYnUS5BccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7hJ3AQC3to1+VkxWYGbwjIN2wP5GP62n
w3zxpo5NlZEI8Qv2CQEA6CPEO2YHEpXnfFeciMCtLl3yxl32V5pl0CStkLsV6QU=
=ACRj
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 9 May 2022 12:06
Re: bug#55276: [PATCH] gnu: Add xkblayout.
(name . Attila Lendvai)(address . attila@lendvai.name)
87v8ufqatk.fsf_-_@gnu.org
Hi,

Attila Lendvai <attila@lendvai.name> skribis:

Toggle quote (2 lines)
> * gnu/packages/xdisorg.scm (xkblayout): New variable.

Applied, thanks! And thanks to Maxime for reviewing.

Ludo’.
Closed
?