[PATCH 0/3] Add python-madbg.

  • Done
  • quality assurance status badge
Details
3 participants
  • jgart
  • Maxim Cournoyer
  • Maxime Devos
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote on 2 May 2022 23:56
(name . Guix Patches)(address . guix-patches@gnu.org)
20220502215637.GB12175@gac.scls.local
Hi Guixers,


all best,

jgart

ps

above patches currently available as a pre-release from guixrus
J
J
jgart wrote on 3 May 2022 00:00
[PATCH 1/3] gnu: Add python-pyinjector.
(address . 55233@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20220502220026.13800-1-jgart@dismail.de
* gnu/packages/python-xyz.scm (python-pyinjector): New variable.
---
gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5b3a742cb7..453080a4b7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28981,6 +28981,26 @@ (define-public pudb
keyboard-friendly package.")
(license license:expat)))
+(define-public python-pyinjector
+ (package
+ (name "python-pyinjector")
+ (version "1.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyinjector" version ".zip"))
+ (sha256
+ (base32 "126n70qmrlqd25xmxwaf800abfm1k250zx01kx3dha2p6pk3vx89"))))
+ (build-system python-build-system)
+ (native-inputs (list unzip))
+ (home-page "https://github.com/kmaork/pyinjector")
+ (synopsis
+ "A tool/library allowing dynamic library injection into running processes")
+ (description
+ "This package provides a tool/library allowing dynamic library injection into
+running processes")
+ (license license:expat)))
+
(define-public python-iwlib
(package
(name "python-iwlib")
--
2.35.1
J
J
jgart wrote on 3 May 2022 00:00
[PATCH 2/3] gnu: Add python-hypno.
(address . 55233@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20220502220026.13800-2-jgart@dismail.de
* gnu/packages/python-xyz.scm (python-hypno): New variable.
---
gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 453080a4b7..61c36699c7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29001,6 +29001,27 @@ (define-public python-pyinjector
running processes")
(license license:expat)))
+(define-public python-hypno
+ (package
+ (name "python-hypno")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "hypno" version ".zip"))
+ (sha256
+ (base32 "1703c1k1g404sl2yvh5wylk7prnfgm7c83cpx2gv3n50025d6910"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-pyinjector))
+ (native-inputs (list unzip))
+ (home-page "https://github.com/kmaork/hypno")
+ (synopsis
+ "A tool/library allowing to inject python code into a running python process.")
+ (description
+ "This package provides a tool/library allowing to inject python code into a
+running python process.")
+ (license license:expat)))
+
(define-public python-iwlib
(package
(name "python-iwlib")
--
2.35.1
J
J
jgart wrote on 3 May 2022 00:00
[PATCH 3/3] gnu: Add python-madbg.
(address . 55233@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20220502220026.13800-3-jgart@dismail.de
* gnu/packages/python-xyz.scm (python-madbg): New variable.
---
gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 61c36699c7..551544b08e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29022,6 +29022,26 @@ (define-public python-hypno
running python process.")
(license license:expat)))
+(define-public python-madbg
+ (package
+ (name "python-madbg")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "madbg" version ".zip"))
+ (sha256
+ (base32 "19cll917w3zshxrcf2v5bdwkvbam3nslyik2hp4wpn5z4xkzsw5v"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-click python-hypno python-ipython python-prompt-toolkit))
+ (native-inputs (list unzip))
+ (home-page "https://github.com/kmaork/madbg")
+ (synopsis "A fully-featured remote debugger for python")
+ (description
+ "This package provides a fully-featured remote debugger for python")
+ (license license:expat)))
+
(define-public python-iwlib
(package
(name "python-iwlib")
--
2.35.1
J
J
jgart wrote on 3 May 2022 00:08
linter warning
(address . 55233@debbugs.gnu.org)
20220502220827.GB15953@gac.scls.local
Hi,

What's should I do to fix this one?

```
/home/jgart/973f231e-fd8e-47ce-bf3d-5f3baf22e411-guix/gnu/packages/python-xyz.scm:29026:2: python-madbg@1.2.0: propagated inputs python-prompt-toolkit@2.0.7 and python-prompt-toolkit@3.0.18 collide
```

all best,

jgart
M
M
Maxime Devos wrote on 3 May 2022 10:56
b1736aab04c6085001381b6d7bdb60ca3d9a15a6.camel@telenet.be
jgart via Guix-patches via schreef op ma 02-05-2022 om 22:08 [+0000]:
Toggle quote (7 lines)
> Hi,
>
> What's should I do to fix this one?
>
> ```
> /home/jgart/973f231e-fd8e-47ce-bf3d-5f3baf22e411-guix/gnu/packages/python-xyz.scm:29026:2: python-madbg@1.2.0: propagated inputs python-prompt-toolkit@2.0.7 and python-prompt-toolkit@3.0.18 collide

Determine which package has python-prompt-toolkit@2.0.7 and try
replacing it with python-prompt-toolkit@3.0.18 somehow
(for compatibility reasons, it might be necessary to update the package
using python-pprompt-toolkit@2.0.7).

These packages appear to be

* python-ipython
* python-jupyter-console

55104 has patches for updating ipythonand changes python-prompt-
toolkit@2 to python-prompt-toolkit@3, so it seems that the propagation
issue will be resolved by that patch series?

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYnDuMBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7osqAP4mfxV8/7A5uDZiRNoa9W6pojyB
fYS9oBXUHS72yaWliwD8DIY1xXPlBo+3GLa2W+IOEBT+9APHIWPvlhb/FKvraQ0=
=Oi+0
-----END PGP SIGNATURE-----


M
M
Maxim Cournoyer wrote on 24 Jun 2022 17:21
Re: bug#55233: [PATCH 0/3] Add python-madbg.
(name . jgart)(address . jgart@dismail.de)(address . 55233@debbugs.gnu.org)
87fsjuytmi.fsf_-_@gmail.com
Hi jgart,

jgart <jgart@dismail.de> writes:

Toggle quote (34 lines)
> * gnu/packages/python-xyz.scm (python-pyinjector): New variable.
> ---
> gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
> 1 file changed, 20 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 5b3a742cb7..453080a4b7 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -28981,6 +28981,26 @@ (define-public pudb
> keyboard-friendly package.")
> (license license:expat)))
>
> +(define-public python-pyinjector
> + (package
> + (name "python-pyinjector")
> + (version "1.0.6")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "pyinjector" version ".zip"))
> + (sha256
> + (base32 "126n70qmrlqd25xmxwaf800abfm1k250zx01kx3dha2p6pk3vx89"))))
> + (build-system python-build-system)
> + (native-inputs (list unzip))
> + (home-page "https://github.com/kmaork/pyinjector")
> + (synopsis
> + "A tool/library allowing dynamic library injection into running processes")
> + (description
> + "This package provides a tool/library allowing dynamic library injection into
> +running processes")
> + (license license:expat)))
> +

Please run this through 'guix lint', and fix any problems reported (the
synopsis will be flagged, at least). Your description should end with a
period (i.e., be a complete sentence).

I assume the test suite is not run; you may have to fetch from git to do
so, but there is a test suite:

Thanks,

Maxim
M
M
Maxim Cournoyer wrote on 24 Jun 2022 17:23
(name . jgart)(address . jgart@dismail.de)(address . 55233@debbugs.gnu.org)
87bkuiytiz.fsf_-_@gmail.com
Hi,

jgart <jgart@dismail.de> writes:

Toggle quote (34 lines)
> * gnu/packages/python-xyz.scm (python-hypno): New variable.
> ---
> gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
> 1 file changed, 21 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 453080a4b7..61c36699c7 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -29001,6 +29001,27 @@ (define-public python-pyinjector
> running processes")
> (license license:expat)))
>
> +(define-public python-hypno
> + (package
> + (name "python-hypno")
> + (version "0.1.4")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "hypno" version ".zip"))
> + (sha256
> + (base32 "1703c1k1g404sl2yvh5wylk7prnfgm7c83cpx2gv3n50025d6910"))))
> + (build-system python-build-system)
> + (propagated-inputs (list python-pyinjector))
> + (native-inputs (list unzip))
> + (home-page "https://github.com/kmaork/hypno")
> + (synopsis
> + "A tool/library allowing to inject python code into a running python process.")
> + (description
> + "This package provides a tool/library allowing to inject python code into a
> +running python process.")
> + (license license:expat)))

The package synopsis/description is the same as for pyinjector. Perhaps
it should say in the description that is based on it.

Otherwise, same comments as for python-pyinjector apply: run 'guix lint'
and fix any problem, and make sure the test suite is run [0].


Thanks,

Maxim
M
M
Maxim Cournoyer wrote on 24 Jun 2022 17:25
(name . jgart)(address . jgart@dismail.de)(address . 55233@debbugs.gnu.org)
877d56ytfm.fsf_-_@gmail.com
jgart <jgart@dismail.de> writes:

Toggle quote (33 lines)
> * gnu/packages/python-xyz.scm (python-madbg): New variable.
> ---
> gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
> 1 file changed, 20 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 61c36699c7..551544b08e 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -29022,6 +29022,26 @@ (define-public python-hypno
> running python process.")
> (license license:expat)))
>
> +(define-public python-madbg
> + (package
> + (name "python-madbg")
> + (version "1.2.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "madbg" version ".zip"))
> + (sha256
> + (base32 "19cll917w3zshxrcf2v5bdwkvbam3nslyik2hp4wpn5z4xkzsw5v"))))
> + (build-system python-build-system)
> + (propagated-inputs
> + (list python-click python-hypno python-ipython python-prompt-toolkit))
> + (native-inputs (list unzip))
> + (home-page "https://github.com/kmaork/madbg")
> + (synopsis "A fully-featured remote debugger for python")
> + (description
> + "This package provides a fully-featured remote debugger for python")
> + (license license:expat)))

Synopsis shouldn't start with determinant (run 'guix lint' to find out).
Description should end with period. I'd also capitalize "Python", since
it's a proper name.

Make sure the test suite is run [0].

Thanks!

M
M
Maxim Cournoyer wrote on 24 Jun 2022 17:25
control message for bug #55233
(address . control@debbugs.gnu.org)
875ykqytfh.fsf@gmail.com
tags 55233 + moreinfo
quit
J
J
jgart wrote on 7 Oct 2023 07:53
Closing
(address . 55233-done@debbugs.gnu.org)
800fbbff10acd393db8013109292e532@dismail.de
Hi,

I'm going to close this patch series I previously sent as won't do.

Feel free to re-open if anyone else wants to work on it.

all best,

jgart
Closed
?