[PATCH] gnu: zsh: Build and install info pages.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andrew Tropin
  • Thiago Jung Bauermann
  • Ludovic Courtès
Owner
unassigned
Submitted by
Andrew Tropin
Severity
normal
A
A
Andrew Tropin wrote on 25 Apr 2022 08:40
(address . guix-patches@gnu.org)
877d7dd2o5.fsf@trop.in
* gnu/packages/shells.scm (zsh)[arguments]: Build and install info pages.
---
gnu/packages/shells.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 3a48bc7dbf..7158a5bcfb 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021, 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -64,6 +65,7 @@ (define-module (gnu packages shells)
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
#:use-module (gnu packages xorg)
+ #:use-module (gnu packages texinfo)
#:use-module (guix build-system cargo)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
@@ -522,9 +524,13 @@ (define-public zsh
(("command -pv") "command -v")
(("command -p") "command ")
(("'command' -p") "'command' "))
- #t)))))
+ #t))
+ (add-after 'build 'make-info
+ (lambda _ (invoke "make" "info")))
+ (add-after 'build 'install-info
+ (lambda _ (invoke "make" "install.info"))))))
(native-inputs (list autoconf))
- (inputs (list ncurses pcre perl))
+ (inputs (list ncurses pcre perl texinfo))
(synopsis "Powerful shell for interactive use and scripting")
(description "The Z shell (zsh) is a Unix shell that can be used
as an interactive login shell and as a powerful command interpreter
--
2.35.1
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmJmUjsPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6wBQsP/1J0PFVyR3if6a+ryRndySFSfJ0Xe5Dt3X5R
kWeyEsSL4PMkdv0IhfafSHErTdrLLZrbFRoEK0pJxiEmSdSVucT9xK7Lay1F9xX7
JmxJG/XnLgiKLxgynB//0+skV1ZUrbtQBKsQO60lnKWrdUp3lxNkrnaX2/6ET6uY
Qp5ixuneZBL8lc6aXud2LMX4sS49+7CJeH8QzGJewmMkDHhqWmdSU1ylByF9PhxN
D6Q7J6KNLyhIzbOwx9k43PUAngMhj2dEexn7iWukPRNr5YURWsSslDsOy5TiVTzK
LjbApLeJYy0xuslYql/AlBocuCOI/gjePlXyMQv5znppZbmdQ8Q6EOL1yyUcvNRa
b/gRaY86NV5XkglMzK7fOSXa8JrlMwwTZzGgjJiGYFZYtWb2S8iGzlr9ck35MqYh
yYnYAJoescRe757r1h5a0f5fi9Olds3s0tDwGe0oQgF3orIWPJYpeFiFbHjTx5mK
U2uKOroUAPfDyHrzg+hHqul0GOZMDferL4TKyjNuJ3cVCm58/v8VLOTtci/rsoA/
vktmylC8/9Dqtfswcgki5DyptoimwL0+Q2AwC6qJ+P1chKxTv5Pu3vGLXjVH+lYw
CDar9mlMEAPidydp+Saa7WpO9dw0MeH/w8078J0LXLdGNMZW6qhFT5LE5er1lvLW
yN3udxbv
=o4s1
-----END PGP SIGNATURE-----

T
T
Thiago Jung Bauermann wrote on 27 Apr 2022 05:51
(name . Andrew Tropin)(address . andrew@trop.in)(address . 55107@debbugs.gnu.org)
87zgk718lz.fsf@kolabnow.com
Hello Andrew,

This looks great. Just a couple of comments:

Andrew Tropin <andrew@trop.in> writes:

Toggle quote (4 lines)
> [[PGP Signed Part:Undecided]]
>
> * gnu/packages/shells.scm (zsh)[arguments]: Build and install info pages.

The changelog should also mention the addition of texinfo to inputs (or
native inputs).

Toggle quote (7 lines)
> @@ -522,9 +524,13 @@ (define-public zsh
> (("command -pv") "command -v")
> (("command -p") "command ")
> (("'command' -p") "'command' "))
> - #t)))))
> + #t))

Phases don't need to return #t anymore, so this patch would be a nice
opportunity to remove it here.

Toggle quote (8 lines)
> + (add-after 'build 'make-info
> + (lambda _ (invoke "make" "info")))
> + (add-after 'build 'install-info
> + (lambda _ (invoke "make" "install.info"))))))
> (native-inputs (list autoconf))
> - (inputs (list ncurses pcre perl))
> + (inputs (list ncurses pcre perl texinfo))

texinfo is a tool executed during the build process itself, so it should
be listed in native-inputs to allow cross-compilation.

--
Thanks
Thiago
L
L
Ludovic Courtès wrote on 29 Apr 2022 14:54
Re: bug#55107: [PATCH] gnu: zsh: Build and install info pages.
(name . Thiago Jung Bauermann)(address . bauermann@kolabnow.com)
87h76c82yd.fsf_-_@gnu.org
Hi,

Thiago Jung Bauermann <bauermann@kolabnow.com> skribis:

Toggle quote (8 lines)
> This looks great. Just a couple of comments:
>
> Andrew Tropin <andrew@trop.in> writes:
>
>> [[PGP Signed Part:Undecided]]
>>
>> * gnu/packages/shells.scm (zsh)[arguments]: Build and install info pages.

Applied with the changes Thiago suggested.

Thanks!

Ludo’.
Closed
A
A
Andrew Tropin wrote on 2 May 2022 14:14
Re: bug#55107: closed (Re: bug#55107: [PATCH] gnu: zsh: Build and install info pages.)
(address . 55107@debbugs.gnu.org)
871qxc872v.fsf@trop.in
On 2022-04-29 12:55, GNU bug Tracking System wrote:

Toggle quote (33 lines)
> Your bug report
>
> #55107: [PATCH] gnu: zsh: Build and install info pages.
>
> which was filed against the guix-patches package, has been closed.
>
> The explanation is attached below, along with your original report.
> If you require more details, please reply to 55107@debbugs.gnu.org.
>
> --
> 55107: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=55107
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
> From: Ludovic Courtès <ludo@gnu.org>
> Subject: Re: bug#55107: [PATCH] gnu: zsh: Build and install info pages.
> To: Thiago Jung Bauermann <bauermann@kolabnow.com>
> Cc: 55107-done@debbugs.gnu.org, Andrew Tropin <andrew@trop.in>
> Date: Fri, 29 Apr 2022 14:54:34 +0200
>
> Hi,
>
> Thiago Jung Bauermann <bauermann@kolabnow.com> skribis:
>
>> This looks great. Just a couple of comments:
>>
>> Andrew Tropin <andrew@trop.in> writes:
>>
>>> [[PGP Signed Part:Undecided]]
>>>
>>> * gnu/packages/shells.scm (zsh)[arguments]: Build and install info pages.
>
> Applied with the changes Thiago suggested.

Thank you very much!

Toggle quote (53 lines)
>
> Thanks!
>
> Ludo’.
>
> From: Andrew Tropin <andrew@trop.in>
> Subject: [PATCH] gnu: zsh: Build and install info pages.
> To: guix-patches@gnu.org
> Date: Mon, 25 Apr 2022 09:40:02 +0300
>
>
> * gnu/packages/shells.scm (zsh)[arguments]: Build and install info pages.
> ---
> gnu/packages/shells.scm | 10 ++++++++--
> 1 file changed, 8 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
> index 3a48bc7dbf..7158a5bcfb 100644
> --- a/gnu/packages/shells.scm
> +++ b/gnu/packages/shells.scm
> @@ -19,6 +19,7 @@
> ;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
> ;;; Copyright © 2021, 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
> ;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
> +;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -64,6 +65,7 @@ (define-module (gnu packages shells)
> #:use-module (gnu packages tls)
> #:use-module (gnu packages version-control)
> #:use-module (gnu packages xorg)
> + #:use-module (gnu packages texinfo)
> #:use-module (guix build-system cargo)
> #:use-module (guix build-system cmake)
> #:use-module (guix build-system gnu)
> @@ -522,9 +524,13 @@ (define-public zsh
> (("command -pv") "command -v")
> (("command -p") "command ")
> (("'command' -p") "'command' "))
> - #t)))))
> + #t))
> + (add-after 'build 'make-info
> + (lambda _ (invoke "make" "info")))
> + (add-after 'build 'install-info
> + (lambda _ (invoke "make" "install.info"))))))
> (native-inputs (list autoconf))
> - (inputs (list ncurses pcre perl))
> + (inputs (list ncurses pcre perl texinfo))
> (synopsis "Powerful shell for interactive use and scripting")
> (description "The Z shell (zsh) is a Unix shell that can be used
> as an interactive login shell and as a powerful command interpreter

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmJvyygPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6wQuIP/RgLviB/eg6vbGlzXz9cHoAxM/FVYhLLF1P4
0jMK4EZ2N9CSDKlm+Tmh2oB+KkXDCMLr8Iy6jRN1nb/JxTCh0EBmoStaLsqtQSg6
y4yQ9H/nzmdvNm1SxIwII+iUPw/j7DrG8VZMxI1NRmWRizHiw823hkK1f7KvBCQq
jClfIcjfxiPDSeMUINXL/ICvZg0gM6h4DXpAHHn62gloHCQ00Nf5tSkctzGgkdcu
6sjfSrjUw3gN7/H5506EtOsqGFeBtqNP0decBYPsvRXCDEpC+bku7fASOJChzZI7
1l0IMEh6ecC+s4pcSs8UNIDjA/6RwO7zqcO3js6vqC0YoKLHauaDSelHPoBWY2jq
9oB3lQ6arX+NCubHp5VlYQqD2u4MB760cthbzOoV5NIE/srxPQGdqEN3Lx/N/u6Z
nNw4pseKhga0VSP9y+FOhT6EDlxQKQzFdiR2s51RPQD4/kbUzOS4QW4rHRn30JT9
4U5B0pEpM7TRUdpKXOIkvAXdJOzv1w89NtLWj2I5nkqkMyqMr9omfSHogWNOgk+1
xRrjqAGHmae7vl+YKYmJ9kVRZ3LSKdmx/98UxyoX3RZTEdBHqKR8QxWsAWwHS0/A
ILuYq6ozHmluXOPukdKYNFevLb8iFnqsrewuX212Zf3d6doesP0hU98c8WryRATg
bnnWzIr5
=PlpJ
-----END PGP SIGNATURE-----

?