[PATCH v1] Allow Guix root-dir overrides when working via Tramp.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brian Cully
  • Leo Famulari
Owner
unassigned
Submitted by
Brian Cully
Severity
normal
B
B
Brian Cully wrote on 23 Apr 2022 18:17
(address . guix-patches@gnu.org)
87fsm3kc2m.fsf@ditto.jhoto.spork.org
Add only the local part of the root directory to the guile search
path. This lets you use Tramp to hack on a remote Guix checkout.
---
.dir-locals.el | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/.dir-locals.el b/.dir-locals.el
index 09e19223d5..3b75989133 100644
--- a/.dir-locals.el
+++ b/.dir-locals.el
@@ -29,7 +29,7 @@
;; Hence the following "when", which might otherwise be unnecessary;
;; it prevents causing an error when root-dir-unexpanded is nil.
(when root-dir-unexpanded
- (let* ((root-dir (expand-file-name root-dir-unexpanded))
+ (let* ((root-dir (file-local-name (expand-file-name root-dir-unexpanded)))
;; Workaround for bug https://issues.guix.gnu.org/43818.
(root-dir* (directory-file-name root-dir)))

base-commit: 8540c2d86ca535ceb188c838cf1885de6f65c94f
--
2.35.1
B
B
Brian Cully wrote on 21 May 2022 21:10
[PATCH v2] Allow Guix root-dir overrides when working via Tramp.
(address . 55081@debbugs.gnu.org)(name . Brian Cully)(address . bjc@kublai.com)
5eb3a6b7718bb1f3959afd27f051f744c9d677f6.1653160223.git.bjc@spork.org
From: Brian Cully <bjc@kublai.com>

Add only the local part of the root directory to the guile search
path. This lets you use Tramp to hack on a remote Guix checkout.
---
I think my last patch was mangled by GNUS, so I'm resending it.

FWIW, I've been using this for months without issue.
.dir-locals.el | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/.dir-locals.el b/.dir-locals.el
index 09e19223d5..3b75989133 100644
--- a/.dir-locals.el
+++ b/.dir-locals.el
@@ -29,7 +29,7 @@
;; Hence the following "when", which might otherwise be unnecessary;
;; it prevents causing an error when root-dir-unexpanded is nil.
(when root-dir-unexpanded
- (let* ((root-dir (expand-file-name root-dir-unexpanded))
+ (let* ((root-dir (file-local-name (expand-file-name root-dir-unexpanded)))
;; Workaround for bug https://issues.guix.gnu.org/43818.
(root-dir* (directory-file-name root-dir)))
--
2.36.1
L
L
Leo Famulari wrote on 5 Mar 2023 20:06
(name . Brian Cully via Guix-patches via)(address . guix-patches@gnu.org)
ZAToLPZGFaQ5DSUw@jasmine.lan
On Sat, May 21, 2022 at 03:10:24PM -0400, Brian Cully via Guix-patches via wrote:
Toggle quote (9 lines)
> From: Brian Cully <bjc@kublai.com>
>
> Add only the local part of the root directory to the guile search
> path. This lets you use Tramp to hack on a remote Guix checkout.
> ---
> I think my last patch was mangled by GNUS, so I'm resending it.
>
> FWIW, I've been using this for months without issue.

Okay, pushed as cedf97ed6ee4eba8c39bfe6cc0efe33fcb977ccf

Thanks!
?