[PATCH] gnu: Add python-mike.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Vincent Prat
Owner
unassigned
Submitted by
Vincent Prat
Severity
normal
V
V
Vincent Prat wrote on 22 Apr 2022 10:22
(address . guix-patches@gnu.org)
CAH9Ak7KnD2jbL2CpospmHpw+Yg6cOm+Yfd2JwT+q2hBbeXHttA@mail.gmail.com

From f0f1d95aa2047ae153dd7566e770f04f2f8bee18 Mon Sep 17 00:00:00 2001
From: Vincent Prat <vprat@deeplinks.com>
Date: Fri, 22 Apr 2022 10:15:59 +0200
Subject: [PATCH] gnu: Add python-mike.

* gnu/packages/python-xyz.scm (python-mike): New variable.
---
gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9a5d311680..942611acd7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29534,3 +29534,25 @@ match a given regular expression, or count possible matches efficiently. It
uses the parsed regular expression, so you get a much more accurate result
than trying to just split strings.")
(license license:asl2.0)))
+
+(define-public python-mike
+ (package
+ (name "python-mike")
+ (version "1.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "mike" version))
+ (sha256
+ (base32
+ "0yxp816x7s948xsd0fifvq9shg01xdxlifd9rzf5y2rd9iwz3hsn"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-jinja2 python-mkdocs python-pyyaml
+ python-verspec))
+ (native-inputs (list python-coverage python-flake8 python-shtab))
+ (home-page "https://github.com/jimporter/mike")
+ (synopsis "Manage multiple versions of MkDocs-powered documentation")
+ (description
+ "This package provides a Python utility to easily deploy multiple versions
+of MkDocs-powered docs to a Git branch. It is suitable for deploying to Github
+via gh-pages.")
+ (license license:bsd-3)))
--
2.30.2
M
M
Mathieu Othacehe wrote on 27 Apr 2022 11:28
(name . Vincent Prat)(address . vprat@deeplinks.com)(address . 55061-done@debbugs.gnu.org)
871qxilvs6.fsf@gnu.org
Pushed, with minor edits,

Thanks,

Mathieu
Closed
?